Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1413273 > unrolled thread
| Started by | Jens Axboe <axboe@kernel.dk> |
|---|---|
| First post | 2016-06-03 16:40 +0200 |
| Last post | 2016-06-06 07:10 +0200 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [RFC v2 1/3] block: Introduce blk_bio_map_sg() to map one bio Jens Axboe <axboe@kernel.dk> - 2016-06-03 16:40 +0200
Re: [RFC v2 1/3] block: Introduce blk_bio_map_sg() to map one bio Baolin Wang <baolin.wang@linaro.org> - 2016-06-06 07:10 +0200
| From | Jens Axboe <axboe@kernel.dk> |
|---|---|
| Date | 2016-06-03 16:40 +0200 |
| Subject | Re: [RFC v2 1/3] block: Introduce blk_bio_map_sg() to map one bio |
| Message-ID | <rFYqt-4lp-5@gated-at.bofh.it> |
On 05/27/2016 05:11 AM, Baolin Wang wrote: > In dm-crypt, it need to map one bio to scatterlist for improving the > hardware engine encryption efficiency. Thus this patch introduces the > blk_bio_map_sg() function to map one bio with scatterlists. > > For avoiding the duplicated code in __blk_bios_map_sg() function, add > one parameter to distinguish bio map or request map. Just detach the bio in blk_bio_map_sg() instead of adding a separate case (and argument) for it in __blk_bios_map_sg(). -- Jens Axboe
[toc] | [next] | [standalone]
| From | Baolin Wang <baolin.wang@linaro.org> |
|---|---|
| Date | 2016-06-06 07:10 +0200 |
| Message-ID | <rGUXw-u6-9@gated-at.bofh.it> |
| In reply to | #1413273 |
On 3 June 2016 at 22:35, Jens Axboe <axboe@kernel.dk> wrote: > On 05/27/2016 05:11 AM, Baolin Wang wrote: >> >> In dm-crypt, it need to map one bio to scatterlist for improving the >> hardware engine encryption efficiency. Thus this patch introduces the >> blk_bio_map_sg() function to map one bio with scatterlists. >> >> For avoiding the duplicated code in __blk_bios_map_sg() function, add >> one parameter to distinguish bio map or request map. > > > Just detach the bio in blk_bio_map_sg() instead of adding a separate case > (and argument) for it in __blk_bios_map_sg(). Make sense. > > -- > Jens Axboe > -- Baolin.wang Best Regards
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web