Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1403740 > unrolled thread
| Started by | Andy Shevchenko <andriy.shevchenko@linux.intel.com> |
|---|---|
| First post | 2016-05-19 15:30 +0200 |
| Last post | 2016-05-24 13:00 +0200 |
| Articles | 2 — 1 participant |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [PATCH v2 2/2] ASoC: da7219: Convert driver to use generic device/fwnode functions Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2016-05-19 15:30 +0200
Re: [PATCH v2 2/2] ASoC: da7219: Convert driver to use generic device/fwnode functions Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2016-05-24 13:00 +0200
| From | Andy Shevchenko <andriy.shevchenko@linux.intel.com> |
|---|---|
| Date | 2016-05-19 15:30 +0200 |
| Subject | Re: [PATCH v2 2/2] ASoC: da7219: Convert driver to use generic device/fwnode functions |
| Message-ID | <rAwbw-kQ-33@gated-at.bofh.it> |
On Tue, 2016-05-17 at 11:28 +0100, Adam Thomson wrote:
> This change converts the driver from using the of_* functions to using
> the device_* and fwnode_* functions for accssing FW related data.
>
> Signed-off-by: Adam Thomson <Adam.Thomson.Opensource@diasemi.com>
> Tested-by: Sathyanarayana Nujella <sathyanarayana.nujella@intel.com>
@@ -538,97 +538,96 @@ static enum da7219_aad_adc_1bit_rpt
> }
> }
>
> -static struct da7219_aad_pdata *da7219_aad_of_to_pdata(struct
> snd_soc_codec *codec)
> +static struct da7219_aad_pdata *da7219_aad_fw_to_pdata(struct
> snd_soc_codec *codec)
> {
> - struct device_node *np = codec->dev->of_node;
> - struct device_node *aad_np = of_find_node_by_name(np,
> "da7219_aad");
> + struct device *dev = codec->dev;
> + struct i2c_client *i2c = to_i2c_client(dev);
> + struct fwnode_handle *aad_np =
> + device_get_named_child_node(dev, "da7219_aad");
I would suggest to do an assignment below...
> struct da7219_aad_pdata *aad_pdata;
> - const char *of_str;
> - u32 of_val32;
> + const char *fw_str;
> + u32 fw_val32;
>
...right here.
Same amount of LOC, but less difficult to see from where aad_np comes.
> if (!aad_np)
> return NULL;
>
> @@ -769,9 +768,9 @@ int da7219_aad_init(struct snd_soc_codec *codec)
> da7219->aad = da7219_aad;
> da7219_aad->codec = codec;
>
> - /* Handle any DT/platform data */
> - if ((codec->dev->of_node) && (da7219->pdata))
> - da7219->pdata->aad_pdata =
> da7219_aad_of_to_pdata(codec);
> + /* Handle any DT/ACPI/platform data */
> + if ((da7219->pdata) && (!da7219->pdata->aad_pdata))
Redundant parens, twice.
--
Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Intel Finland Oy
[toc] | [next] | [standalone]
| From | Andy Shevchenko <andriy.shevchenko@linux.intel.com> |
|---|---|
| Date | 2016-05-24 13:00 +0200 |
| Message-ID | <rCie6-2bW-19@gated-at.bofh.it> |
| In reply to | #1403740 |
On Mon, 2016-05-23 at 22:53 +0000, Opensource [Adam Thomson] wrote:
> On May 19, 2015 14:28, Andy Shevchenko wrote:
>
> > > -static struct da7219_aad_pdata *da7219_aad_of_to_pdata(struct
> > > snd_soc_codec *codec)
> > > +static struct da7219_aad_pdata *da7219_aad_fw_to_pdata(struct
> > > snd_soc_codec *codec)
> > > {
> > > - struct device_node *np = codec->dev->of_node;
> > > - struct device_node *aad_np = of_find_node_by_name(np,
> > > "da7219_aad");
> > > + struct device *dev = codec->dev;
> > > + struct i2c_client *i2c = to_i2c_client(dev);
> > > + struct fwnode_handle *aad_np =
> > > + device_get_named_child_node(dev, "da7219_aad");
> >
> > I would suggest to do an assignment below...
> >
> > > struct da7219_aad_pdata *aad_pdata;
> > > - const char *of_str;
> > > - u32 of_val32;
> > > + const char *fw_str;
> > > + u32 fw_val32;
> > >
> >
> >
> > ...right here.
> > Same amount of LOC, but less difficult to see from where aad_np
> > comes.
> >
> > > if (!aad_np)
> > > return NULL;
> > >
>
> To be fair the allocation of 'aad_np' is only a few lines above so
> this really
> doesn't seem to make much difference in my opinion. It really
> shouldn't be hard
> for someone to spot where it's allocated.
Better to have it exactly before check. Just a readability and future
maintenance. (Someone might insert something in between, and a matter of
fact already did)
Though I agree this is minor.
>
> > > @@ -769,9 +768,9 @@ int da7219_aad_init(struct snd_soc_codec
> > > *codec)
> > > da7219->aad = da7219_aad;
> > > da7219_aad->codec = codec;
> > >
> > > - /* Handle any DT/platform data */
> > > - if ((codec->dev->of_node) && (da7219->pdata))
> > > - da7219->pdata->aad_pdata =
> > > da7219_aad_of_to_pdata(codec);
> > > + /* Handle any DT/ACPI/platform data */
> > > + if ((da7219->pdata) && (!da7219->pdata->aad_pdata))
> >
> > Redundant parens, twice.
>
> Not essential, but looks cleaner to me. Unless there's a real demand
> to change,
> I'd like to leave this as is.
It's really unusual pattern and doesn't add any value
Compare
if ((da7219->pdata) && (!da7219->pdata->aad_pdata))
to
if (da7219->pdata && !da7219->pdata->aad_pdata)
Latter looks cleaner.
--
Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Intel Finland Oy
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web