Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1402653 > unrolled thread

[PATCH 1/1] iwlwifi: rs: remove superfluous check

Started byHeinrich Schuchardt <xypron.glpk@gmx.de>
First post2016-05-18 01:40 +0200
Last post2016-05-19 10:30 +0200
Articles 2 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH 1/1] iwlwifi: rs: remove superfluous check Heinrich Schuchardt <xypron.glpk@gmx.de> - 2016-05-18 01:40 +0200
    Re: [PATCH 1/1] iwlwifi: rs: remove superfluous check "Coelho, Luciano" <luciano.coelho@intel.com> - 2016-05-19 10:30 +0200

#1402653 — [PATCH 1/1] iwlwifi: rs: remove superfluous check

FromHeinrich Schuchardt <xypron.glpk@gmx.de>
Date2016-05-18 01:40 +0200
Subject[PATCH 1/1] iwlwifi: rs: remove superfluous check
Message-ID<rzWKJ-2DG-5@gated-at.bofh.it>
If we dereference a variable anyway in other parts of the code,
there is no need to check against NULL in a single place.

Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
---
 drivers/net/wireless/intel/iwlwifi/mvm/rs.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/net/wireless/intel/iwlwifi/mvm/rs.c b/drivers/net/wireless/intel/iwlwifi/mvm/rs.c
index 81dd2f6..bab01ea 100644
--- a/drivers/net/wireless/intel/iwlwifi/mvm/rs.c
+++ b/drivers/net/wireless/intel/iwlwifi/mvm/rs.c
@@ -2867,7 +2867,7 @@ static void rs_get_rate(void *mvm_r, struct ieee80211_sta *sta, void *mvm_sta,
 	/* TODO: handle rate_idx_mask and rate_idx_mcs_mask */
 
 	/* Treat uninitialized rate scaling data same as non-existing. */
-	if (lq_sta && !lq_sta->pers.drv) {
+	if (!lq_sta->pers.drv) {
 		IWL_DEBUG_RATE(mvm, "Rate scaling not initialized yet.\n");
 		mvm_sta = NULL;
 	}
-- 
2.1.4

[toc] | [next] | [standalone]


#1403495

From"Coelho, Luciano" <luciano.coelho@intel.com>
Date2016-05-19 10:30 +0200
Message-ID<rArvb-5HV-7@gated-at.bofh.it>
In reply to#1402653
On Wed, 2016-05-18 at 01:31 +0200, Heinrich Schuchardt wrote:
> If we dereference a variable anyway in other parts of the code,
> there is no need to check against NULL in a single place.

NACK.  This is not true.

If lq_sta is NULL, it means that mvm_sta is also NULL.  Then we call
the rate_control_send with mvm_sta == NULL:

	if (rate_control_send_low(sta, mvm_sta, txrc))
		return;

The rate_control_send_low() function looks like this:


bool rate_control_send_low(struct ieee80211_sta *pubsta,
			   void *priv_sta,
			   struct ieee80211_tx_rate_control *txrc)
{
[...]
	if (!pubsta || !priv_sta || rc_no_data_or_no_ack_use_min(txrc)) {
[...]
		return true;
	}
[...]
}


Which means that if priv_sta (aka mvm_sta) is NULL, we will return
without running the rest of rs_get_rate() where lq_sta is accessed
without checks.

I admit that the rs_get_rate() function is a bit hard to read, but
removing the lq_sta check as you did doesn't help, but makes things
worse.

--
Cheers,
Luca.

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web