Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1402238 > unrolled thread

[PATCH 05/14] staging: comedi: daqboard2000: rename serial EEPROM register macros

Started byIan Abbott <abbotti@mev.co.uk>
First post2016-05-17 12:00 +0200
Last post2016-05-18 12:30 +0200
Articles 3 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  [PATCH 05/14] staging: comedi: daqboard2000: rename serial EEPROM register macros Ian Abbott <abbotti@mev.co.uk> - 2016-05-17 12:00 +0200
    RE: [PATCH 05/14] staging: comedi: daqboard2000: rename serial EEPROM  register macros Hartley Sweeten <HartleyS@visionengravers.com> - 2016-05-17 19:30 +0200
      Re: [PATCH 05/14] staging: comedi: daqboard2000: rename serial EEPROM  register macros Ian Abbott <abbotti@mev.co.uk> - 2016-05-18 12:30 +0200

#1402238 — [PATCH 05/14] staging: comedi: daqboard2000: rename serial EEPROM register macros

FromIan Abbott <abbotti@mev.co.uk>
Date2016-05-17 12:00 +0200
Subject[PATCH 05/14] staging: comedi: daqboard2000: rename serial EEPROM register macros
Message-ID<rzJXg-2UD-7@gated-at.bofh.it>
Rename the macros defining values for the Serial EEPROM Control Register
to avoid CamelCase.

Signed-off-by: Ian Abbott <abbotti@mev.co.uk>
---
 drivers/staging/comedi/drivers/daqboard2000.c | 26 +++++++++++++-------------
 1 file changed, 13 insertions(+), 13 deletions(-)

diff --git a/drivers/staging/comedi/drivers/daqboard2000.c b/drivers/staging/comedi/drivers/daqboard2000.c
index fde0924..b3b68e8 100644
--- a/drivers/staging/comedi/drivers/daqboard2000.c
+++ b/drivers/staging/comedi/drivers/daqboard2000.c
@@ -116,12 +116,12 @@
 #define DAQBOARD2000_SUBSYSTEM_IDS4	0x0004	/* Daqboard/2000 - 4 Dacs */
 
 /* Initialization bits for the Serial EEPROM Control Register */
-#define DAQBOARD2000_SECRProgPinHi      0x8001767e
-#define DAQBOARD2000_SECRProgPinLo      0x8000767e
-#define DAQBOARD2000_SECRLocalBusHi     0xc000767e
-#define DAQBOARD2000_SECRLocalBusLo     0x8000767e
-#define DAQBOARD2000_SECRReloadHi       0xa000767e
-#define DAQBOARD2000_SECRReloadLo       0x8000767e
+#define DAQBOARD2000_SECR_PROG_PIN_HI	0x8001767e
+#define DAQBOARD2000_SECR_PROG_PIN_LO	0x8000767e
+#define DAQBOARD2000_SECR_LOCAL_BUS_HI	0xc000767e
+#define DAQBOARD2000_SECR_LOCAL_BUS_LO	0x8000767e
+#define DAQBOARD2000_SECR_RELOAD_HI	0xa000767e
+#define DAQBOARD2000_SECR_RELOAD_LO	0x8000767e
 
 /* SECR status bits */
 #define DAQBOARD2000_EEPROM_PRESENT     0x10000000
@@ -438,9 +438,9 @@ static void daqboard2000_resetLocalBus(struct comedi_device *dev)
 {
 	struct daqboard2000_private *devpriv = dev->private;
 
-	writel(DAQBOARD2000_SECRLocalBusHi, devpriv->plx + 0x6c);
+	writel(DAQBOARD2000_SECR_LOCAL_BUS_HI, devpriv->plx + 0x6c);
 	mdelay(10);
-	writel(DAQBOARD2000_SECRLocalBusLo, devpriv->plx + 0x6c);
+	writel(DAQBOARD2000_SECR_LOCAL_BUS_LO, devpriv->plx + 0x6c);
 	mdelay(10);
 }
 
@@ -448,11 +448,11 @@ static void daqboard2000_reloadPLX(struct comedi_device *dev)
 {
 	struct daqboard2000_private *devpriv = dev->private;
 
-	writel(DAQBOARD2000_SECRReloadLo, devpriv->plx + 0x6c);
+	writel(DAQBOARD2000_SECR_RELOAD_LO, devpriv->plx + 0x6c);
 	mdelay(10);
-	writel(DAQBOARD2000_SECRReloadHi, devpriv->plx + 0x6c);
+	writel(DAQBOARD2000_SECR_RELOAD_HI, devpriv->plx + 0x6c);
 	mdelay(10);
-	writel(DAQBOARD2000_SECRReloadLo, devpriv->plx + 0x6c);
+	writel(DAQBOARD2000_SECR_RELOAD_LO, devpriv->plx + 0x6c);
 	mdelay(10);
 }
 
@@ -460,9 +460,9 @@ static void daqboard2000_pulseProgPin(struct comedi_device *dev)
 {
 	struct daqboard2000_private *devpriv = dev->private;
 
-	writel(DAQBOARD2000_SECRProgPinHi, devpriv->plx + 0x6c);
+	writel(DAQBOARD2000_SECR_PROG_PIN_HI, devpriv->plx + 0x6c);
 	mdelay(10);
-	writel(DAQBOARD2000_SECRProgPinLo, devpriv->plx + 0x6c);
+	writel(DAQBOARD2000_SECR_PROG_PIN_LO, devpriv->plx + 0x6c);
 	mdelay(10);	/* Not in the original code, but I like symmetry... */
 }
 
-- 
2.8.1

[toc] | [next] | [standalone]


#1402490 — RE: [PATCH 05/14] staging: comedi: daqboard2000: rename serial EEPROM register macros

FromHartley Sweeten <HartleyS@visionengravers.com>
Date2016-05-17 19:30 +0200
SubjectRE: [PATCH 05/14] staging: comedi: daqboard2000: rename serial EEPROM register macros
Message-ID<rzQYG-7s5-17@gated-at.bofh.it>
In reply to#1402238
On Tuesday, May 17, 2016 2:53 AM, Ian Abbott wrote:
> Rename the macros defining values for the Serial EEPROM Control Register
> to avoid CamelCase.
>
> Signed-off-by: Ian Abbott <abbotti@mev.co.uk>
> ---
>  drivers/staging/comedi/drivers/daqboard2000.c | 26 +++++++++++++-------------
>  1 file changed, 13 insertions(+), 13 deletions(-)
>
> diff --git a/drivers/staging/comedi/drivers/daqboard2000.c b/drivers/staging/comedi/drivers/daqboard2000.c
> index fde0924..b3b68e8 100644
> --- a/drivers/staging/comedi/drivers/daqboard2000.c
> +++ b/drivers/staging/comedi/drivers/daqboard2000.c
> @@ -116,12 +116,12 @@
>  #define DAQBOARD2000_SUBSYSTEM_IDS4	0x0004	/* Daqboard/2000 - 4 Dacs */

Ian,

This board uses a PLX-9080 chip for the PCI interface.

If would be better to include <plx9080.h> and use the register/bit defines
to remove the magic numbers.

The only PLX register used is PLX_CONTROL_REG (0x6c).

>  /* Initialization bits for the Serial EEPROM Control Register */
> -#define DAQBOARD2000_SECRProgPinHi      0x8001767e
> -#define DAQBOARD2000_SECRProgPinLo      0x8000767e
> -#define DAQBOARD2000_SECRLocalBusHi     0xc000767e
> -#define DAQBOARD2000_SECRLocalBusLo     0x8000767e
> -#define DAQBOARD2000_SECRReloadHi       0xa000767e
> -#define DAQBOARD2000_SECRReloadLo       0x8000767e
> +#define DAQBOARD2000_SECR_PROG_PIN_HI	0x8001767e
> +#define DAQBOARD2000_SECR_PROG_PIN_LO	0x8000767e
> +#define DAQBOARD2000_SECR_LOCAL_BUS_HI	0xc000767e
> +#define DAQBOARD2000_SECR_LOCAL_BUS_LO	0x8000767e
> +#define DAQBOARD2000_SECR_RELOAD_HI	0xa000767e
> +#define DAQBOARD2000_SECR_RELOAD_LO	0x8000767e

These "Initialization bits" are just various combinations of the
PLX_CONTROL_REG bit defines (CTL_*) to toggle the various
EEPROM bits.
 
>  /* SECR status bits */
>  #define DAQBOARD2000_EEPROM_PRESENT     0x10000000
> @@ -438,9 +438,9 @@ static void daqboard2000_resetLocalBus(struct comedi_device *dev)
>  {
>  	struct daqboard2000_private *devpriv = dev->private;
>  
> -	writel(DAQBOARD2000_SECRLocalBusHi, devpriv->plx + 0x6c);
> +	writel(DAQBOARD2000_SECR_LOCAL_BUS_HI, devpriv->plx + 0x6c);
>  	mdelay(10);
> -	writel(DAQBOARD2000_SECRLocalBusLo, devpriv->plx + 0x6c);
> +	writel(DAQBOARD2000_SECR_LOCAL_BUS_LO, devpriv->plx + 0x6c);
>  	mdelay(10);
>  }
>  
> @@ -448,11 +448,11 @@ static void daqboard2000_reloadPLX(struct comedi_device *dev)
>  {
>  	struct daqboard2000_private *devpriv = dev->private;
>  
> -	writel(DAQBOARD2000_SECRReloadLo, devpriv->plx + 0x6c);
> +	writel(DAQBOARD2000_SECR_RELOAD_LO, devpriv->plx + 0x6c);
>  	mdelay(10);
> -	writel(DAQBOARD2000_SECRReloadHi, devpriv->plx + 0x6c);
> +	writel(DAQBOARD2000_SECR_RELOAD_HI, devpriv->plx + 0x6c);
>  	mdelay(10);
> -	writel(DAQBOARD2000_SECRReloadLo, devpriv->plx + 0x6c);
> +	writel(DAQBOARD2000_SECR_RELOAD_LO, devpriv->plx + 0x6c);
>  	mdelay(10);
>  }
 >
> @@ -460,9 +460,9 @@ static void daqboard2000_pulseProgPin(struct comedi_device *dev)
>  {
>  	struct daqboard2000_private *devpriv = dev->private;
>  
> -	writel(DAQBOARD2000_SECRProgPinHi, devpriv->plx + 0x6c);
> +	writel(DAQBOARD2000_SECR_PROG_PIN_HI, devpriv->plx + 0x6c);
>  	mdelay(10);
> -	writel(DAQBOARD2000_SECRProgPinLo, devpriv->plx + 0x6c);
> +	writel(DAQBOARD2000_SECR_PROG_PIN_LO, devpriv->plx + 0x6c);
>  	mdelay(10);	/* Not in the original code, but I like symmetry... */
>  }

Regards,
Hartley

[toc] | [prev] | [next] | [standalone]


#1402866 — Re: [PATCH 05/14] staging: comedi: daqboard2000: rename serial EEPROM register macros

FromIan Abbott <abbotti@mev.co.uk>
Date2016-05-18 12:30 +0200
SubjectRe: [PATCH 05/14] staging: comedi: daqboard2000: rename serial EEPROM register macros
Message-ID<rA6TM-Pd-27@gated-at.bofh.it>
In reply to#1402490
On 17/05/16 18:22, Hartley Sweeten wrote:
> On Tuesday, May 17, 2016 2:53 AM, Ian Abbott wrote:
>> Rename the macros defining values for the Serial EEPROM Control Register
>> to avoid CamelCase.
>>
>> Signed-off-by: Ian Abbott <abbotti@mev.co.uk>
>> ---
>>   drivers/staging/comedi/drivers/daqboard2000.c | 26 +++++++++++++-------------
>>   1 file changed, 13 insertions(+), 13 deletions(-)
>>
>> diff --git a/drivers/staging/comedi/drivers/daqboard2000.c b/drivers/staging/comedi/drivers/daqboard2000.c
>> index fde0924..b3b68e8 100644
>> --- a/drivers/staging/comedi/drivers/daqboard2000.c
>> +++ b/drivers/staging/comedi/drivers/daqboard2000.c
>> @@ -116,12 +116,12 @@
>>   #define DAQBOARD2000_SUBSYSTEM_IDS4	0x0004	/* Daqboard/2000 - 4 Dacs */
>
> Ian,
>
> This board uses a PLX-9080 chip for the PCI interface.
>
> If would be better to include <plx9080.h> and use the register/bit defines
> to remove the magic numbers.

I was planning to do that, but want to massage plx9080.h a bit first.

>
> The only PLX register used is PLX_CONTROL_REG (0x6c).
>
>>   /* Initialization bits for the Serial EEPROM Control Register */
>> -#define DAQBOARD2000_SECRProgPinHi      0x8001767e
>> -#define DAQBOARD2000_SECRProgPinLo      0x8000767e
>> -#define DAQBOARD2000_SECRLocalBusHi     0xc000767e
>> -#define DAQBOARD2000_SECRLocalBusLo     0x8000767e
>> -#define DAQBOARD2000_SECRReloadHi       0xa000767e
>> -#define DAQBOARD2000_SECRReloadLo       0x8000767e
>> +#define DAQBOARD2000_SECR_PROG_PIN_HI	0x8001767e
>> +#define DAQBOARD2000_SECR_PROG_PIN_LO	0x8000767e
>> +#define DAQBOARD2000_SECR_LOCAL_BUS_HI	0xc000767e
>> +#define DAQBOARD2000_SECR_LOCAL_BUS_LO	0x8000767e
>> +#define DAQBOARD2000_SECR_RELOAD_HI	0xa000767e
>> +#define DAQBOARD2000_SECR_RELOAD_LO	0x8000767e
>
> These "Initialization bits" are just various combinations of the
> PLX_CONTROL_REG bit defines (CTL_*) to toggle the various
> EEPROM bits.

Yes, it would be better to read the control register and only change the 
bits of interest.

I plan to do some more work on this driver.  This series is mainly to 
get the checkpatch warnings (well, most of them) out of the way first.

-- 
-=( Ian Abbott @ MEV Ltd.    E-mail: <abbotti@mev.co.uk> )=-
-=(                          Web: http://www.mev.co.uk/  )=-

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web