Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1343063 > unrolled thread
| Started by | Tim Sander <tim@krieglstein.org> |
|---|---|
| First post | 2016-02-25 11:10 +0100 |
| Last post | 2016-02-26 00:40 +0100 |
| Articles | 3 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
[PATCH v2] dts: add specific compatible type for Terasic DE0-NANO-SoC Board Tim Sander <tim@krieglstein.org> - 2016-02-25 11:10 +0100
Re: [PATCH v2] dts: add specific compatible type for Terasic DE0-NANO-SoC Board Steffen Trumtrar <s.trumtrar@pengutronix.de> - 2016-02-25 11:40 +0100
Re: [PATCH v2] dts: add specific compatible type for Terasic DE0-NANO-SoC Board Tim Sander <tim@krieglstein.org> - 2016-02-26 00:40 +0100
| From | Tim Sander <tim@krieglstein.org> |
|---|---|
| Date | 2016-02-25 11:10 +0100 |
| Subject | [PATCH v2] dts: add specific compatible type for Terasic DE0-NANO-SoC Board |
| Message-ID | <r611U-2fv-9@gated-at.bofh.it> |
From: Tim Sander <tim@krieglstein.org>
Add a more specific compatible string:"terasic,de0-nano-soc" for respective board.
Background: when checking for bootspec entries, some board specific fixups are
not apropriate for board of the same platform ("altr,socfpga-cyclone5").
The same aproach is taken with the EBV-Socrates board.
Signed-off-by: Tim Sander <tim@krieglstein.org>
---
Documentation/devicetree/bindings/vendor-prefixes.txt | 1 +
arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts | 2 +-
2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/Documentation/devicetree/bindings/vendor-prefixes.txt b/Documentation/devicetree/bindings/vendor-prefixes.txt
index 72e2c5a..d1f7803 100644
--- a/Documentation/devicetree/bindings/vendor-prefixes.txt
+++ b/Documentation/devicetree/bindings/vendor-prefixes.txt
@@ -230,6 +230,7 @@ synology Synology, Inc.
tbs TBS Technologies
tcl Toby Churchill Ltd.
technologic Technologic Systems
+terasic Terasic Inc.
thine THine Electronics, Inc.
ti Texas Instruments
tlm Trusted Logic Mobility
diff --git a/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts b/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
index afea364..704aa9d 100644
--- a/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
+++ b/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
@@ -18,7 +18,7 @@
/ {
model = "Terasic DE-0(Atlas)";
- compatible = "altr,socfpga-cyclone5", "altr,socfpga";
+ compatible = "terasic,de0-nano-soc","altr,socfpga-cyclone5", "altr,socfpga";
chosen {
bootargs = "earlyprintk";
--
1.9.1
[toc] | [next] | [standalone]
| From | Steffen Trumtrar <s.trumtrar@pengutronix.de> |
|---|---|
| Date | 2016-02-25 11:40 +0100 |
| Subject | Re: [PATCH v2] dts: add specific compatible type for Terasic DE0-NANO-SoC Board |
| Message-ID | <r61uW-2sM-29@gated-at.bofh.it> |
| In reply to | #1343063 |
Hi Tim!
On Thu, Feb 25, 2016 at 11:05:05AM +0100, Tim Sander wrote:
> From: Tim Sander <tim@krieglstein.org>
>
> Add a more specific compatible string:"terasic,de0-nano-soc" for respective board.
> Background: when checking for bootspec entries, some board specific fixups are
> not apropriate for board of the same platform ("altr,socfpga-cyclone5").
> The same aproach is taken with the EBV-Socrates board.
>
> Signed-off-by: Tim Sander <tim@krieglstein.org>
> ---
> Documentation/devicetree/bindings/vendor-prefixes.txt | 1 +
> arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts | 2 +-
> 2 files changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/Documentation/devicetree/bindings/vendor-prefixes.txt b/Documentation/devicetree/bindings/vendor-prefixes.txt
> index 72e2c5a..d1f7803 100644
> --- a/Documentation/devicetree/bindings/vendor-prefixes.txt
> +++ b/Documentation/devicetree/bindings/vendor-prefixes.txt
> @@ -230,6 +230,7 @@ synology Synology, Inc.
> tbs TBS Technologies
> tcl Toby Churchill Ltd.
> technologic Technologic Systems
> +terasic Terasic Inc.
> thine THine Electronics, Inc.
> ti Texas Instruments
> tlm Trusted Logic Mobility
You should IMHO split this up in two patches.
First patch: add terasic
> diff --git a/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts b/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
> index afea364..704aa9d 100644
> --- a/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
> +++ b/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
> @@ -18,7 +18,7 @@
>
> / {
> model = "Terasic DE-0(Atlas)";
> - compatible = "altr,socfpga-cyclone5", "altr,socfpga";
> + compatible = "terasic,de0-nano-soc","altr,socfpga-cyclone5", "altr,socfpga";
Second patch: this.
>
> chosen {
> bootargs = "earlyprintk";
The naming of this board still confuses me though.
It has 3 different names now:
- de0_sockit.dts
- Terasic DE-0(Atlas)
- de0-nano-soc
And according to Terasic DE0-Nano-SoC is the same as Atlas-SoC with a different software?!
So all three names are actually correct ?! Weird.
Regards,
Steffen
--
Pengutronix e.K. | |
Industrial Linux Solutions | http://www.pengutronix.de/ |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0 |
Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |
[toc] | [prev] | [next] | [standalone]
| From | Tim Sander <tim@krieglstein.org> |
|---|---|
| Date | 2016-02-26 00:40 +0100 |
| Subject | Re: [PATCH v2] dts: add specific compatible type for Terasic DE0-NANO-SoC Board |
| Message-ID | <r6dFM-2OI-23@gated-at.bofh.it> |
| In reply to | #1343095 |
Hi Dinh
On Thursday 25 February 2016 10:56:28 Dinh Nguyen wrote:
> On 02/25/2016 04:38 AM, Steffen Trumtrar wrote:
> > Hi Tim!
> >
> > On Thu, Feb 25, 2016 at 11:05:05AM +0100, Tim Sander wrote:
> >> From: Tim Sander <tim@krieglstein.org>
> >>
> >> Add a more specific compatible string:"terasic,de0-nano-soc" for
> >> respective board. Background: when checking for bootspec entries, some
> >> board specific fixups are not apropriate for board of the same platform
> >> ("altr,socfpga-cyclone5"). The same aproach is taken with the
> >> EBV-Socrates board.
> >>
> >> Signed-off-by: Tim Sander <tim@krieglstein.org>
> >> ---
> >>
> >> Documentation/devicetree/bindings/vendor-prefixes.txt | 1 +
> >> arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts | 2 +-
> >> 2 files changed, 2 insertions(+), 1 deletion(-)
> >>
> >> diff --git a/Documentation/devicetree/bindings/vendor-prefixes.txt
> >> b/Documentation/devicetree/bindings/vendor-prefixes.txt index
> >> 72e2c5a..d1f7803 100644
> >> --- a/Documentation/devicetree/bindings/vendor-prefixes.txt
> >> +++ b/Documentation/devicetree/bindings/vendor-prefixes.txt
> >> @@ -230,6 +230,7 @@ synology Synology, Inc.
> >>
> >> tbs TBS Technologies
> >> tcl Toby Churchill Ltd.
> >> technologic Technologic Systems
> >>
> >> +terasic Terasic Inc.
> >>
> >> thine THine Electronics, Inc.
> >> ti Texas Instruments
> >> tlm Trusted Logic Mobility
> >
> > You should IMHO split this up in two patches.
> > First patch: add terasic
>
> That's right. That patch will go through the DTS maintainer's tree.
Ah well for such a simple patch it turns out more complicated than thought :-)
Will do as soon as there is agreement on a name which does not seem that
easy...
>
> >> diff --git a/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
> >> b/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts index
> >> afea364..704aa9d 100644
> >> --- a/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
> >> +++ b/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
> >> @@ -18,7 +18,7 @@
> >>
> >> / {
> >>
> >> model = "Terasic DE-0(Atlas)";
> >>
> >> - compatible = "altr,socfpga-cyclone5", "altr,socfpga";
> >> + compatible = "terasic,de0-nano-soc","altr,socfpga-cyclone5",
> >> "altr,socfpga";
> So perhaps, "terasic,de0-sockit"?
>
> > Second patch: this.
>
> And I can take this one.
>
> >> chosen {
> >>
> >> bootargs = "earlyprintk";
> >
> > The naming of this board still confuses me though.
> >
> > It has 3 different names now:
> > - de0_sockit.dts
> > - Terasic DE-0(Atlas)
> > - de0-nano-soc
> >
> > And according to Terasic DE0-Nano-SoC is the same as Atlas-SoC with a
> > different software?! So all three names are actually correct ?! Weird.
>
> I had a hard time understanding this myself. But from what I gather
> from[1], I just name the file de0_sockit.
As far as i remember there are different de0 and different sockit boards, so
the name does not seem to be as concise? I don't care but i would say that
de0-nano-soc is the most concise and easier to search for than atlas which
might turn up more false postives?
But as long as there is a more selective name than cyclone5 everthing is fine
with me.
Best regards
Tim
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web