Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1341840 > unrolled thread

Re: [PATCH v8 3/8] time: Remove duplicated code in ktime_get_raw_and_real()

Started byThomas Gleixner <tglx@linutronix.de>
First post2016-02-24 12:00 +0100
Last post2016-02-24 12:00 +0100
Articles 1 — 1 participant

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH v8 3/8] time: Remove duplicated code in  ktime_get_raw_and_real() Thomas Gleixner <tglx@linutronix.de> - 2016-02-24 12:00 +0100

#1341840 — Re: [PATCH v8 3/8] time: Remove duplicated code in ktime_get_raw_and_real()

FromThomas Gleixner <tglx@linutronix.de>
Date2016-02-24 12:00 +0100
SubjectRe: [PATCH v8 3/8] time: Remove duplicated code in ktime_get_raw_and_real()
Message-ID<r5FkL-3hc-33@gated-at.bofh.it>
On Mon, 22 Feb 2016, Christopher S. Hall wrote:

> --- a/kernel/time/timekeeping.c
> +++ b/kernel/time/timekeeping.c
> @@ -888,6 +888,8 @@ void ktime_get_snapshot(struct system_time_snapshot *systime_snapshot)
>  	s64 nsec_real;
>  	cycle_t now;
>  
> +	WARN_ON(timekeeping_suspended);

WARN_ON_ONCE please

Other than that: Reviewed-by: Thomas Gleixner <tglx@linutronix.de>

[toc] | [standalone]


Back to top | Article view | linux.kernel


csiph-web