Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1337119 > unrolled thread

[PATCH v2] x86/head64: no need to define early_idt_ripmsg only if CONFIG_KALLSYMS=n

Started byAlexander Kuleshov <kuleshovmail@gmail.com>
First post2016-02-18 09:10 +0100
Last post2016-02-18 14:40 +0100
Articles 2 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH v2] x86/head64: no need to define early_idt_ripmsg only if CONFIG_KALLSYMS=n Alexander Kuleshov <kuleshovmail@gmail.com> - 2016-02-18 09:10 +0100
    Re: [PATCH v2] x86/head64: no need to define early_idt_ripmsg only  if CONFIG_KALLSYMS=n Borislav Petkov <bp@suse.de> - 2016-02-18 14:40 +0100

#1337119 — [PATCH v2] x86/head64: no need to define early_idt_ripmsg only if CONFIG_KALLSYMS=n

FromAlexander Kuleshov <kuleshovmail@gmail.com>
Date2016-02-18 09:10 +0100
Subject[PATCH v2] x86/head64: no need to define early_idt_ripmsg only if CONFIG_KALLSYMS=n
Message-ID<r3rOW-2FS-27@gated-at.bofh.it>
We have definition of the early_idt_ripmsg which represents string header
for the output of the kernel symbols during early exception. But the
header with kernel symbols will be printed in a case if the CONFIG_KALLSYMS=y.

Signed-off-by: Alexander Kuleshov <kuleshovmail@gmail.com>
---
Changelog:

v2: commit message fixed and comment added.

 arch/x86/kernel/head_64.S | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/arch/x86/kernel/head_64.S b/arch/x86/kernel/head_64.S
index ffdc0e8..f93997f 100644
--- a/arch/x86/kernel/head_64.S
+++ b/arch/x86/kernel/head_64.S
@@ -433,8 +433,10 @@ early_recursion_flag:
 #ifdef CONFIG_EARLY_PRINTK
 early_idt_msg:
 	.asciz "PANIC: early exception %02lx rip %lx:%lx error %lx cr2 %lx\n"
+#ifdef CONFIG_KALLSYMS
 early_idt_ripmsg:
 	.asciz "RIP %s\n"
+#endif /* CONFIG_KALLSYMS */
 #endif /* CONFIG_EARLY_PRINTK */
 
 #define NEXT_PAGE(name) \
-- 
2.7.0.364.g4943984

[toc] | [next] | [standalone]


#1337359 — Re: [PATCH v2] x86/head64: no need to define early_idt_ripmsg only if CONFIG_KALLSYMS=n

FromBorislav Petkov <bp@suse.de>
Date2016-02-18 14:40 +0100
SubjectRe: [PATCH v2] x86/head64: no need to define early_idt_ripmsg only if CONFIG_KALLSYMS=n
Message-ID<r3wYj-6bc-9@gated-at.bofh.it>
In reply to#1337119
On Thu, Feb 18, 2016 at 01:58:15PM +0600, Alexander Kuleshov wrote:
> We have definition of the early_idt_ripmsg which represents string header
> for the output of the kernel symbols during early exception. But the
> header with kernel symbols will be printed in a case if the CONFIG_KALLSYMS=y.

And this is a problem because... ?

Also, try to search how many distros and configs enable KALLSYMS. That
might clear some uncertainties when deciding to add one more ifdef to an
already hard to read code.

-- 
Regards/Gruss,
    Boris.

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284 (AG Nürnberg)
-- 

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web