Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1338312 > unrolled thread

[PATCH v2 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer

Started bySudeep Holla <sudeep.holla@arm.com>
First post2016-02-19 17:10 +0100
Last post2016-02-19 17:10 +0100
Articles 2 — 1 participant

Back to article view | Back to linux.kernel


Contents

  [PATCH v2 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer Sudeep Holla <sudeep.holla@arm.com> - 2016-02-19 17:10 +0100
    [PATCH v2 2/4] mailbox: mailbox-test: fix the compatible string Sudeep Holla <sudeep.holla@arm.com> - 2016-02-19 17:10 +0100

#1338312 — [PATCH v2 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer

FromSudeep Holla <sudeep.holla@arm.com>
Date2016-02-19 17:10 +0100
Subject[PATCH v2 0/4] mailbox: mailbox-test: support single channel with separate Tx and Rx buffer
Message-ID<r3VMZ-7DB-3@gated-at.bofh.it>
Hi Jassi,

Assuming mailbox-test was designed to be generic, I am trying to extend
it to support single channel with separate Tx and Rx buffer. With these
changes I am able to test arm_mhu driver.

However I couldn't understand the intention of converting buffer to ASCII
hex dump in read method. I have a local change to remove that so that it
can deal with any data in any format(e.g. some protocol format) and
userspace can deal with the actual interpretation of the data. I will
post that separately and discuss that in that thread. For now this
series is sufficient and userspace can do reverse conversion.

Please consider applying this for v4.6

Regards,
Sudeep

v1: https://lkml.org/lkml/2016/2/11/561
v1-v2:
	- Minor/Cosmetic changes as suggested by Lee
	- Added Acks from RobH and Lee

Sudeep Holla (4):
  mailbox: mailbox-test: rename driver as generic test driver
  mailbox: mailbox-test: fix the compatible string
  mailbox: mailbox-test: use print_hex_dump_bytes to allow dynamic
    printk
  mailbox: mailbox-test: add support for separate tx/rx buffer with
    single channel

 .../devicetree/bindings/mailbox/sti-mailbox.txt    |  2 +-
 drivers/mailbox/mailbox-test.c                     | 53 +++++++++++++---------
 2 files changed, 32 insertions(+), 23 deletions(-)

-- 
1.9.1

[toc] | [next] | [standalone]


#1338313 — [PATCH v2 2/4] mailbox: mailbox-test: fix the compatible string

FromSudeep Holla <sudeep.holla@arm.com>
Date2016-02-19 17:10 +0100
Subject[PATCH v2 2/4] mailbox: mailbox-test: fix the compatible string
Message-ID<r3VN0-7DB-15@gated-at.bofh.it>
In reply to#1338312
Underscores are usually forbidden in the compatible strings. So lets
remove it before the first users of this is seen.

Cc: Jassi Brar <jassisinghbrar@gmail.com>
Acked-by: Rob Herring <robh@kernel.org>
Acked-by: Lee Jones <lee.jones@linaro.org>
Signed-off-by: Sudeep Holla <sudeep.holla@arm.com>
---
 Documentation/devicetree/bindings/mailbox/sti-mailbox.txt | 2 +-
 drivers/mailbox/mailbox-test.c                            | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/Documentation/devicetree/bindings/mailbox/sti-mailbox.txt b/Documentation/devicetree/bindings/mailbox/sti-mailbox.txt
index b61eec920359..351f612673fc 100644
--- a/Documentation/devicetree/bindings/mailbox/sti-mailbox.txt
+++ b/Documentation/devicetree/bindings/mailbox/sti-mailbox.txt
@@ -44,7 +44,7 @@ Optional properties
 Example:
 
 mailbox_test {
-	compatible	= "mailbox_test";
+	compatible	= "mailbox-test";
 	reg		= <0x[shared_memory_address], [shared_memory_size]>;
 	mboxes		= <&mailbox2 0 1>, <&mailbox0 2 1>;
 	mbox-names	= "tx",	"rx";
diff --git a/drivers/mailbox/mailbox-test.c b/drivers/mailbox/mailbox-test.c
index 3813f6d9eba9..036a852b5fa1 100644
--- a/drivers/mailbox/mailbox-test.c
+++ b/drivers/mailbox/mailbox-test.c
@@ -342,7 +342,7 @@ static int mbox_test_remove(struct platform_device *pdev)
 }
 
 static const struct of_device_id mbox_test_match[] = {
-	{ .compatible = "mailbox_test" },
+	{ .compatible = "mailbox-test" },
 	{},
 };
 
-- 
1.9.1

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web