Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1272882 > unrolled thread

[PATCH v2 0/3] Improve bitmap_empty and bitmap_full

Started byJia He <hejianet@gmail.com>
First post2015-11-19 07:50 +0100
Last post2015-11-19 10:10 +0100
Articles 6 — 5 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH v2 0/3] Improve bitmap_empty and bitmap_full Jia He <hejianet@gmail.com> - 2015-11-19 07:50 +0100
    [PATCH v2 2/3] lib: Introduce 2 bit ops api: all_is_bit_{one,zero} Jia He <hejianet@gmail.com> - 2015-11-19 07:50 +0100
      Re: [PATCH v2 2/3] lib: Introduce 2 bit ops api:  all_is_bit_{one,zero} xinhui <xinhui@linux.vnet.ibm.com> - 2015-11-19 09:50 +0100
        Re: [PATCH v2 2/3] lib: Introduce 2 bit ops api:  all_is_bit_{one,zero} hejianet <hejianet@gmail.com> - 2015-11-19 10:00 +0100
      Re: [PATCH v2 2/3] lib: Introduce 2 bit ops api: all_is_bit_{one,zero} yalin wang <yalin.wang2010@gmail.com> - 2015-11-19 10:00 +0100
    Re: [PATCH v2 0/3] Improve bitmap_empty and bitmap_full Rasmus Villemoes <linux@rasmusvillemoes.dk> - 2015-11-19 10:10 +0100

#1272882 — [PATCH v2 0/3] Improve bitmap_empty and bitmap_full

FromJia He <hejianet@gmail.com>
Date2015-11-19 07:50 +0100
Subject[PATCH v2 0/3] Improve bitmap_empty and bitmap_full
Message-ID<qwrcB-5Lq-3@gated-at.bofh.it>
find_fisrt_{zero_}bit are too heavy for bitmap_{full,empty}. We don't 
need to calculate and compare the position of bitmap. This set of patch
instroduces lightweight api and replaces the heavy one.

v2: Move the declarations to linux/bitops.h for compilation

Jia He (3):
  Move 2 mask macro from bitmap.h to bitops.h
  Introduce 2 bit ops api: all_is_bit_{one,zero}
  Replace find_fisrt_{zero_}bit with the new lightweight api

 include/linux/bitmap.h |  7 ++-----
 include/linux/bitops.h |  7 +++++++
 lib/find_bit.c         | 50 ++++++++++++++++++++++++++++++++++++++++++++++++++
 3 files changed, 59 insertions(+), 5 deletions(-)

-- 
2.5.0

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1272885 — [PATCH v2 2/3] lib: Introduce 2 bit ops api: all_is_bit_{one,zero}

FromJia He <hejianet@gmail.com>
Date2015-11-19 07:50 +0100
Subject[PATCH v2 2/3] lib: Introduce 2 bit ops api: all_is_bit_{one,zero}
Message-ID<qwrcC-5Lq-13@gated-at.bofh.it>
In reply to#1272882
This patch introduces 2 lightweight bit api.
all_bit_is_zero return 1 if the bit string is all zero.
The addr is the start address, the size is the bit size of the bit string.
all_bit_is_one is the opposite.

Signed-off-by: Jia He <hejianet@gmail.com>
---
 lib/find_bit.c | 50 ++++++++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)

diff --git a/lib/find_bit.c b/lib/find_bit.c
index 18072ea..1d56d8d 100644
--- a/lib/find_bit.c
+++ b/lib/find_bit.c
@@ -131,6 +131,56 @@ unsigned long find_last_bit(const unsigned long *addr, unsigned long size)
 EXPORT_SYMBOL(find_last_bit);
 #endif
 
+#ifndef all_bit_is_zero
+/*
+ * return val: 1 means all bit is zero
+ */
+unsigned int all_bit_is_zero(const unsigned long *addr, unsigned size)
+{
+	unsigned long idx;
+	unsigned long mask = size;
+
+	if (unlikely(size == 0))
+		return 1;
+
+	if (size > BITS_PER_LONG) {
+		for (idx = 0; idx * BITS_PER_LONG < size; idx++)
+			if (addr[idx])
+				return 0;
+
+		mask = size - (idx - 1) * BITS_PER_LONG;
+	}
+
+	return !(*addr & BITMAP_LAST_WORD_MASK(mask));
+}
+EXPORT_SYMBOL(all_bit_is_zero);
+#endif
+
+#ifndef all_bit_is_one
+/*
+ * return val: 1 means all bit is one
+ */
+unsigned int all_bit_is_one(const unsigned long *addr, unsigned size)
+{
+	unsigned long idx;
+	unsigned long mask = size;
+
+	if (unlikely(size == 0))
+		return 1;
+
+	if (size > BITS_PER_LONG) {
+		for (idx = 0; idx * BITS_PER_LONG < size; idx++)
+			if (~addr[idx])
+				return 0;
+
+		mask = size - (idx - 1) * BITS_PER_LONG;
+	}
+
+	return !(~(*addr) & BITMAP_LAST_WORD_MASK(mask));
+}
+EXPORT_SYMBOL(all_bit_is_one);
+#endif
+
 #ifdef __BIG_ENDIAN
 
 /* include/linux/byteorder does not support "unsigned long" type */
-- 
2.5.0

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1272939 — Re: [PATCH v2 2/3] lib: Introduce 2 bit ops api: all_is_bit_{one,zero}

Fromxinhui <xinhui@linux.vnet.ibm.com>
Date2015-11-19 09:50 +0100
SubjectRe: [PATCH v2 2/3] lib: Introduce 2 bit ops api: all_is_bit_{one,zero}
Message-ID<qwt4J-6WM-13@gated-at.bofh.it>
In reply to#1272885
hi, jia
	Nice patch. But I have one minor question. see inline comments.

On 2015/11/19 14:48, Jia He wrote:
> This patch introduces 2 lightweight bit api.
> all_bit_is_zero return 1 if the bit string is all zero.
> The addr is the start address, the size is the bit size of the bit string.
> all_bit_is_one is the opposite.
>
> Signed-off-by: Jia He <hejianet@gmail.com>
> ---
>   lib/find_bit.c | 50 ++++++++++++++++++++++++++++++++++++++++++++++++++
>   1 file changed, 50 insertions(+)
>
> diff --git a/lib/find_bit.c b/lib/find_bit.c
> index 18072ea..1d56d8d 100644
> --- a/lib/find_bit.c
> +++ b/lib/find_bit.c
> @@ -131,6 +131,56 @@ unsigned long find_last_bit(const unsigned long *addr, unsigned long size)
>   EXPORT_SYMBOL(find_last_bit);
>   #endif
>
> +#ifndef all_bit_is_zero
> +/*
> + * return val: 1 means all bit is zero
> + */
> +unsigned int all_bit_is_zero(const unsigned long *addr, unsigned size)
> +{
  Seems better that size should be type of "unsigned long". Otherwise I'm afraid when we compare idx * BITS_PER_LONG with size, there might be overflow issue.

> +	unsigned long idx;
> +	unsigned long mask = size;
> +
> +	if (unlikely(size == 0))
> +		return 1;
> +
> +	if (size > BITS_PER_LONG) {
> +		for (idx = 0; idx * BITS_PER_LONG < size; idx++)
> +			if (addr[idx])
> +				return 0;
> +
> +		mask = size - (idx - 1) * BITS_PER_LONG;
> +	}
> +
> +	return !(*addr & BITMAP_LAST_WORD_MASK(mask));
> +}
> +EXPORT_SYMBOL(all_bit_is_zero);
> +#endif
> +
> +#ifndef all_bit_is_one
> +/*
> + * return val: 1 means all bit is one
> + */
> +unsigned int all_bit_is_one(const unsigned long *addr, unsigned size)
> +{
this argc of size should be type of "unsigned long", too.

thanks
xinhui

> +	unsigned long idx;
> +	unsigned long mask = size;
> +
> +	if (unlikely(size == 0))
> +		return 1;
> +
> +	if (size > BITS_PER_LONG) {
> +		for (idx = 0; idx * BITS_PER_LONG < size; idx++)
> +			if (~addr[idx])
> +				return 0;
> +
> +		mask = size - (idx - 1) * BITS_PER_LONG;
> +	}
> +
> +	return !(~(*addr) & BITMAP_LAST_WORD_MASK(mask));
> +}
> +EXPORT_SYMBOL(all_bit_is_one);
> +#endif
> +
>   #ifdef __BIG_ENDIAN
>
>   /* include/linux/byteorder does not support "unsigned long" type */
>

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1272943 — Re: [PATCH v2 2/3] lib: Introduce 2 bit ops api: all_is_bit_{one,zero}

Fromhejianet <hejianet@gmail.com>
Date2015-11-19 10:00 +0100
SubjectRe: [PATCH v2 2/3] lib: Introduce 2 bit ops api: all_is_bit_{one,zero}
Message-ID<qwteq-6ZV-9@gated-at.bofh.it>
In reply to#1272939
Thanks, I will add it in next verison
B.R.
Justin

在 11/19/15 4:40 PM, xinhui 写道:
> hi, jia
>     Nice patch. But I have one minor question. see inline comments.
>
> On 2015/11/19 14:48, Jia He wrote:
>> This patch introduces 2 lightweight bit api.
>> all_bit_is_zero return 1 if the bit string is all zero.
>> The addr is the start address, the size is the bit size of the bit 
>> string.
>> all_bit_is_one is the opposite.
>>
>> Signed-off-by: Jia He <hejianet@gmail.com>
>> ---
>>   lib/find_bit.c | 50 ++++++++++++++++++++++++++++++++++++++++++++++++++
>>   1 file changed, 50 insertions(+)
>>
>> diff --git a/lib/find_bit.c b/lib/find_bit.c
>> index 18072ea..1d56d8d 100644
>> --- a/lib/find_bit.c
>> +++ b/lib/find_bit.c
>> @@ -131,6 +131,56 @@ unsigned long find_last_bit(const unsigned long 
>> *addr, unsigned long size)
>>   EXPORT_SYMBOL(find_last_bit);
>>   #endif
>>
>> +#ifndef all_bit_is_zero
>> +/*
>> + * return val: 1 means all bit is zero
>> + */
>> +unsigned int all_bit_is_zero(const unsigned long *addr, unsigned size)
>> +{
>  Seems better that size should be type of "unsigned long". Otherwise 
> I'm afraid when we compare idx * BITS_PER_LONG with size, there might 
> be overflow issue.
>
>> +    unsigned long idx;
>> +    unsigned long mask = size;
>> +
>> +    if (unlikely(size == 0))
>> +        return 1;
>> +
>> +    if (size > BITS_PER_LONG) {
>> +        for (idx = 0; idx * BITS_PER_LONG < size; idx++)
>> +            if (addr[idx])
>> +                return 0;
>> +
>> +        mask = size - (idx - 1) * BITS_PER_LONG;
>> +    }
>> +
>> +    return !(*addr & BITMAP_LAST_WORD_MASK(mask));
>> +}
>> +EXPORT_SYMBOL(all_bit_is_zero);
>> +#endif
>> +
>> +#ifndef all_bit_is_one
>> +/*
>> + * return val: 1 means all bit is one
>> + */
>> +unsigned int all_bit_is_one(const unsigned long *addr, unsigned size)
>> +{
> this argc of size should be type of "unsigned long", too.
>
> thanks
> xinhui
>
>> +    unsigned long idx;
>> +    unsigned long mask = size;
>> +
>> +    if (unlikely(size == 0))
>> +        return 1;
>> +
>> +    if (size > BITS_PER_LONG) {
>> +        for (idx = 0; idx * BITS_PER_LONG < size; idx++)
>> +            if (~addr[idx])
>> +                return 0;
>> +
>> +        mask = size - (idx - 1) * BITS_PER_LONG;
>> +    }
>> +
>> +    return !(~(*addr) & BITMAP_LAST_WORD_MASK(mask));
>> +}
>> +EXPORT_SYMBOL(all_bit_is_one);
>> +#endif
>> +
>>   #ifdef __BIG_ENDIAN
>>
>>   /* include/linux/byteorder does not support "unsigned long" type */
>>
>
> -- 
> To unsubscribe from this list: send the line "unsubscribe 
> linux-kernel" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> Please read the FAQ at  http://www.tux.org/lkml/
>

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1272944 — Re: [PATCH v2 2/3] lib: Introduce 2 bit ops api: all_is_bit_{one,zero}

Fromyalin wang <yalin.wang2010@gmail.com>
Date2015-11-19 10:00 +0100
SubjectRe: [PATCH v2 2/3] lib: Introduce 2 bit ops api: all_is_bit_{one,zero}
Message-ID<qwteq-6ZV-5@gated-at.bofh.it>
In reply to#1272885
> On Nov 19, 2015, at 14:48, Jia He <hejianet@gmail.com> wrote:
> 
> 
why not use memcmp() to compare with  0x0000000 or 0xffffffff  ?
memcmp() have better performance on some platforms .

Thanks

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1272949

FromRasmus Villemoes <linux@rasmusvillemoes.dk>
Date2015-11-19 10:10 +0100
Message-ID<qwto7-7iI-7@gated-at.bofh.it>
In reply to#1272882
On Thu, Nov 19 2015, Jia He <hejianet@gmail.com> wrote:

> find_fisrt_{zero_}bit are too heavy for bitmap_{full,empty}. We don't 
> need to calculate and compare the position of bitmap. This set of patch
> instroduces lightweight api and replaces the heavy one.
>

Please check the history of the code you're modifying. git blame
include/linux/bitmap.h would immediately point you to 2afe27c718b
"lib/bitmap.c: bitmap_[empty,full]: remove code duplication". While it's
obviously true that find_first_bit does slightly more work than strictly
necessary to establish whether the bitmap is empty, it does the same
number of memory accesses, so I wouldn't consider it particularly
heavy-weight. Getting rid of .text as 2afe27c718b did is a good thing,
so you'd have to explain why we should reintroduce specialized functions
for this.

Your code is also buggy :-(

Rasmus
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web