Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1269862 > unrolled thread

[PATCH 7/7] mm/mmzone: refactor memmap_valid_within

Started byYaowei Bai <baiyaowei@cmss.chinamobile.com>
First post2015-11-16 08:00 +0100
Last post2015-11-17 03:50 +0100
Articles 3 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  [PATCH 7/7] mm/mmzone: refactor memmap_valid_within Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-16 08:00 +0100
    Re: [PATCH 7/7] mm/mmzone: refactor memmap_valid_within Michal Hocko <mhocko@kernel.org> - 2015-11-16 13:50 +0100
      Re: [PATCH 7/7] mm/mmzone: refactor memmap_valid_within Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-17 03:50 +0100

#1269862 — [PATCH 7/7] mm/mmzone: refactor memmap_valid_within

FromYaowei Bai <baiyaowei@cmss.chinamobile.com>
Date2015-11-16 08:00 +0100
Subject[PATCH 7/7] mm/mmzone: refactor memmap_valid_within
Message-ID<qvlVD-3Sn-1@gated-at.bofh.it>
This patch makes memmap_valid_within return bool due to this
particular function only using either one or zero as its return
value.

This patch also refactors memmap_valid_within for simplicity.

No functional change.

Signed-off-by: Yaowei Bai <baiyaowei@cmss.chinamobile.com>
---
 include/linux/mmzone.h |  6 +++---
 mm/mmzone.c            | 10 ++--------
 2 files changed, 5 insertions(+), 11 deletions(-)

diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h
index 9963846..b9b59bb8 100644
--- a/include/linux/mmzone.h
+++ b/include/linux/mmzone.h
@@ -1202,13 +1202,13 @@ unsigned long __init node_memmap_size_bytes(int, unsigned long, unsigned long);
  * the zone and PFN linkages are still valid. This is expensive, but walkers
  * of the full memmap are extremely rare.
  */
-int memmap_valid_within(unsigned long pfn,
+bool memmap_valid_within(unsigned long pfn,
 					struct page *page, struct zone *zone);
 #else
-static inline int memmap_valid_within(unsigned long pfn,
+static inline bool memmap_valid_within(unsigned long pfn,
 					struct page *page, struct zone *zone)
 {
-	return 1;
+	return true;
 }
 #endif /* CONFIG_ARCH_HAS_HOLES_MEMORYMODEL */
 
diff --git a/mm/mmzone.c b/mm/mmzone.c
index 7d87ebb..de0824e 100644
--- a/mm/mmzone.c
+++ b/mm/mmzone.c
@@ -72,16 +72,10 @@ struct zoneref *next_zones_zonelist(struct zoneref *z,
 }
 
 #ifdef CONFIG_ARCH_HAS_HOLES_MEMORYMODEL
-int memmap_valid_within(unsigned long pfn,
+bool memmap_valid_within(unsigned long pfn,
 					struct page *page, struct zone *zone)
 {
-	if (page_to_pfn(page) != pfn)
-		return 0;
-
-	if (page_zone(page) != zone)
-		return 0;
-
-	return 1;
+	return page_to_pfn(page) == pfn && page_zone(page) == zone;
 }
 #endif /* CONFIG_ARCH_HAS_HOLES_MEMORYMODEL */
 
-- 
1.9.1



--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1270079

FromMichal Hocko <mhocko@kernel.org>
Date2015-11-16 13:50 +0100
Message-ID<qvrom-7n2-15@gated-at.bofh.it>
In reply to#1269862
On Mon 16-11-15 14:51:26, Yaowei Bai wrote:
[...]
> @@ -72,16 +72,10 @@ struct zoneref *next_zones_zonelist(struct zoneref *z,
>  }
>  
>  #ifdef CONFIG_ARCH_HAS_HOLES_MEMORYMODEL
> -int memmap_valid_within(unsigned long pfn,
> +bool memmap_valid_within(unsigned long pfn,
>  					struct page *page, struct zone *zone)
>  {
> -	if (page_to_pfn(page) != pfn)
> -		return 0;
> -
> -	if (page_zone(page) != zone)
> -		return 0;
> -
> -	return 1;
> +	return page_to_pfn(page) == pfn && page_zone(page) == zone;

I do not think this is easier to read. Quite contrary

>  }
>  #endif /* CONFIG_ARCH_HAS_HOLES_MEMORYMODEL */
>  
> -- 
> 1.9.1
> 
> 

-- 
Michal Hocko
SUSE Labs
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1270776

FromYaowei Bai <baiyaowei@cmss.chinamobile.com>
Date2015-11-17 03:50 +0100
Message-ID<qvEvf-7jH-9@gated-at.bofh.it>
In reply to#1270079
On Mon, Nov 16, 2015 at 01:45:01PM +0100, Michal Hocko wrote:
> On Mon 16-11-15 14:51:26, Yaowei Bai wrote:
> [...]
> > @@ -72,16 +72,10 @@ struct zoneref *next_zones_zonelist(struct zoneref *z,
> >  }
> >  
> >  #ifdef CONFIG_ARCH_HAS_HOLES_MEMORYMODEL
> > -int memmap_valid_within(unsigned long pfn,
> > +bool memmap_valid_within(unsigned long pfn,
> >  					struct page *page, struct zone *zone)
> >  {
> > -	if (page_to_pfn(page) != pfn)
> > -		return 0;
> > -
> > -	if (page_zone(page) != zone)
> > -		return 0;
> > -
> > -	return 1;
> > +	return page_to_pfn(page) == pfn && page_zone(page) == zone;
> 
> I do not think this is easier to read. Quite contrary

OK, so we can just make it return ture/false without refactoring it.

> 
> >  }
> >  #endif /* CONFIG_ARCH_HAS_HOLES_MEMORYMODEL */
> >  
> > -- 
> > 1.9.1
> > 
> > 
> 
> -- 
> Michal Hocko
> SUSE Labs


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web