Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1270702 > unrolled thread

Re: [PATCH 4/4] m68knommu: Add missing initialization of max_pfn and {min,max}_low_pfn

Started byGreg Ungerer <gerg@uclinux.org>
First post2015-11-17 01:00 +0100
Last post2015-11-22 11:40 +0100
Articles 2 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH 4/4] m68knommu: Add missing initialization of max_pfn and  {min,max}_low_pfn Greg Ungerer <gerg@uclinux.org> - 2015-11-17 01:00 +0100
    Re: [PATCH 4/4] m68knommu: Add missing initialization of max_pfn and {min,max}_low_pfn Geert Uytterhoeven <geert@linux-m68k.org> - 2015-11-22 11:40 +0100

#1270702 — Re: [PATCH 4/4] m68knommu: Add missing initialization of max_pfn and {min,max}_low_pfn

FromGreg Ungerer <gerg@uclinux.org>
Date2015-11-17 01:00 +0100
SubjectRe: [PATCH 4/4] m68knommu: Add missing initialization of max_pfn and {min,max}_low_pfn
Message-ID<qvBQJ-5zm-11@gated-at.bofh.it>
Hi Geert,

On 15/11/15 21:04, Geert Uytterhoeven wrote:
> If max_pfn is not initialized, the block layer may use wrong DMA masks.
> 
> Replace open-coded shifts by PFN_DOWN() while we're at it.
> 
> Signed-off-by: Geert Uytterhoeven <geert@linux-m68k.org>

Tested and working fine on m68knommu. So:

Tested-By: Greg Ungerer <gerg@uclinux.org>

If you respin this patch for any reason I wouldn't object
to removing the "/* 0 on coldfire */" comment...

Regards
Greg



> ---
> Compile-tested only.
> ---
>  arch/m68k/kernel/setup_no.c | 9 ++++++---
>  1 file changed, 6 insertions(+), 3 deletions(-)
> 
> diff --git a/arch/m68k/kernel/setup_no.c b/arch/m68k/kernel/setup_no.c
> index 88c27d94a7214c95..29b44e69f0f47375 100644
> --- a/arch/m68k/kernel/setup_no.c
> +++ b/arch/m68k/kernel/setup_no.c
> @@ -238,11 +238,14 @@ void __init setup_arch(char **cmdline_p)
>  	 * Give all the memory to the bootmap allocator, tell it to put the
>  	 * boot mem_map at the start of memory.
>  	 */
> +	min_low_pfn = PFN_DOWN(memory_start);
> +	max_pfn = max_low_pfn = PFN_DOWN(memory_end);
> +
>  	bootmap_size = init_bootmem_node(
>  			NODE_DATA(0),
> -			memory_start >> PAGE_SHIFT, /* map goes here */
> -			PAGE_OFFSET >> PAGE_SHIFT,	/* 0 on coldfire */
> -			memory_end >> PAGE_SHIFT);
> +			min_low_pfn,		/* map goes here */
> +			PFN_DOWN(PAGE_OFFSET),	/* 0 on coldfire */
> +			max_pfn);
>  	/*
>  	 * Free the usable memory, we have to make sure we do not free
>  	 * the bootmem bitmap so we then reserve it after freeing it :-)
> 

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1274846 — Re: [PATCH 4/4] m68knommu: Add missing initialization of max_pfn and {min,max}_low_pfn

FromGeert Uytterhoeven <geert@linux-m68k.org>
Date2015-11-22 11:40 +0100
SubjectRe: [PATCH 4/4] m68knommu: Add missing initialization of max_pfn and {min,max}_low_pfn
Message-ID<qxAdQ-2sv-19@gated-at.bofh.it>
In reply to#1270702
Hi Greg,

On Tue, Nov 17, 2015 at 12:54 AM, Greg Ungerer <gerg@uclinux.org> wrote:
> On 15/11/15 21:04, Geert Uytterhoeven wrote:
>> If max_pfn is not initialized, the block layer may use wrong DMA masks.
>>
>> Replace open-coded shifts by PFN_DOWN() while we're at it.
>>
>> Signed-off-by: Geert Uytterhoeven <geert@linux-m68k.org>
>
> Tested and working fine on m68knommu. So:
>
> Tested-By: Greg Ungerer <gerg@uclinux.org>
>
> If you respin this patch for any reason I wouldn't object
> to removing the "/* 0 on coldfire */" comment...

Thanks, done, applied, and queued for v4.4.

Gr{oetje,eeting}s,

                        Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                -- Linus Torvalds
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web