Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1263628 > unrolled thread
| Started by | Andrew Duggan <aduggan@synaptics.com> |
|---|---|
| First post | 2015-11-06 00:50 +0100 |
| Last post | 2015-11-09 14:40 +0100 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
[PATCH 26/26] Input: synaptics-rmi4: Change the rmi device's name to be less generic Andrew Duggan <aduggan@synaptics.com> - 2015-11-06 00:50 +0100
Re: [PATCH 26/26] Input: synaptics-rmi4: Change the rmi device's name to be less generic Linus Walleij <linus.walleij@linaro.org> - 2015-11-09 14:40 +0100
| From | Andrew Duggan <aduggan@synaptics.com> |
|---|---|
| Date | 2015-11-06 00:50 +0100 |
| Subject | [PATCH 26/26] Input: synaptics-rmi4: Change the rmi device's name to be less generic |
| Message-ID | <qrCs2-5az-27@gated-at.bofh.it> |
Currently, the rmi device has the name sensorXX. Sensor is very generic and in cases when there is little context it is hard to tell what the device is (ie in /sys/devices or /proc/interrupts). This patch changes the name to rmiXX which at least indicates that it is an rmi device. Signed-off-by: Andrew Duggan <aduggan@synaptics.com> --- Linus Walleij suggested that we use the TM number as the device name. But, we need to set the device name when we add the device before we read the TM number. Changing the name to rmiXX is a compromise since it's not as unique as the TM, but not as generic as sensor. drivers/input/rmi4/rmi_bus.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/input/rmi4/rmi_bus.c b/drivers/input/rmi4/rmi_bus.c index a04468d..998b4e1 100644 --- a/drivers/input/rmi4/rmi_bus.c +++ b/drivers/input/rmi4/rmi_bus.c @@ -66,7 +66,7 @@ int rmi_register_transport_device(struct rmi_transport_dev *xport) rmi_dev->xport = xport; rmi_dev->number = atomic_inc_return(&transport_device_count) - 1; - dev_set_name(&rmi_dev->dev, "sensor%02d", rmi_dev->number); + dev_set_name(&rmi_dev->dev, "rmi%02d", rmi_dev->number); rmi_dev->dev.bus = &rmi_bus_type; rmi_dev->dev.type = &rmi_device_type; -- 2.1.4 -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [next] | [standalone]
| From | Linus Walleij <linus.walleij@linaro.org> |
|---|---|
| Date | 2015-11-09 14:40 +0100 |
| Subject | Re: [PATCH 26/26] Input: synaptics-rmi4: Change the rmi device's name to be less generic |
| Message-ID | <qsUPU-70f-21@gated-at.bofh.it> |
| In reply to | #1263628 |
On Fri, Nov 6, 2015 at 12:43 AM, Andrew Duggan <aduggan@synaptics.com> wrote: > Currently, the rmi device has the name sensorXX. Sensor is very generic > and in cases when there is little context it is hard to tell what the > device is (ie in /sys/devices or /proc/interrupts). This patch changes > the name to rmiXX which at least indicates that it is an rmi device. > > Signed-off-by: Andrew Duggan <aduggan@synaptics.com> > --- > Linus Walleij suggested that we use the TM number as the device name. > But, we need to set the device name when we add the device before we > read the TM number. Changing the name to rmiXX is a compromise since > it's not as unique as the TM, but not as generic as sensor. OK OK I give up. No big deal anyway, the device works. Squash into core patch? Acked-by: Linus Walleij <linus.walleij@linaro.org> Yours, Linus Walleij -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web