Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1260327 > unrolled thread
| Started by | Alim Akhtar <alim.akhtar@samsung.com> |
|---|---|
| First post | 2015-11-02 05:10 +0100 |
| Last post | 2015-11-04 14:50 +0100 |
| Articles | 3 — 3 participants |
Back to article view | Back to linux.kernel
[PATCH v2] mfd: sec-core: Rename MFD and regulator names differently Alim Akhtar <alim.akhtar@samsung.com> - 2015-11-02 05:10 +0100
Re: [PATCH v2] mfd: sec-core: Rename MFD and regulator names differently Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2015-11-02 05:20 +0100
Re: [PATCH v2] mfd: sec-core: Rename MFD and regulator names differently Mark Brown <broonie@kernel.org> - 2015-11-04 14:50 +0100
| From | Alim Akhtar <alim.akhtar@samsung.com> |
|---|---|
| Date | 2015-11-02 05:10 +0100 |
| Subject | [PATCH v2] mfd: sec-core: Rename MFD and regulator names differently |
| Message-ID | <qqeBr-EF-1@gated-at.bofh.it> |
Currently S2MPSXX multifunction device is named as *-pmic,
and these MFDs also supports regulator as a one of its MFD cell which
has the same name, because current name is confusing and we want to
sort it out.
We did discussed different approaches about how the MFD and it
cells need to be named here [1].
Based in the discussion this patch rename MFD regulator name as
*-regulator instead of current *-pmic.
This patch also changes the corresponding entries in the regulator driver
to keep git-bisect happy.
[1]-> https://lkml.org/lkml/2015/10/28/417
Suggested-by: Lee Jones <lee.jones@linaro.org>
Signed-off-by: Alim Akhtar <alim.akhtar@samsung.com>
---
Changes since V1:
* Squashed the two patches in one as sugeested by Lee
* Based on the top of [1]
[1]-> https://www.mail-archive.com/linux-samsung-soc@vger.kernel.org/msg47736.html
drivers/mfd/sec-core.c | 8 ++++----
drivers/regulator/s2mps11.c | 8 ++++----
2 files changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/mfd/sec-core.c b/drivers/mfd/sec-core.c
index 7c4e7be17f1e..c9802ba9be72 100644
--- a/drivers/mfd/sec-core.c
+++ b/drivers/mfd/sec-core.c
@@ -68,7 +68,7 @@ static const struct mfd_cell s5m8767_devs[] = {
static const struct mfd_cell s2mps11_devs[] = {
{
- .name = "s2mps11-pmic",
+ .name = "s2mps11-regulator",
}, {
.name = "s2mps14-rtc",
}, {
@@ -78,7 +78,7 @@ static const struct mfd_cell s2mps11_devs[] = {
};
static const struct mfd_cell s2mps13_devs[] = {
- { .name = "s2mps13-pmic", },
+ { .name = "s2mps13-regulator", },
{ .name = "s2mps13-rtc", },
{
.name = "s2mps13-clk",
@@ -88,7 +88,7 @@ static const struct mfd_cell s2mps13_devs[] = {
static const struct mfd_cell s2mps14_devs[] = {
{
- .name = "s2mps14-pmic",
+ .name = "s2mps14-regulator",
}, {
.name = "s2mps14-rtc",
}, {
@@ -116,7 +116,7 @@ static const struct mfd_cell s2mpa01_devs[] = {
static const struct mfd_cell s2mpu02_devs[] = {
{
- .name = "s2mpu02-pmic",
+ .name = "s2mpu02-regulator",
},
};
diff --git a/drivers/regulator/s2mps11.c b/drivers/regulator/s2mps11.c
index b2f3a28e720c..3242ffc0cb25 100644
--- a/drivers/regulator/s2mps11.c
+++ b/drivers/regulator/s2mps11.c
@@ -1199,11 +1199,11 @@ out:
}
static const struct platform_device_id s2mps11_pmic_id[] = {
- { "s2mps11-pmic", S2MPS11X},
- { "s2mps13-pmic", S2MPS13X},
- { "s2mps14-pmic", S2MPS14X},
+ { "s2mps11-regulator", S2MPS11X},
+ { "s2mps13-regulator", S2MPS13X},
+ { "s2mps14-regulator", S2MPS14X},
{ "s2mps15-regulator", S2MPS15X},
- { "s2mpu02-pmic", S2MPU02},
+ { "s2mpu02-regulator", S2MPU02},
{ },
};
MODULE_DEVICE_TABLE(platform, s2mps11_pmic_id);
--
1.7.10.4
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [next] | [standalone]
| From | Krzysztof Kozlowski <k.kozlowski@samsung.com> |
|---|---|
| Date | 2015-11-02 05:20 +0100 |
| Subject | Re: [PATCH v2] mfd: sec-core: Rename MFD and regulator names differently |
| Message-ID | <qqeL8-I4-5@gated-at.bofh.it> |
| In reply to | #1260327 |
On 02.11.2015 13:06, Alim Akhtar wrote: > Currently S2MPSXX multifunction device is named as *-pmic, > and these MFDs also supports regulator as a one of its MFD cell which > has the same name, because current name is confusing and we want to > sort it out. > > We did discussed different approaches about how the MFD and it > cells need to be named here [1]. > Based in the discussion this patch rename MFD regulator name as > *-regulator instead of current *-pmic. > > This patch also changes the corresponding entries in the regulator driver > to keep git-bisect happy. > > [1]-> https://lkml.org/lkml/2015/10/28/417 > > Suggested-by: Lee Jones <lee.jones@linaro.org> > Signed-off-by: Alim Akhtar <alim.akhtar@samsung.com> > --- > Changes since V1: > * Squashed the two patches in one as sugeested by Lee > * Based on the top of [1] > [1]-> https://www.mail-archive.com/linux-samsung-soc@vger.kernel.org/msg47736.html > > drivers/mfd/sec-core.c | 8 ++++---- > drivers/regulator/s2mps11.c | 8 ++++---- > 2 files changed, 8 insertions(+), 8 deletions(-) > Looks good: Reviewed-by: Krzysztof Kozlowski <k.kozlowski@samsung.com> Best regards, Krzysztof -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Mark Brown <broonie@kernel.org> |
|---|---|
| Date | 2015-11-04 14:50 +0100 |
| Subject | Re: [PATCH v2] mfd: sec-core: Rename MFD and regulator names differently |
| Message-ID | <qr6BQ-16g-5@gated-at.bofh.it> |
| In reply to | #1260327 |
[Multipart message — attachments visible in raw view] — view raw
On Mon, Nov 02, 2015 at 09:36:09AM +0530, Alim Akhtar wrote: > Currently S2MPSXX multifunction device is named as *-pmic, > and these MFDs also supports regulator as a one of its MFD cell which > has the same name, because current name is confusing and we want to > sort it out. Acked-by: Mark Brown <broonie@kernel.org>
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web