Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1246020 > unrolled thread
| Started by | Aravind Gopalakrishnan <Aravind.Gopalakrishnan@amd.com> |
|---|---|
| First post | 2015-10-13 20:20 +0200 |
| Last post | 2015-10-14 16:00 +0200 |
| Articles | 3 — 3 participants |
Back to article view | Back to linux.kernel
[PATCH] x86/amd_nb: Rename amd_get_node_id Aravind Gopalakrishnan <Aravind.Gopalakrishnan@amd.com> - 2015-10-13 20:20 +0200
Re: [PATCH] x86/amd_nb: Rename amd_get_node_id Ingo Molnar <mingo@kernel.org> - 2015-10-14 15:50 +0200
Re: [PATCH] x86/amd_nb: Rename amd_get_node_id Borislav Petkov <bp@alien8.de> - 2015-10-14 16:00 +0200
| From | Aravind Gopalakrishnan <Aravind.Gopalakrishnan@amd.com> |
|---|---|
| Date | 2015-10-13 20:20 +0200 |
| Subject | [PATCH] x86/amd_nb: Rename amd_get_node_id |
| Message-ID | <qjcl3-642-7@gated-at.bofh.it> |
This function doesn't give us the "Node ID" as the function
name suggests. Rather- it receives a PCI device as argument,
checks the available F3 PCI device IDs in the system
and returns the index of the matching Bus/Device IDs
Renaming it accordingly in this patch.
No functional change is introduced.
Signed-off-by: Aravind Gopalakrishnan <Aravind.Gopalakrishnan@amd.com>
---
arch/x86/include/asm/amd_nb.h | 2 +-
drivers/edac/amd64_edac.c | 6 +++---
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/arch/x86/include/asm/amd_nb.h b/arch/x86/include/asm/amd_nb.h
index 1a5da2e..319843d 100644
--- a/arch/x86/include/asm/amd_nb.h
+++ b/arch/x86/include/asm/amd_nb.h
@@ -81,7 +81,7 @@ static inline struct amd_northbridge *node_to_amd_nb(int node)
return (node < amd_northbridges.num) ? &amd_northbridges.nb[node] : NULL;
}
-static inline u16 amd_get_node_id(struct pci_dev *pdev)
+static inline u16 amd_get_node_id_from_pci_dev(struct pci_dev *pdev)
{
struct pci_dev *misc;
int i;
diff --git a/drivers/edac/amd64_edac.c b/drivers/edac/amd64_edac.c
index 73aea40..896cf1f 100644
--- a/drivers/edac/amd64_edac.c
+++ b/drivers/edac/amd64_edac.c
@@ -2770,7 +2770,7 @@ static int init_one_instance(struct pci_dev *F2)
struct mem_ctl_info *mci = NULL;
struct edac_mc_layer layers[2];
int err = 0, ret;
- u16 nid = amd_get_node_id(F2);
+ u16 nid = amd_get_node_id_from_pci_dev(F2);
ret = -ENOMEM;
pvt = kzalloc(sizeof(struct amd64_pvt), GFP_KERNEL);
@@ -2860,7 +2860,7 @@ err_ret:
static int probe_one_instance(struct pci_dev *pdev,
const struct pci_device_id *mc_type)
{
- u16 nid = amd_get_node_id(pdev);
+ u16 nid = amd_get_node_id_from_pci_dev(pdev);
struct pci_dev *F3 = node_to_amd_nb(nid)->misc;
struct ecc_settings *s;
int ret = 0;
@@ -2910,7 +2910,7 @@ static void remove_one_instance(struct pci_dev *pdev)
{
struct mem_ctl_info *mci;
struct amd64_pvt *pvt;
- u16 nid = amd_get_node_id(pdev);
+ u16 nid = amd_get_node_id_from_pci_dev(pdev);
struct pci_dev *F3 = node_to_amd_nb(nid)->misc;
struct ecc_settings *s = ecc_stngs[nid];
--
2.5.0
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [next] | [standalone]
| From | Ingo Molnar <mingo@kernel.org> |
|---|---|
| Date | 2015-10-14 15:50 +0200 |
| Message-ID | <qjuBk-8B-19@gated-at.bofh.it> |
| In reply to | #1246020 |
* Aravind Gopalakrishnan <Aravind.Gopalakrishnan@amd.com> wrote: > This function doesn't give us the "Node ID" as the function > name suggests. Rather- it receives a PCI device as argument, > checks the available F3 PCI device IDs in the system > and returns the index of the matching Bus/Device IDs > > Renaming it accordingly in this patch. > No functional change is introduced. > > Signed-off-by: Aravind Gopalakrishnan <Aravind.Gopalakrishnan@amd.com> > --- > arch/x86/include/asm/amd_nb.h | 2 +- > drivers/edac/amd64_edac.c | 6 +++--- > 2 files changed, 4 insertions(+), 4 deletions(-) > > diff --git a/arch/x86/include/asm/amd_nb.h b/arch/x86/include/asm/amd_nb.h > index 1a5da2e..319843d 100644 > --- a/arch/x86/include/asm/amd_nb.h > +++ b/arch/x86/include/asm/amd_nb.h > @@ -81,7 +81,7 @@ static inline struct amd_northbridge *node_to_amd_nb(int node) > return (node < amd_northbridges.num) ? &amd_northbridges.nb[node] : NULL; > } > > -static inline u16 amd_get_node_id(struct pci_dev *pdev) > +static inline u16 amd_get_node_id_from_pci_dev(struct pci_dev *pdev) So if we go to the trouble of naming things properly, I guess that function should be named: amd_pci_dev_to_node_id() or so. Thanks, Ingo -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Borislav Petkov <bp@alien8.de> |
|---|---|
| Date | 2015-10-14 16:00 +0200 |
| Message-ID | <qjuL1-k6-31@gated-at.bofh.it> |
| In reply to | #1246763 |
On Wed, Oct 14, 2015 at 03:42:49PM +0200, Ingo Molnar wrote:
>
> * Aravind Gopalakrishnan <Aravind.Gopalakrishnan@amd.com> wrote:
>
> > This function doesn't give us the "Node ID" as the function
> > name suggests. Rather- it receives a PCI device as argument,
> > checks the available F3 PCI device IDs in the system
> > and returns the index of the matching Bus/Device IDs
> >
> > Renaming it accordingly in this patch.
> > No functional change is introduced.
> >
> > Signed-off-by: Aravind Gopalakrishnan <Aravind.Gopalakrishnan@amd.com>
> > ---
> > arch/x86/include/asm/amd_nb.h | 2 +-
> > drivers/edac/amd64_edac.c | 6 +++---
> > 2 files changed, 4 insertions(+), 4 deletions(-)
> >
> > diff --git a/arch/x86/include/asm/amd_nb.h b/arch/x86/include/asm/amd_nb.h
> > index 1a5da2e..319843d 100644
> > --- a/arch/x86/include/asm/amd_nb.h
> > +++ b/arch/x86/include/asm/amd_nb.h
> > @@ -81,7 +81,7 @@ static inline struct amd_northbridge *node_to_amd_nb(int node)
> > return (node < amd_northbridges.num) ? &amd_northbridges.nb[node] : NULL;
> > }
> >
> > -static inline u16 amd_get_node_id(struct pci_dev *pdev)
> > +static inline u16 amd_get_node_id_from_pci_dev(struct pci_dev *pdev)
>
> So if we go to the trouble of naming things properly, I guess that function should
> be named:
>
> amd_pci_dev_to_node_id()
>
> or so.
Or so.
This is in preparation for future changes anyway so the name had to
be not so generic and hint at the PCI dev argument. I'll change it to
amd_pci_dev_to_node_id() when applying.
Thanks.
--
Regards/Gruss,
Boris.
ECO tip #101: Trim your mails when you reply.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web