Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1232707 > unrolled thread

Re: [PATCH v2 5/9] mm/compaction: allow to scan nonmovable pageblock when depleted state

Started byVlastimil Babka <vbabka@suse.cz>
First post2015-09-25 12:40 +0200
Last post2015-09-30 10:30 +0200
Articles 2 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH v2 5/9] mm/compaction: allow to scan nonmovable pageblock  when depleted state Vlastimil Babka <vbabka@suse.cz> - 2015-09-25 12:40 +0200
    Re: [PATCH v2 5/9] mm/compaction: allow to scan nonmovable pageblock  when depleted state Joonsoo Kim <iamjoonsoo.kim@lge.com> - 2015-09-30 10:30 +0200

#1232707 — Re: [PATCH v2 5/9] mm/compaction: allow to scan nonmovable pageblock when depleted state

FromVlastimil Babka <vbabka@suse.cz>
Date2015-09-25 12:40 +0200
SubjectRe: [PATCH v2 5/9] mm/compaction: allow to scan nonmovable pageblock when depleted state
Message-ID<qcyA2-7au-5@gated-at.bofh.it>
On 08/24/2015 04:19 AM, Joonsoo Kim wrote:

[...]

> 
> Because we just allow freepage scanner to scan non-movable pageblock
> in very limited situation, more scanning events happen. But, allowing
> in very limited situation results in a very important benefit that
> memory isn't fragmented more than before. Fragmentation effect is
> measured on following patch so please refer it.

AFAICS it's measured only for the whole series in the cover letter, no? Just to
be sure I didn't overlook something.

> Signed-off-by: Joonsoo Kim <iamjoonsoo.kim@lge.com>
> ---
>  include/linux/mmzone.h |  1 +
>  mm/compaction.c        | 27 +++++++++++++++++++++++++--
>  2 files changed, 26 insertions(+), 2 deletions(-)
> 
> diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h
> index e13b732..5cae0ad 100644
> --- a/include/linux/mmzone.h
> +++ b/include/linux/mmzone.h
> @@ -545,6 +545,7 @@ enum zone_flags {
>  					 */
>  	ZONE_FAIR_DEPLETED,		/* fair zone policy batch depleted */
>  	ZONE_COMPACTION_DEPLETED,	/* compaction possiblity depleted */
> +	ZONE_COMPACTION_SCANALLFREE,	/* scan all kinds of pageblocks */

"SCANALLFREE" is hard to read. Otherwise yeah, I agree scanning unmovable
pageblocks is necessary sometimes, and this seems to make a reasonable tradeoff.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1235890

FromJoonsoo Kim <iamjoonsoo.kim@lge.com>
Date2015-09-30 10:30 +0200
Message-ID<qekVZ-7TY-31@gated-at.bofh.it>
In reply to#1232707
On Fri, Sep 25, 2015 at 12:32:02PM +0200, Vlastimil Babka wrote:
> On 08/24/2015 04:19 AM, Joonsoo Kim wrote:
> 
> [...]
> 
> > 
> > Because we just allow freepage scanner to scan non-movable pageblock
> > in very limited situation, more scanning events happen. But, allowing
> > in very limited situation results in a very important benefit that
> > memory isn't fragmented more than before. Fragmentation effect is
> > measured on following patch so please refer it.
> 
> AFAICS it's measured only for the whole series in the cover letter, no? Just to
> be sure I didn't overlook something.

It takes too much time so no measurement is done on every patch.
I will try to measure it on at least this patch in next revision.

> 
> > Signed-off-by: Joonsoo Kim <iamjoonsoo.kim@lge.com>
> > ---
> >  include/linux/mmzone.h |  1 +
> >  mm/compaction.c        | 27 +++++++++++++++++++++++++--
> >  2 files changed, 26 insertions(+), 2 deletions(-)
> > 
> > diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h
> > index e13b732..5cae0ad 100644
> > --- a/include/linux/mmzone.h
> > +++ b/include/linux/mmzone.h
> > @@ -545,6 +545,7 @@ enum zone_flags {
> >  					 */
> >  	ZONE_FAIR_DEPLETED,		/* fair zone policy batch depleted */
> >  	ZONE_COMPACTION_DEPLETED,	/* compaction possiblity depleted */
> > +	ZONE_COMPACTION_SCANALLFREE,	/* scan all kinds of pageblocks */
> 
> "SCANALLFREE" is hard to read. Otherwise yeah, I agree scanning unmovable
> pageblocks is necessary sometimes, and this seems to make a reasonable tradeoff.

Good! I will think better name.

Thanks.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web