Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1232534 > unrolled thread

[PATCH v2 2/4] clocksource: rockchip: trivial: Make the driver more readability

Started byCaesar Wang <wxt@rock-chips.com>
First post2015-09-25 04:20 +0200
Last post2015-09-29 06:20 +0200
Articles 2 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  [PATCH v2 2/4] clocksource: rockchip: trivial: Make the driver more readability Caesar Wang <wxt@rock-chips.com> - 2015-09-25 04:20 +0200
    Re: [PATCH v2 2/4] clocksource: rockchip: trivial: Make the driver  more readability Daniel Lezcano <daniel.lezcano@linaro.org> - 2015-09-29 06:20 +0200

#1232534 — [PATCH v2 2/4] clocksource: rockchip: trivial: Make the driver more readability

FromCaesar Wang <wxt@rock-chips.com>
Date2015-09-25 04:20 +0200
Subject[PATCH v2 2/4] clocksource: rockchip: trivial: Make the driver more readability
Message-ID<qcqMa-4Jw-3@gated-at.bofh.it>
Let's checkstyle to clean up the macros with such trivial details.

Signed-off-by: Caesar Wang <wxt@rock-chips.com>
---

Changes in v2: None
Changes in v1: None

 drivers/clocksource/rockchip_timer.c | 19 ++++++++++---------
 1 file changed, 10 insertions(+), 9 deletions(-)

diff --git a/drivers/clocksource/rockchip_timer.c b/drivers/clocksource/rockchip_timer.c
index 3ace7ac..9ed662a 100644
--- a/drivers/clocksource/rockchip_timer.c
+++ b/drivers/clocksource/rockchip_timer.c
@@ -17,16 +17,16 @@
 
 #define TIMER_NAME "rk_timer"
 
-#define TIMER_LOAD_COUNT0 0x00
-#define TIMER_LOAD_COUNT1 0x04
-#define TIMER_CONTROL_REG 0x10
-#define TIMER_INT_STATUS 0x18
+#define TIMER_LOAD_COUNT0	0x00
+#define TIMER_LOAD_COUNT1	0x04
+#define TIMER_CONTROL_REG	0x10
+#define TIMER_INT_STATUS	0x18
 
-#define TIMER_DISABLE 0x0
-#define TIMER_ENABLE 0x1
-#define TIMER_MODE_FREE_RUNNING (0 << 1)
-#define TIMER_MODE_USER_DEFINED_COUNT (1 << 1)
-#define TIMER_INT_UNMASK (1 << 2)
+#define TIMER_DISABLE		0x0
+#define TIMER_ENABLE		0x1
+#define TIMER_MODE_FREE_RUNNING			(0 << 1)
+#define TIMER_MODE_USER_DEFINED_COUNT		(1 << 1)
+#define TIMER_INT_UNMASK			(1 << 2)
 
 struct bc_timer {
 	struct clock_event_device ce;
@@ -173,4 +173,5 @@ static void __init rk_timer_init(struct device_node *np)
 
 	clockevents_config_and_register(ce, bc_timer.freq, 1, UINT_MAX);
 }
+
 CLOCKSOURCE_OF_DECLARE(rk_timer, "rockchip,rk3288-timer", rk_timer_init);
-- 
1.9.1

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1234712 — Re: [PATCH v2 2/4] clocksource: rockchip: trivial: Make the driver more readability

FromDaniel Lezcano <daniel.lezcano@linaro.org>
Date2015-09-29 06:20 +0200
SubjectRe: [PATCH v2 2/4] clocksource: rockchip: trivial: Make the driver more readability
Message-ID<qdUyu-3TN-7@gated-at.bofh.it>
In reply to#1232534
On 09/25/2015 04:14 AM, Caesar Wang wrote:
> Let's checkstyle to clean up the macros with such trivial details.
>
> Signed-off-by: Caesar Wang <wxt@rock-chips.com>
> ---

Acked-by: Daniel Lezcano <daniel.lezcano@linaro.org>

-- 
  <http://www.linaro.org/> Linaro.org │ Open source software for ARM SoCs

Follow Linaro:  <http://www.facebook.com/pages/Linaro> Facebook |
<http://twitter.com/#!/linaroorg> Twitter |
<http://www.linaro.org/linaro-blog/> Blog

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web