Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1232018 > unrolled thread

[PATCH] drm: drm_atomic_crtc_get_property should be static

Started byGeliang Tang <geliangtang@163.com>
First post2015-09-24 12:10 +0200
Last post2015-09-24 17:20 +0200
Articles 2 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH] drm: drm_atomic_crtc_get_property should be static Geliang Tang <geliangtang@163.com> - 2015-09-24 12:10 +0200
    Re: [PATCH] drm: drm_atomic_crtc_get_property should be static Daniel Vetter <daniel@ffwll.ch> - 2015-09-24 17:20 +0200

#1232018 — [PATCH] drm: drm_atomic_crtc_get_property should be static

FromGeliang Tang <geliangtang@163.com>
Date2015-09-24 12:10 +0200
Subject[PATCH] drm: drm_atomic_crtc_get_property should be static
Message-ID<qcbDu-8jL-73@gated-at.bofh.it>
Fixes the following sparse warning:
 drivers/gpu/drm/drm_atomic.c:442:5: warning: symbol
 'drm_atomic_crtc_get_property' was not declared. Should it be static?

Signed-off-by: Geliang Tang <geliangtang@163.com>
---
 drivers/gpu/drm/drm_atomic.c | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/drivers/gpu/drm/drm_atomic.c b/drivers/gpu/drm/drm_atomic.c
index 940f80b..7bb3845 100644
--- a/drivers/gpu/drm/drm_atomic.c
+++ b/drivers/gpu/drm/drm_atomic.c
@@ -438,7 +438,8 @@ EXPORT_SYMBOL(drm_atomic_crtc_set_property);
  * consistent behavior you must call this function rather than the
  * driver hook directly.
  */
-int drm_atomic_crtc_get_property(struct drm_crtc *crtc,
+static int
+drm_atomic_crtc_get_property(struct drm_crtc *crtc,
 		const struct drm_crtc_state *state,
 		struct drm_property *property, uint64_t *val)
 {
-- 
1.9.1


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1232185

FromDaniel Vetter <daniel@ffwll.ch>
Date2015-09-24 17:20 +0200
Message-ID<qcgtt-6OZ-21@gated-at.bofh.it>
In reply to#1232018
On Thu, Sep 24, 2015 at 03:01:03AM -0700, Geliang Tang wrote:
> Fixes the following sparse warning:
>  drivers/gpu/drm/drm_atomic.c:442:5: warning: symbol
>  'drm_atomic_crtc_get_property' was not declared. Should it be static?
> 
> Signed-off-by: Geliang Tang <geliangtang@163.com>

Applied to drm-misc, thansk.
-Daniel

> ---
>  drivers/gpu/drm/drm_atomic.c | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/drivers/gpu/drm/drm_atomic.c b/drivers/gpu/drm/drm_atomic.c
> index 940f80b..7bb3845 100644
> --- a/drivers/gpu/drm/drm_atomic.c
> +++ b/drivers/gpu/drm/drm_atomic.c
> @@ -438,7 +438,8 @@ EXPORT_SYMBOL(drm_atomic_crtc_set_property);
>   * consistent behavior you must call this function rather than the
>   * driver hook directly.
>   */
> -int drm_atomic_crtc_get_property(struct drm_crtc *crtc,
> +static int
> +drm_atomic_crtc_get_property(struct drm_crtc *crtc,
>  		const struct drm_crtc_state *state,
>  		struct drm_property *property, uint64_t *val)
>  {
> -- 
> 1.9.1
> 
> 
> _______________________________________________
> dri-devel mailing list
> dri-devel@lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/dri-devel

-- 
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web