Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1228466 > unrolled thread

[PATCH] char: ipmi: Move MODULE_DEVICE_TABLE() to follow struct

Started byLuis de Bethencourt <luisbg@osg.samsung.com>
First post2015-09-19 17:50 +0200
Last post2015-09-20 02:50 +0200
Articles 2 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH] char: ipmi: Move MODULE_DEVICE_TABLE() to follow struct Luis de Bethencourt <luisbg@osg.samsung.com> - 2015-09-19 17:50 +0200
    Re: [PATCH] char: ipmi: Move MODULE_DEVICE_TABLE() to follow struct Corey Minyard <minyard@acm.org> - 2015-09-20 02:50 +0200

#1228466 — [PATCH] char: ipmi: Move MODULE_DEVICE_TABLE() to follow struct

FromLuis de Bethencourt <luisbg@osg.samsung.com>
Date2015-09-19 17:50 +0200
Subject[PATCH] char: ipmi: Move MODULE_DEVICE_TABLE() to follow struct
Message-ID<qasyK-5Fx-9@gated-at.bofh.it>
The policy for drivers is to have MODULE_DEVICE_TABLE() just after the
struct used in it. For clarity.

Suggested-by: Corey Minyard <minyard@acm.org>
Signed-off-by: Luis de Bethencourt <luisbg@osg.samsung.com>
---

Suggested in:
https://lkml.org/lkml/2015/9/18/842

Thanks Corey,
Luis

 drivers/char/ipmi/ipmi_si_intf.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/char/ipmi/ipmi_si_intf.c b/drivers/char/ipmi/ipmi_si_intf.c
index 654f6f3..061fef0 100644
--- a/drivers/char/ipmi/ipmi_si_intf.c
+++ b/drivers/char/ipmi/ipmi_si_intf.c
@@ -2560,6 +2560,7 @@ static const struct of_device_id of_ipmi_match[] = {
 	  .data = (void *)(unsigned long) SI_BT },
 	{},
 };
+MODULE_DEVICE_TABLE(of, of_ipmi_match);
 
 static int of_ipmi_probe(struct platform_device *dev)
 {
@@ -2646,7 +2647,6 @@ static int of_ipmi_probe(struct platform_device *dev)
 	}
 	return 0;
 }
-MODULE_DEVICE_TABLE(of, of_ipmi_match);
 #else
 #define of_ipmi_match NULL
 static int of_ipmi_probe(struct platform_device *dev)
-- 
2.5.1

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1228806

FromCorey Minyard <minyard@acm.org>
Date2015-09-20 02:50 +0200
Message-ID<qaAZk-UZ-5@gated-at.bofh.it>
In reply to#1228466
Ok, queued for 4.4.

Thanks,

-corey

On 09/19/2015 10:43 AM, Luis de Bethencourt wrote:
> The policy for drivers is to have MODULE_DEVICE_TABLE() just after the
> struct used in it. For clarity.
>
> Suggested-by: Corey Minyard <minyard@acm.org>
> Signed-off-by: Luis de Bethencourt <luisbg@osg.samsung.com>
> ---
>
> Suggested in:
> https://lkml.org/lkml/2015/9/18/842
>
> Thanks Corey,
> Luis
>
>  drivers/char/ipmi/ipmi_si_intf.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/char/ipmi/ipmi_si_intf.c b/drivers/char/ipmi/ipmi_si_intf.c
> index 654f6f3..061fef0 100644
> --- a/drivers/char/ipmi/ipmi_si_intf.c
> +++ b/drivers/char/ipmi/ipmi_si_intf.c
> @@ -2560,6 +2560,7 @@ static const struct of_device_id of_ipmi_match[] = {
>  	  .data = (void *)(unsigned long) SI_BT },
>  	{},
>  };
> +MODULE_DEVICE_TABLE(of, of_ipmi_match);
>  
>  static int of_ipmi_probe(struct platform_device *dev)
>  {
> @@ -2646,7 +2647,6 @@ static int of_ipmi_probe(struct platform_device *dev)
>  	}
>  	return 0;
>  }
> -MODULE_DEVICE_TABLE(of, of_ipmi_match);
>  #else
>  #define of_ipmi_match NULL
>  static int of_ipmi_probe(struct platform_device *dev)

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web