Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1324832 > unrolled thread

[PATCH v2 1/2] rtlwifi: Fix improve function 'rtl_addr_delay()' in core.c

Started byByeoungwook Kim <quddnr145@gmail.com>
First post2016-02-03 03:20 +0100
Last post2016-02-03 07:10 +0100
Articles 4 — 3 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH v2 1/2] rtlwifi: Fix improve function 'rtl_addr_delay()' in  core.c Byeoungwook Kim <quddnr145@gmail.com> - 2016-02-03 03:20 +0100
    Re: [PATCH v2 1/2] rtlwifi: Fix improve function 'rtl_addr_delay()'  in core.c kbuild test robot <lkp@intel.com> - 2016-02-03 04:40 +0100
    [PATCH] rtlwifi: fix semicolon.cocci warnings kbuild test robot <lkp@intel.com> - 2016-02-03 04:40 +0100
      Re: [PATCH] rtlwifi: fix semicolon.cocci warnings Larry Finger <Larry.Finger@lwfinger.net> - 2016-02-03 07:10 +0100

#1324832 — [PATCH v2 1/2] rtlwifi: Fix improve function 'rtl_addr_delay()' in core.c

FromByeoungwook Kim <quddnr145@gmail.com>
Date2016-02-03 03:20 +0100
Subject[PATCH v2 1/2] rtlwifi: Fix improve function 'rtl_addr_delay()' in core.c
Message-ID<qXVd0-45u-9@gated-at.bofh.it>
Conditional codes in rtl_addr_delay() were improved in readability and
performance by using switch codes.

Signed-off-by: Byeoungwook Kim <quddnr145@gmail.com>
Reviewed-by: Julian Calaby <julian.calaby@gmail.com>
---
V2 split in separate patchs.
 drivers/net/wireless/realtek/rtlwifi/core.c | 20 ++++++++++++++------
 1 file changed, 14 insertions(+), 6 deletions(-)

diff --git a/drivers/net/wireless/realtek/rtlwifi/core.c b/drivers/net/wireless/realtek/rtlwifi/core.c
index 4ae421e..05f432c 100644
--- a/drivers/net/wireless/realtek/rtlwifi/core.c
+++ b/drivers/net/wireless/realtek/rtlwifi/core.c
@@ -37,18 +37,26 @@
 
 void rtl_addr_delay(u32 addr)
 {
-	if (addr == 0xfe)
+	switch (addr) {
+	case 0xfe:
 		mdelay(50);
-	else if (addr == 0xfd)
+		break;
+	case 0xfd:
 		mdelay(5);
-	else if (addr == 0xfc)
+		break;
+	case 0xfc:
 		mdelay(1);
-	else if (addr == 0xfb)
+		break;
+	case 0xfb:
 		udelay(50);
-	else if (addr == 0xfa)
+		break;
+	case 0xfa:
 		udelay(5);
-	else if (addr == 0xf9)
+		break;
+	case 0xf9:
 		udelay(1);
+		break;
+	};
 }
 EXPORT_SYMBOL(rtl_addr_delay);
 
-- 
2.5.0

[toc] | [next] | [standalone]


#1324878 — Re: [PATCH v2 1/2] rtlwifi: Fix improve function 'rtl_addr_delay()' in core.c

Fromkbuild test robot <lkp@intel.com>
Date2016-02-03 04:40 +0100
SubjectRe: [PATCH v2 1/2] rtlwifi: Fix improve function 'rtl_addr_delay()' in core.c
Message-ID<qXWsp-4TV-1@gated-at.bofh.it>
In reply to#1324832
Hi Byeoungwook,

[auto build test WARNING on wireless-drivers-next/master]
[also build test WARNING on v4.5-rc2 next-20160202]
[if your patch is applied to the wrong git tree, please drop us a note to help improving the system]

url:    https://github.com/0day-ci/linux/commits/Byeoungwook-Kim/rtlwifi-Fix-improve-function-rtl_addr_delay-in-core-c/20160203-101854
base:   https://git.kernel.org/pub/scm/linux/kernel/git/kvalo/wireless-drivers-next.git master


coccinelle warnings: (new ones prefixed by >>)

>> drivers/net/wireless/realtek/rtlwifi/core.c:59:2-3: Unneeded semicolon

Please review and possibly fold the followup patch.

---
0-DAY kernel test infrastructure                Open Source Technology Center
https://lists.01.org/pipermail/kbuild-all                   Intel Corporation

[toc] | [prev] | [next] | [standalone]


#1324881 — [PATCH] rtlwifi: fix semicolon.cocci warnings

Fromkbuild test robot <lkp@intel.com>
Date2016-02-03 04:40 +0100
Subject[PATCH] rtlwifi: fix semicolon.cocci warnings
Message-ID<qXWsq-4TV-15@gated-at.bofh.it>
In reply to#1324832
drivers/net/wireless/realtek/rtlwifi/core.c:59:2-3: Unneeded semicolon


 Remove unneeded semicolon.

Generated by: scripts/coccinelle/misc/semicolon.cocci

CC: Byeoungwook Kim <quddnr145@gmail.com>
Signed-off-by: Fengguang Wu <fengguang.wu@intel.com>
---

 core.c |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

--- a/drivers/net/wireless/realtek/rtlwifi/core.c
+++ b/drivers/net/wireless/realtek/rtlwifi/core.c
@@ -56,7 +56,7 @@ void rtl_addr_delay(u32 addr)
 	case 0xf9:
 		udelay(1);
 		break;
-	};
+	}
 }
 EXPORT_SYMBOL(rtl_addr_delay);
 

[toc] | [prev] | [next] | [standalone]


#1324939 — Re: [PATCH] rtlwifi: fix semicolon.cocci warnings

FromLarry Finger <Larry.Finger@lwfinger.net>
Date2016-02-03 07:10 +0100
SubjectRe: [PATCH] rtlwifi: fix semicolon.cocci warnings
Message-ID<qXYNz-6z9-3@gated-at.bofh.it>
In reply to#1324881
On 02/02/2016 09:40 PM, kbuild test robot wrote:
> drivers/net/wireless/realtek/rtlwifi/core.c:59:2-3: Unneeded semicolon
>
>
>   Remove unneeded semicolon.
>
> Generated by: scripts/coccinelle/misc/semicolon.cocci
>
> CC: Byeoungwook Kim <quddnr145@gmail.com>
> Signed-off-by: Fengguang Wu <fengguang.wu@intel.com>
> ---

Acked-by: Larry Finger <Larry.Finger@lwfinger.net>

Thanks,

Larry

>
>   core.c |    2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
>
> --- a/drivers/net/wireless/realtek/rtlwifi/core.c
> +++ b/drivers/net/wireless/realtek/rtlwifi/core.c
> @@ -56,7 +56,7 @@ void rtl_addr_delay(u32 addr)
>   	case 0xf9:
>   		udelay(1);
>   		break;
> -	};
> +	}
>   }
>   EXPORT_SYMBOL(rtl_addr_delay);
>
>

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web