Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1324092 > unrolled thread

[PATCH v2 00/11] android sync framework: clean up IOCTLs and ABI

Started byGustavo Padovan <gustavo@padovan.org>
First post2016-02-02 14:30 +0100
Last post2016-02-02 19:50 +0100
Articles 4 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH v2 00/11] android sync framework: clean up IOCTLs and ABI Gustavo Padovan <gustavo@padovan.org> - 2016-02-02 14:30 +0100
    [PATCH v2 08/11] staging/android: make info->len return only the size of fence_infos Gustavo Padovan <gustavo@padovan.org> - 2016-02-02 14:50 +0100
      Re: [PATCH v2 08/11] staging/android: make info->len return only the  size of fence_infos Maarten Lankhorst <maarten.lankhorst@linux.intel.com> - 2016-02-02 15:20 +0100
        Re: [PATCH v2 08/11] staging/android: make info->len return only the  size of fence_infos Gustavo Padovan <gustavo@padovan.org> - 2016-02-02 19:50 +0100

#1324092 — [PATCH v2 00/11] android sync framework: clean up IOCTLs and ABI

FromGustavo Padovan <gustavo@padovan.org>
Date2016-02-02 14:30 +0100
Subject[PATCH v2 00/11] android sync framework: clean up IOCTLs and ABI
Message-ID<qXJbQ-3xo-13@gated-at.bofh.it>
From: Gustavo Padovan <gustavo.padovan@collabora.co.uk>

Hi,

This patch series clean up IOCTLs and abi of sync framework and it is a follow
up on the clean up series I've sent on Jan 21:

http://thread.gmane.org/gmane.comp.video.dri.devel/145509

The main changes here are:

* remove of SYNC_WAIT ioctl, poll() should be used instead.
* rename some structs and macros to better reflect the new internal names.
* clean up and improve ABI on SYNC_IOC_FILE_INFO
* add flags filed to all ABI structs
* make sync_file_info->len return only the size of the array of fence_infos

v2:
	- Check flags passed to the kernel (Maarten)
	- Rework len to report only the size of fence_infos array (Emil)
	- Fix fence_info type. Use __u64 pointer type (Emil, Maarten)

Please review! Thanks.

Gustavo Padovan (11):
  staging/android: remove SYNC_WAIT ioctl
  staging/android: rename sync_pt_info to fence_info
  staging/android: rename sync_file_info_data to sync_file_info
  staging/android: remove driver_data from struct fence_info
  staging/android: remove len field from struct fence_info
  staging/android: turn fence_info into a __u64 pointer
  staging/android: add num_fences field to struct sync_file_info
  staging/android: make info->len return only the size of fence_infos
  staging/android: rename SYNC_IOC_FENCE_INFO
  staging/android: add flags member to sync ioctl structs
  staging/android: remove redundant comments on sync_merge_data

 drivers/staging/android/sw_sync.c    |  14 ----
 drivers/staging/android/sync.c       | 128 +++++++++--------------------------
 drivers/staging/android/sync.h       |  20 ------
 drivers/staging/android/trace/sync.h |  44 ------------
 drivers/staging/android/uapi/sync.h  |  50 ++++++--------
 5 files changed, 55 insertions(+), 201 deletions(-)

-- 
2.5.0

[toc] | [next] | [standalone]


#1324103 — [PATCH v2 08/11] staging/android: make info->len return only the size of fence_infos

FromGustavo Padovan <gustavo@padovan.org>
Date2016-02-02 14:50 +0100
Subject[PATCH v2 08/11] staging/android: make info->len return only the size of fence_infos
Message-ID<qXJvc-3G9-15@gated-at.bofh.it>
In reply to#1324092
From: Gustavo Padovan <gustavo.padovan@collabora.co.uk>

The len member of struct sync_file_info was returning the size of the whole
buffer (struct sync_file_info + fence_infos at the of it). This commit
change it to return only the size of the array of fence_infos.

It also moves len to be right before the fences_infos struct.

Signed-off-by: Gustavo Padovan <gustavo.padovan@collabora.co.uk>
---
 drivers/staging/android/sync.c      | 16 +++++++++++-----
 drivers/staging/android/uapi/sync.h |  7 +++----
 2 files changed, 14 insertions(+), 9 deletions(-)

diff --git a/drivers/staging/android/sync.c b/drivers/staging/android/sync.c
index ba7d461..e5fbf5a 100644
--- a/drivers/staging/android/sync.c
+++ b/drivers/staging/android/sync.c
@@ -502,14 +502,19 @@ static int sync_fill_fence_info(struct fence *fence, void *data, int size)
 static long sync_file_ioctl_fence_info(struct sync_file *sync_file,
 					unsigned long arg)
 {
-	struct sync_file_info *info;
+	struct sync_file_info in, *info;
 	__u32 size;
-	__u32 len = 0;
+	__u32 b_len, len = 0;
 	int ret, i;
 
-	if (copy_from_user(&size, (void __user *)arg, sizeof(size)))
+	if (copy_from_user(&in, (void __user *)arg, sizeof(*info)))
 		return -EFAULT;
 
+	if (in.name || in.status || in.num_fences || in.fence_info)
+		return -EFAULT;
+
+	size = in.len;
+
 	if (size < sizeof(struct sync_file_info))
 		return -EINVAL;
 
@@ -527,8 +532,9 @@ static long sync_file_ioctl_fence_info(struct sync_file *sync_file,
 
 	info->num_fences = sync_file->num_fences;
 
-	len = sizeof(struct sync_file_info) - sizeof(__u64);
+	b_len = sizeof(struct sync_file_info) - sizeof(__u64);
 
+	len = b_len;
 	for (i = 0; i < sync_file->num_fences; ++i) {
 		struct fence *fence = sync_file->cbs[i].fence;
 
@@ -540,7 +546,7 @@ static long sync_file_ioctl_fence_info(struct sync_file *sync_file,
 		len += ret;
 	}
 
-	info->len = len;
+	info->len = len - b_len;
 
 	if (copy_to_user((void __user *)arg, info, len))
 		ret = -EFAULT;
diff --git a/drivers/staging/android/uapi/sync.h b/drivers/staging/android/uapi/sync.h
index 01a10b7..9ad3763 100644
--- a/drivers/staging/android/uapi/sync.h
+++ b/drivers/staging/android/uapi/sync.h
@@ -42,19 +42,18 @@ struct fence_info {
 
 /**
  * struct sync_file_info - data returned from fence info ioctl
- * @len:	ioctl caller writes the size of the buffer its passing in.
- *		ioctl returns length of sync_file_info returned to
- *		userspace including pt_info.
  * @name:	name of fence
  * @status:	status of fence. 1: signaled 0:active <0:error
  * @num_fences	number of fences in the sync_file
+ * @len:	ioctl caller writes the size of the buffer its passing in.
+ *		ioctl returns length of all fence_infos summed.
  * @fence_info:	a fence_info struct for every fence in the sync_file
  */
 struct sync_file_info {
-	__u32	len;
 	char	name[32];
 	__s32	status;
 	__u32	num_fences;
+	__u32	len;
 
 	__u64	fence_info;
 };
-- 
2.5.0

[toc] | [prev] | [next] | [standalone]


#1324113 — Re: [PATCH v2 08/11] staging/android: make info->len return only the size of fence_infos

FromMaarten Lankhorst <maarten.lankhorst@linux.intel.com>
Date2016-02-02 15:20 +0100
SubjectRe: [PATCH v2 08/11] staging/android: make info->len return only the size of fence_infos
Message-ID<qXJYe-47e-5@gated-at.bofh.it>
In reply to#1324103
Op 02-02-16 om 14:23 schreef Gustavo Padovan:
> From: Gustavo Padovan <gustavo.padovan@collabora.co.uk>
>
> The len member of struct sync_file_info was returning the size of the whole
> buffer (struct sync_file_info + fence_infos at the of it). This commit
> change it to return only the size of the array of fence_infos.
>
> It also moves len to be right before the fences_infos struct.
>
> Signed-off-by: Gustavo Padovan <gustavo.padovan@collabora.co.uk>
> ---
>  drivers/staging/android/sync.c      | 16 +++++++++++-----
>  drivers/staging/android/uapi/sync.h |  7 +++----
>  2 files changed, 14 insertions(+), 9 deletions(-)
>
> diff --git a/drivers/staging/android/sync.c b/drivers/staging/android/sync.c
> index ba7d461..e5fbf5a 100644
> --- a/drivers/staging/android/sync.c
> +++ b/drivers/staging/android/sync.c
> @@ -502,14 +502,19 @@ static int sync_fill_fence_info(struct fence *fence, void *data, int size)
>  static long sync_file_ioctl_fence_info(struct sync_file *sync_file,
>  					unsigned long arg)
>  {
> -	struct sync_file_info *info;
> +	struct sync_file_info in, *info;
>  	__u32 size;
> -	__u32 len = 0;
> +	__u32 b_len, len = 0;
>  	int ret, i;
>  
> -	if (copy_from_user(&size, (void __user *)arg, sizeof(size)))
> +	if (copy_from_user(&in, (void __user *)arg, sizeof(*info)))
>  		return -EFAULT;
>  
> +	if (in.name || in.status || in.num_fences || in.fence_info)
> +		return -EFAULT;
>
Did you test this? I think in.name is always true..

[toc] | [prev] | [next] | [standalone]


#1324461 — Re: [PATCH v2 08/11] staging/android: make info->len return only the size of fence_infos

FromGustavo Padovan <gustavo@padovan.org>
Date2016-02-02 19:50 +0100
SubjectRe: [PATCH v2 08/11] staging/android: make info->len return only the size of fence_infos
Message-ID<qXObw-7av-21@gated-at.bofh.it>
In reply to#1324113
2016-02-02 Maarten Lankhorst <maarten.lankhorst@linux.intel.com>:

> Op 02-02-16 om 14:23 schreef Gustavo Padovan:
> > From: Gustavo Padovan <gustavo.padovan@collabora.co.uk>
> >
> > The len member of struct sync_file_info was returning the size of the whole
> > buffer (struct sync_file_info + fence_infos at the of it). This commit
> > change it to return only the size of the array of fence_infos.
> >
> > It also moves len to be right before the fences_infos struct.
> >
> > Signed-off-by: Gustavo Padovan <gustavo.padovan@collabora.co.uk>
> > ---
> >  drivers/staging/android/sync.c      | 16 +++++++++++-----
> >  drivers/staging/android/uapi/sync.h |  7 +++----
> >  2 files changed, 14 insertions(+), 9 deletions(-)
> >
> > diff --git a/drivers/staging/android/sync.c b/drivers/staging/android/sync.c
> > index ba7d461..e5fbf5a 100644
> > --- a/drivers/staging/android/sync.c
> > +++ b/drivers/staging/android/sync.c
> > @@ -502,14 +502,19 @@ static int sync_fill_fence_info(struct fence *fence, void *data, int size)
> >  static long sync_file_ioctl_fence_info(struct sync_file *sync_file,
> >  					unsigned long arg)
> >  {
> > -	struct sync_file_info *info;
> > +	struct sync_file_info in, *info;
> >  	__u32 size;
> > -	__u32 len = 0;
> > +	__u32 b_len, len = 0;
> >  	int ret, i;
> >  
> > -	if (copy_from_user(&size, (void __user *)arg, sizeof(size)))
> > +	if (copy_from_user(&in, (void __user *)arg, sizeof(*info)))
> >  		return -EFAULT;
> >  
> > +	if (in.name || in.status || in.num_fences || in.fence_info)
> > +		return -EFAULT;
> >
> Did you test this? I think in.name is always true..

Ugh, no! These checks were last change I made so I think I forgot to
test them properly.

	Gustavo

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web