Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1316384 > unrolled thread
| Started by | Mel Gorman <mgorman@techsingularity.net> |
|---|---|
| First post | 2016-01-25 11:10 +0100 |
| Last post | 2016-01-25 12:40 +0100 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
[PATCH 1/2] mm: filemap: Remove redundant code in do_read_cache_page Mel Gorman <mgorman@techsingularity.net> - 2016-01-25 11:10 +0100
Re: [PATCH 1/2] mm: filemap: Remove redundant code in do_read_cache_page Jan Kara <jack@suse.cz> - 2016-01-25 12:40 +0100
| From | Mel Gorman <mgorman@techsingularity.net> |
|---|---|
| Date | 2016-01-25 11:10 +0100 |
| Subject | [PATCH 1/2] mm: filemap: Remove redundant code in do_read_cache_page |
| Message-ID | <qUMfV-2lm-9@gated-at.bofh.it> |
do_read_cache_page and __read_cache_page duplicates page filler code
when filling the page for the first time. This patch simply removes the
duplicate logic.
Signed-off-by: Mel Gorman <mgorman@techsingularity.net>
---
mm/filemap.c | 43 ++++++++++++-------------------------------
1 file changed, 12 insertions(+), 31 deletions(-)
diff --git a/mm/filemap.c b/mm/filemap.c
index bc943867d68c..aa38593d0cd5 100644
--- a/mm/filemap.c
+++ b/mm/filemap.c
@@ -2283,7 +2283,7 @@ static struct page *wait_on_page_read(struct page *page)
return page;
}
-static struct page *__read_cache_page(struct address_space *mapping,
+static struct page *do_read_cache_page(struct address_space *mapping,
pgoff_t index,
int (*filler)(void *, struct page *),
void *data,
@@ -2305,31 +2305,19 @@ static struct page *__read_cache_page(struct address_space *mapping,
/* Presumably ENOMEM for radix tree node */
return ERR_PTR(err);
}
+
+filler:
err = filler(data, page);
if (err < 0) {
page_cache_release(page);
- page = ERR_PTR(err);
- } else {
- page = wait_on_page_read(page);
+ return ERR_PTR(err);
}
- }
- return page;
-}
-
-static struct page *do_read_cache_page(struct address_space *mapping,
- pgoff_t index,
- int (*filler)(void *, struct page *),
- void *data,
- gfp_t gfp)
-
-{
- struct page *page;
- int err;
-retry:
- page = __read_cache_page(mapping, index, filler, data, gfp);
- if (IS_ERR(page))
- return page;
+ page = wait_on_page_read(page);
+ if (IS_ERR(page))
+ return page;
+ goto out;
+ }
if (PageUptodate(page))
goto out;
@@ -2337,21 +2325,14 @@ static struct page *do_read_cache_page(struct address_space *mapping,
if (!page->mapping) {
unlock_page(page);
page_cache_release(page);
- goto retry;
+ goto repeat;
}
if (PageUptodate(page)) {
unlock_page(page);
goto out;
}
- err = filler(data, page);
- if (err < 0) {
- page_cache_release(page);
- return ERR_PTR(err);
- } else {
- page = wait_on_page_read(page);
- if (IS_ERR(page))
- return page;
- }
+ goto filler;
+
out:
mark_page_accessed(page);
return page;
--
2.6.4
[toc] | [next] | [standalone]
| From | Jan Kara <jack@suse.cz> |
|---|---|
| Date | 2016-01-25 12:40 +0100 |
| Subject | Re: [PATCH 1/2] mm: filemap: Remove redundant code in do_read_cache_page |
| Message-ID | <qUNF1-3cn-19@gated-at.bofh.it> |
| In reply to | #1316384 |
On Mon 25-01-16 10:03:23, Mel Gorman wrote:
> do_read_cache_page and __read_cache_page duplicates page filler code
> when filling the page for the first time. This patch simply removes the
> duplicate logic.
>
> Signed-off-by: Mel Gorman <mgorman@techsingularity.net>
Looks good to me. You can add:
Reviewed-by: Jan Kara <jack@suse.cz>
Honza
> ---
> mm/filemap.c | 43 ++++++++++++-------------------------------
> 1 file changed, 12 insertions(+), 31 deletions(-)
>
> diff --git a/mm/filemap.c b/mm/filemap.c
> index bc943867d68c..aa38593d0cd5 100644
> --- a/mm/filemap.c
> +++ b/mm/filemap.c
> @@ -2283,7 +2283,7 @@ static struct page *wait_on_page_read(struct page *page)
> return page;
> }
>
> -static struct page *__read_cache_page(struct address_space *mapping,
> +static struct page *do_read_cache_page(struct address_space *mapping,
> pgoff_t index,
> int (*filler)(void *, struct page *),
> void *data,
> @@ -2305,31 +2305,19 @@ static struct page *__read_cache_page(struct address_space *mapping,
> /* Presumably ENOMEM for radix tree node */
> return ERR_PTR(err);
> }
> +
> +filler:
> err = filler(data, page);
> if (err < 0) {
> page_cache_release(page);
> - page = ERR_PTR(err);
> - } else {
> - page = wait_on_page_read(page);
> + return ERR_PTR(err);
> }
> - }
> - return page;
> -}
> -
> -static struct page *do_read_cache_page(struct address_space *mapping,
> - pgoff_t index,
> - int (*filler)(void *, struct page *),
> - void *data,
> - gfp_t gfp)
> -
> -{
> - struct page *page;
> - int err;
>
> -retry:
> - page = __read_cache_page(mapping, index, filler, data, gfp);
> - if (IS_ERR(page))
> - return page;
> + page = wait_on_page_read(page);
> + if (IS_ERR(page))
> + return page;
> + goto out;
> + }
> if (PageUptodate(page))
> goto out;
>
> @@ -2337,21 +2325,14 @@ static struct page *do_read_cache_page(struct address_space *mapping,
> if (!page->mapping) {
> unlock_page(page);
> page_cache_release(page);
> - goto retry;
> + goto repeat;
> }
> if (PageUptodate(page)) {
> unlock_page(page);
> goto out;
> }
> - err = filler(data, page);
> - if (err < 0) {
> - page_cache_release(page);
> - return ERR_PTR(err);
> - } else {
> - page = wait_on_page_read(page);
> - if (IS_ERR(page))
> - return page;
> - }
> + goto filler;
> +
> out:
> mark_page_accessed(page);
> return page;
> --
> 2.6.4
>
--
Jan Kara <jack@suse.com>
SUSE Labs, CR
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web