Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1311440 > unrolled thread
| Started by | Wei Ni <wni@nvidia.com> |
|---|---|
| First post | 2016-01-18 11:10 +0100 |
| Last post | 2016-01-25 07:00 +0100 |
| Articles | 3 — 2 participants |
Back to article view | Back to linux.kernel
[PATCH V3 06/11] thermal: tegra: add a debugfs to show registers Wei Ni <wni@nvidia.com> - 2016-01-18 11:10 +0100
Re: [PATCH V3 06/11] thermal: tegra: add a debugfs to show registers Thierry Reding <thierry.reding@gmail.com> - 2016-01-21 16:00 +0100
Re: [PATCH V3 06/11] thermal: tegra: add a debugfs to show registers Wei Ni <wni@nvidia.com> - 2016-01-25 07:00 +0100
| From | Wei Ni <wni@nvidia.com> |
|---|---|
| Date | 2016-01-18 11:10 +0100 |
| Subject | [PATCH V3 06/11] thermal: tegra: add a debugfs to show registers |
| Message-ID | <qSeV4-7C5-23@gated-at.bofh.it> |
Add a debugfs interface to show register contents for debug.
Signed-off-by: Wei Ni <wni@nvidia.com>
---
drivers/thermal/tegra/soctherm.c | 145 ++++++++++++++++++++++++++++++++++++++-
drivers/thermal/tegra/soctherm.h | 2 +
2 files changed, 144 insertions(+), 3 deletions(-)
diff --git a/drivers/thermal/tegra/soctherm.c b/drivers/thermal/tegra/soctherm.c
index dd527e5ae4c3..1b5ff99d36f9 100644
--- a/drivers/thermal/tegra/soctherm.c
+++ b/drivers/thermal/tegra/soctherm.c
@@ -15,6 +15,7 @@
*
*/
+#include <linux/debugfs.h>
#include <linux/bitops.h>
#include <linux/clk.h>
#include <linux/delay.h>
@@ -33,14 +34,18 @@
#define SENSOR_CONFIG0 0
#define SENSOR_CONFIG0_STOP BIT(0)
-#define SENSOR_CONFIG0_TALL_SHIFT 8
-#define SENSOR_CONFIG0_TCALC_OVER BIT(4)
-#define SENSOR_CONFIG0_OVER BIT(3)
#define SENSOR_CONFIG0_CPTR_OVER BIT(2)
+#define SENSOR_CONFIG0_OVER BIT(3)
+#define SENSOR_CONFIG0_TCALC_OVER BIT(4)
+#define SENSOR_CONFIG0_TALL_MASK (0xfffff << 8)
+#define SENSOR_CONFIG0_TALL_SHIFT 8
#define SENSOR_CONFIG1 4
+#define SENSOR_CONFIG1_TSAMPLE_MASK 0x3ff
#define SENSOR_CONFIG1_TSAMPLE_SHIFT 0
+#define SENSOR_CONFIG1_TIDDQ_EN_MASK (0x3f << 15)
#define SENSOR_CONFIG1_TIDDQ_EN_SHIFT 15
+#define SENSOR_CONFIG1_TEN_COUNT_MASK (0x3f << 24)
#define SENSOR_CONFIG1_TEN_COUNT_SHIFT 24
#define SENSOR_CONFIG1_TEMP_ENABLE BIT(31)
@@ -49,6 +54,14 @@
* because, it will be used by tegra_soctherm_fuse.c
*/
+#define SENSOR_STATUS0 0xc
+#define SENSOR_STATUS0_VALID_MASK BIT(31)
+#define SENSOR_STATUS0_CAPTURE_MASK 0xffff
+
+#define SENSOR_STATUS1 0x10
+#define SENSOR_STATUS1_TEMP_VALID_MASK BIT(31)
+#define SENSOR_STATUS1_TEMP_MASK 0xffff
+
#define READBACK_VALUE_MASK 0xff00
#define READBACK_VALUE_SHIFT 8
#define READBACK_ADD_HALF BIT(7)
@@ -72,6 +85,9 @@ struct tegra_soctherm {
void __iomem *regs;
struct thermal_zone_device *thermctl_tzs[TEGRA124_SOCTHERM_SENSOR_NUM];
+ struct tegra_soctherm_soc *soc;
+
+ struct dentry *debugfs_dir;
};
static int enable_tsensor(struct tegra_soctherm *tegra,
@@ -137,6 +153,121 @@ static const struct thermal_zone_of_device_ops tegra_of_thermal_ops = {
.get_temp = tegra_thermctl_get_temp,
};
+#ifdef CONFIG_DEBUG_FS
+static int regs_show(struct seq_file *s, void *data)
+{
+ struct platform_device *pdev = s->private;
+ struct tegra_soctherm *ts = platform_get_drvdata(pdev);
+ struct tegra_tsensor *tsensors = ts->soc->tsensors;
+ u32 r, state;
+ int i;
+
+ seq_puts(s, "-----TSENSE (convert HW)-----\n");
+
+ for (i = 0; i < ts->soc->num_tsensors; i++) {
+ r = readl(ts->regs + tsensors[i].base + SENSOR_CONFIG1);
+ state = REG_GET_MASK(r, SENSOR_CONFIG1_TEMP_ENABLE);
+ if (!state)
+ continue;
+
+ seq_printf(s, "%s: ", tsensors[i].name);
+
+ seq_printf(s, "En(%d) ", state);
+ state = REG_GET_MASK(r, SENSOR_CONFIG1_TIDDQ_EN_MASK);
+ seq_printf(s, "tiddq(%d) ", state);
+ state = REG_GET_MASK(r, SENSOR_CONFIG1_TEN_COUNT_MASK);
+ seq_printf(s, "ten_count(%d) ", state);
+ state = REG_GET_MASK(r, SENSOR_CONFIG1_TSAMPLE_MASK);
+ seq_printf(s, "tsample(%d) ", state + 1);
+
+ r = readl(ts->regs + tsensors[i].base + SENSOR_STATUS1);
+ state = REG_GET_MASK(r, SENSOR_STATUS1_TEMP_VALID_MASK);
+ seq_printf(s, "Temp(%d/", state);
+ state = REG_GET_MASK(r, SENSOR_STATUS1_TEMP_MASK);
+ seq_printf(s, "%d) ", translate_temp(state));
+
+ r = readl(ts->regs + tsensors[i].base + SENSOR_STATUS0);
+ state = REG_GET_MASK(r, SENSOR_STATUS0_VALID_MASK);
+ seq_printf(s, "Capture(%d/", state);
+ state = REG_GET_MASK(r, SENSOR_STATUS0_CAPTURE_MASK);
+ seq_printf(s, "%d) ", state);
+
+ r = readl(ts->regs + tsensors[i].base + SENSOR_CONFIG0);
+ state = REG_GET_MASK(r, SENSOR_CONFIG0_STOP);
+ seq_printf(s, "Stop(%d) ", state);
+ state = REG_GET_MASK(r, SENSOR_CONFIG0_TALL_MASK);
+ seq_printf(s, "Tall(%d) ", state);
+ state = REG_GET_MASK(r, SENSOR_CONFIG0_TCALC_OVER);
+ seq_printf(s, "Over(%d/", state);
+ state = REG_GET_MASK(r, SENSOR_CONFIG0_OVER);
+ seq_printf(s, "%d/", state);
+ state = REG_GET_MASK(r, SENSOR_CONFIG0_CPTR_OVER);
+ seq_printf(s, "%d) ", state);
+
+ r = readl(ts->regs + tsensors[i].base + SENSOR_CONFIG2);
+ state = REG_GET_MASK(r, SENSOR_CONFIG2_THERMA_MASK);
+ seq_printf(s, "Therm_A/B(%d/", state);
+ state = REG_GET_MASK(r, SENSOR_CONFIG2_THERMB_MASK);
+ seq_printf(s, "%d)\n", (s16)state);
+ }
+
+ r = readl(ts->regs + SENSOR_PDIV);
+ seq_printf(s, "PDIV: 0x%x\n", r);
+
+ r = readl(ts->regs + SENSOR_HOTSPOT_OFF);
+ seq_printf(s, "HOTSPOT: 0x%x\n", r);
+
+ seq_puts(s, "\n");
+ seq_puts(s, "-----SOC_THERM-----\n");
+
+ r = readl(ts->regs + SENSOR_TEMP1);
+ state = REG_GET_MASK(r, SENSOR_TEMP1_CPU_TEMP_MASK);
+ seq_printf(s, "Temperatures: CPU(%d) ", translate_temp(state));
+ state = REG_GET_MASK(r, SENSOR_TEMP1_GPU_TEMP_MASK);
+ seq_printf(s, " GPU(%d) ", translate_temp(state));
+ r = readl(ts->regs + SENSOR_TEMP2);
+ state = REG_GET_MASK(r, SENSOR_TEMP2_PLLX_TEMP_MASK);
+ seq_printf(s, " PLLX(%d) ", translate_temp(state));
+ state = REG_GET_MASK(r, SENSOR_TEMP2_MEM_TEMP_MASK);
+ seq_printf(s, " MEM(%d)\n", translate_temp(state));
+
+ return 0;
+}
+
+static int regs_open(struct inode *inode, struct file *file)
+{
+ return single_open(file, regs_show, inode->i_private);
+}
+
+static const struct file_operations regs_fops = {
+ .open = regs_open,
+ .read = seq_read,
+ .llseek = seq_lseek,
+ .release = single_release,
+};
+
+static void soctherm_debug_init(struct platform_device *pdev)
+{
+ struct tegra_soctherm *tegra = platform_get_drvdata(pdev);
+ struct dentry *root, *file;
+
+ root = debugfs_create_dir("tegra_soctherm", NULL);
+ if (!root) {
+ dev_err(&pdev->dev, "failed to create debugfs directory\n");
+ return;
+ }
+
+ tegra->debugfs_dir = root;
+
+ file = debugfs_create_file("regs", 0644, root, pdev, ®s_fops);
+ if (!file)
+ dev_err(&pdev->dev, "failed to create debugfs file\n");
+}
+#else
+static inline void soctherm_debug_init(struct platform_device *pdev)
+{ return 0; }
+#endif
+
static const struct of_device_id tegra_soctherm_of_match[] = {
#ifdef CONFIG_ARCH_TEGRA_124_SOC
{
@@ -178,6 +309,10 @@ static int tegra_soctherm_probe(struct platform_device *pdev)
if (!tegra)
return -ENOMEM;
+ dev_set_drvdata(&pdev->dev, tegra);
+
+ tegra->soc = soc;
+
res = platform_get_resource(pdev, IORESOURCE_MEM, 0);
tegra->regs = devm_ioremap_resource(&pdev->dev, res);
if (IS_ERR(tegra->regs))
@@ -270,6 +405,8 @@ static int tegra_soctherm_probe(struct platform_device *pdev)
tegra->thermctl_tzs[soc->ttgs[i]->id] = tz;
}
+ soctherm_debug_init(pdev);
+
return 0;
unregister_tzs:
@@ -289,6 +426,8 @@ static int tegra_soctherm_remove(struct platform_device *pdev)
struct tegra_soctherm *tegra = platform_get_drvdata(pdev);
unsigned int i;
+ debugfs_remove_recursive(tegra->debugfs_dir);
+
for (i = 0; i < ARRAY_SIZE(tegra->thermctl_tzs); ++i) {
thermal_zone_of_sensor_unregister(&pdev->dev,
tegra->thermctl_tzs[i]);
diff --git a/drivers/thermal/tegra/soctherm.h b/drivers/thermal/tegra/soctherm.h
index bd0f03bc9d80..d3583223d76c 100644
--- a/drivers/thermal/tegra/soctherm.h
+++ b/drivers/thermal/tegra/soctherm.h
@@ -16,7 +16,9 @@
#define __DRIVERS_THERMAL_TEGRA_SOCTHERM_H
#define SENSOR_CONFIG2 8
+#define SENSOR_CONFIG2_THERMA_MASK (0xffff << 16)
#define SENSOR_CONFIG2_THERMA_SHIFT 16
+#define SENSOR_CONFIG2_THERMB_MASK 0xffff
#define SENSOR_CONFIG2_THERMB_SHIFT 0
#define SENSOR_PDIV 0x1c0
--
1.9.1
[toc] | [next] | [standalone]
| From | Thierry Reding <thierry.reding@gmail.com> |
|---|---|
| Date | 2016-01-21 16:00 +0100 |
| Message-ID | <qToSn-6CC-35@gated-at.bofh.it> |
| In reply to | #1311440 |
[Multipart message — attachments visible in raw view] — view raw
On Mon, Jan 18, 2016 at 06:03:57PM +0800, Wei Ni wrote:
[...]
> diff --git a/drivers/thermal/tegra/soctherm.c b/drivers/thermal/tegra/soctherm.c
[...]
> +static void soctherm_debug_init(struct platform_device *pdev)
> +{
> + struct tegra_soctherm *tegra = platform_get_drvdata(pdev);
> + struct dentry *root, *file;
> +
> + root = debugfs_create_dir("tegra_soctherm", NULL);
Perhaps leave away the tegra_ prefix here? It's kind of redundant.
> + if (!root) {
> + dev_err(&pdev->dev, "failed to create debugfs directory\n");
> + return;
> + }
> +
> + tegra->debugfs_dir = root;
> +
> + file = debugfs_create_file("regs", 0644, root, pdev, ®s_fops);
Can we call this something different, please? "summary" would be a
better name, in my opinion.
> + if (!file)
> + dev_err(&pdev->dev, "failed to create debugfs file\n");
> +}
> +#else
> +static inline void soctherm_debug_init(struct platform_device *pdev)
> +{ return 0; }
Please follow the regular CodingStyle here, too:
...
{
return 0;
}
> @@ -178,6 +309,10 @@ static int tegra_soctherm_probe(struct platform_device *pdev)
> if (!tegra)
> return -ENOMEM;
>
> + dev_set_drvdata(&pdev->dev, tegra);
> +
> + tegra->soc = soc;
This looks odd here. Does this perhaps belong in one of the previous
patches?
Thierry
[toc] | [prev] | [next] | [standalone]
| From | Wei Ni <wni@nvidia.com> |
|---|---|
| Date | 2016-01-25 07:00 +0100 |
| Message-ID | <qUIlY-7Qf-7@gated-at.bofh.it> |
| In reply to | #1314247 |
On 2016年01月21日 22:50, Thierry Reding wrote:
> * PGP Signed by an unknown key
>
> On Mon, Jan 18, 2016 at 06:03:57PM +0800, Wei Ni wrote:
> [...]
>> diff --git a/drivers/thermal/tegra/soctherm.c b/drivers/thermal/tegra/soctherm.c
> [...]
>> +static void soctherm_debug_init(struct platform_device *pdev)
>> +{
>> + struct tegra_soctherm *tegra = platform_get_drvdata(pdev);
>> + struct dentry *root, *file;
>> +
>> + root = debugfs_create_dir("tegra_soctherm", NULL);
>
> Perhaps leave away the tegra_ prefix here? It's kind of redundant.
Ok, will remove the prefix.
>
>> + if (!root) {
>> + dev_err(&pdev->dev, "failed to create debugfs directory\n");
>> + return;
>> + }
>> +
>> + tegra->debugfs_dir = root;
>> +
>> + file = debugfs_create_file("regs", 0644, root, pdev, ®s_fops);
>
> Can we call this something different, please? "summary" would be a
> better name, in my opinion.
How about to change to "reg_contents"
>
>> + if (!file)
>> + dev_err(&pdev->dev, "failed to create debugfs file\n");
>> +}
>> +#else
>> +static inline void soctherm_debug_init(struct platform_device *pdev)
>> +{ return 0; }
>
> Please follow the regular CodingStyle here, too:
Got it, will fix it.
>
> ...
> {
> return 0;
> }
>
>> @@ -178,6 +309,10 @@ static int tegra_soctherm_probe(struct platform_device *pdev)
>> if (!tegra)
>> return -ENOMEM;
>>
>> + dev_set_drvdata(&pdev->dev, tegra);
>> +
>> + tegra->soc = soc;
>
> This looks odd here. Does this perhaps belong in one of the previous
> patches?
Sorry, I made a mistake when I rebased these patches.
Will fix it.
>
> Thierry
>
> * Unknown Key
> * 0x7F3EB3A1
>
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web