Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1306072 > unrolled thread
| Started by | "Michael S. Tsirkin" <mst@redhat.com> |
|---|---|
| First post | 2016-01-11 12:10 +0100 |
| Last post | 2016-01-11 12:10 +0100 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [PATCH v4 0/3] checkpatch: handling of memory barriers "Michael S. Tsirkin" <mst@redhat.com> - 2016-01-11 12:10 +0100
Re: [PATCH v4 0/3] checkpatch: handling of memory barriers Julian Calaby <julian.calaby@gmail.com> - 2016-01-11 12:10 +0100
| From | "Michael S. Tsirkin" <mst@redhat.com> |
|---|---|
| Date | 2016-01-11 12:10 +0100 |
| Subject | Re: [PATCH v4 0/3] checkpatch: handling of memory barriers |
| Message-ID | <qPIwi-1vs-5@gated-at.bofh.it> |
On Mon, Jan 11, 2016 at 12:59:25PM +0200, Michael S. Tsirkin wrote:
> As part of memory barrier cleanup, this patchset
> extends checkpatch to make it easier to stop
> incorrect memory barrier usage.
>
> This replaces the checkpatch patches in my series
> arch: barrier cleanup + barriers for virt
> and will be included in the pull request including
> the series.
>
> changes from v3:
> rename smp_barrier_stems to barrier_stems
> as suggested by Julian Calaby.
In fact it was Joe Perches that suggested it.
Sorry about the confusion.
> add (?: ... ) around a variable in regexp,
> in case we change the value later so that it matters.
> changes from v2:
> address comments by Joe Perches:
> use (?: ... ) to avoid unnecessary capture groups
> rename smp_barriers to smp_barrier_stems for clarity
> add barriers before/after atomic
> Changes from v1:
> catch optional\s* before () in barriers
> rewrite using qr{} instead of map
>
> Michael S. Tsirkin (3):
> checkpatch.pl: add missing memory barriers
> checkpatch: check for __smp outside barrier.h
> checkpatch: add virt barriers
>
> Michael S. Tsirkin (3):
> checkpatch.pl: add missing memory barriers
> checkpatch: check for __smp outside barrier.h
> checkpatch: add virt barriers
>
> scripts/checkpatch.pl | 33 ++++++++++++++++++++++++++++++++-
> 1 file changed, 32 insertions(+), 1 deletion(-)
>
> --
> MST
[toc] | [next] | [standalone]
| From | Julian Calaby <julian.calaby@gmail.com> |
|---|---|
| Date | 2016-01-11 12:10 +0100 |
| Message-ID | <qPIwi-1vs-9@gated-at.bofh.it> |
| In reply to | #1306072 |
Hi Michael, On Mon, Jan 11, 2016 at 10:04 PM, Michael S. Tsirkin <mst@redhat.com> wrote: > On Mon, Jan 11, 2016 at 12:59:25PM +0200, Michael S. Tsirkin wrote: >> As part of memory barrier cleanup, this patchset >> extends checkpatch to make it easier to stop >> incorrect memory barrier usage. >> >> This replaces the checkpatch patches in my series >> arch: barrier cleanup + barriers for virt >> and will be included in the pull request including >> the series. >> >> changes from v3: >> rename smp_barrier_stems to barrier_stems >> as suggested by Julian Calaby. > > In fact it was Joe Perches that suggested it. > Sorry about the confusion. I was about to point that out. FWIW this entire series is: Acked-by: Julian Calaby <julian.calaby@gmail.com> Thanks, -- Julian Calaby Email: julian.calaby@gmail.com Profile: http://www.google.com/profiles/julian.calaby/
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web