Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1305616 > unrolled thread

[PATCH -next v2 1/2] net: tc35815: Fix build error due to missed API change

Started byGuenter Roeck <linux@roeck-us.net>
First post2016-01-10 16:20 +0100
Last post2016-01-11 05:40 +0100
Articles 5 — 3 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH -next v2 1/2] net: tc35815: Fix build error due to missed API change Guenter Roeck <linux@roeck-us.net> - 2016-01-10 16:20 +0100
    [PATCH -next v2 2/2] net: tc35815: Drop unused variable Guenter Roeck <linux@roeck-us.net> - 2016-01-10 16:20 +0100
      Re: [PATCH -next v2 2/2] net: tc35815: Drop unused variable David Miller <davem@davemloft.net> - 2016-01-11 05:40 +0100
    Re: [PATCH -next v2 1/2] net: tc35815: Fix build error due to missed  API change Andrew Lunn <andrew@lunn.ch> - 2016-01-10 16:50 +0100
    Re: [PATCH -next v2 1/2] net: tc35815: Fix build error due to  missed API change David Miller <davem@davemloft.net> - 2016-01-11 05:40 +0100

#1305616 — [PATCH -next v2 1/2] net: tc35815: Fix build error due to missed API change

FromGuenter Roeck <linux@roeck-us.net>
Date2016-01-10 16:20 +0100
Subject[PATCH -next v2 1/2] net: tc35815: Fix build error due to missed API change
Message-ID<qPpWG-5U9-5@gated-at.bofh.it>
Commit 7f854420fbfe ("phy: Add API for {un}registering an mdio device to
a bus") introduces an API to access mii_bus structures, but missed to
update the tc35815 driver. This results in the following error message.

drivers/net/ethernet/toshiba/tc35815.c: In function 'tc_mii_probe':
drivers/net/ethernet/toshiba/tc35815.c:617:18: error:
	'struct mii_bus' has no member named 'phy_map'
drivers/net/ethernet/toshiba/tc35815.c:623:24: error:
	'struct mii_bus' has no member named 'phy_map'

Instead of looping over the list of phy addresses to find a phy chip,
use phy_find_first(). While the intent of the original code was to return
an error if more than one phy was specified, this code path was never
executed because the loop aborted after finding the first phy. The
original code is therefore semantically identical to phy_find_first(),
thus it is simpler and more straightforward to use phy_find_first()
directly.

Fixes: 7f854420fbfe ("phy: Add API for {un}registering an mdio device to a bus")
Cc: Andrew Lunn <andrew@lunn.ch>
Signed-off-by: Guenter Roeck <linux@roeck-us.net>
---
v2: Use phy_find_first() instead of open-coding it.

 drivers/net/ethernet/toshiba/tc35815.c | 17 ++---------------
 1 file changed, 2 insertions(+), 15 deletions(-)

diff --git a/drivers/net/ethernet/toshiba/tc35815.c b/drivers/net/ethernet/toshiba/tc35815.c
index fed5e3dfbc8f..71efe0092bec 100644
--- a/drivers/net/ethernet/toshiba/tc35815.c
+++ b/drivers/net/ethernet/toshiba/tc35815.c
@@ -608,23 +608,10 @@ static void tc_handle_link_change(struct net_device *dev)
 static int tc_mii_probe(struct net_device *dev)
 {
 	struct tc35815_local *lp = netdev_priv(dev);
-	struct phy_device *phydev = NULL;
-	int phy_addr;
+	struct phy_device *phydev;
 	u32 dropmask;
 
-	/* find the first phy */
-	for (phy_addr = 0; phy_addr < PHY_MAX_ADDR; phy_addr++) {
-		if (lp->mii_bus->phy_map[phy_addr]) {
-			if (phydev) {
-				printk(KERN_ERR "%s: multiple PHYs found\n",
-				       dev->name);
-				return -EINVAL;
-			}
-			phydev = lp->mii_bus->phy_map[phy_addr];
-			break;
-		}
-	}
-
+	phydev = phy_find_first(lp->mii_bus);
 	if (!phydev) {
 		printk(KERN_ERR "%s: no PHY found\n", dev->name);
 		return -ENODEV;
-- 
2.1.4

[toc] | [next] | [standalone]


#1305619 — [PATCH -next v2 2/2] net: tc35815: Drop unused variable

FromGuenter Roeck <linux@roeck-us.net>
Date2016-01-10 16:20 +0100
Subject[PATCH -next v2 2/2] net: tc35815: Drop unused variable
Message-ID<qPpWG-5U9-21@gated-at.bofh.it>
In reply to#1305616
Commit e7f4dc3536a4 ("mdio: Move allocation of interrupts into core")
removes some code from tc_mii_init(), but does not remove a now unused
variable. This results in the following build warning.

drivers/net/ethernet/toshiba/tc35815.c: In function 'tc_mii_init':
drivers/net/ethernet/toshiba/tc35815.c:670:6: warning: unused variable 'i'

Fixes: e7f4dc3536a4 ("mdio: Move allocation of interrupts into core")
Cc: Andrew Lunn <andrew@lunn.ch>
Acked-by: Andrew Lunn <andrew@lunn.ch>
Signed-off-by: Guenter Roeck <linux@roeck-us.net>
---
v2: Added Acked-by:

 drivers/net/ethernet/toshiba/tc35815.c | 1 -
 1 file changed, 1 deletion(-)

diff --git a/drivers/net/ethernet/toshiba/tc35815.c b/drivers/net/ethernet/toshiba/tc35815.c
index 71efe0092bec..54874783476a 100644
--- a/drivers/net/ethernet/toshiba/tc35815.c
+++ b/drivers/net/ethernet/toshiba/tc35815.c
@@ -654,7 +654,6 @@ static int tc_mii_init(struct net_device *dev)
 {
 	struct tc35815_local *lp = netdev_priv(dev);
 	int err;
-	int i;
 
 	lp->mii_bus = mdiobus_alloc();
 	if (lp->mii_bus == NULL) {
-- 
2.1.4

[toc] | [prev] | [next] | [standalone]


#1305836 — Re: [PATCH -next v2 2/2] net: tc35815: Drop unused variable

FromDavid Miller <davem@davemloft.net>
Date2016-01-11 05:40 +0100
SubjectRe: [PATCH -next v2 2/2] net: tc35815: Drop unused variable
Message-ID<qPCqU-5KZ-53@gated-at.bofh.it>
In reply to#1305619
From: Guenter Roeck <linux@roeck-us.net>
Date: Sun, 10 Jan 2016 07:10:45 -0800

> Commit e7f4dc3536a4 ("mdio: Move allocation of interrupts into core")
> removes some code from tc_mii_init(), but does not remove a now unused
> variable. This results in the following build warning.
> 
> drivers/net/ethernet/toshiba/tc35815.c: In function 'tc_mii_init':
> drivers/net/ethernet/toshiba/tc35815.c:670:6: warning: unused variable 'i'
> 
> Fixes: e7f4dc3536a4 ("mdio: Move allocation of interrupts into core")
> Cc: Andrew Lunn <andrew@lunn.ch>
> Acked-by: Andrew Lunn <andrew@lunn.ch>
> Signed-off-by: Guenter Roeck <linux@roeck-us.net>

Applied.

[toc] | [prev] | [next] | [standalone]


#1305624 — Re: [PATCH -next v2 1/2] net: tc35815: Fix build error due to missed API change

FromAndrew Lunn <andrew@lunn.ch>
Date2016-01-10 16:50 +0100
SubjectRe: [PATCH -next v2 1/2] net: tc35815: Fix build error due to missed API change
Message-ID<qPqpH-66L-5@gated-at.bofh.it>
In reply to#1305616
On Sun, Jan 10, 2016 at 07:10:44AM -0800, Guenter Roeck wrote:
> Commit 7f854420fbfe ("phy: Add API for {un}registering an mdio device to
> a bus") introduces an API to access mii_bus structures, but missed to
> update the tc35815 driver. This results in the following error message.
> 
> drivers/net/ethernet/toshiba/tc35815.c: In function 'tc_mii_probe':
> drivers/net/ethernet/toshiba/tc35815.c:617:18: error:
> 	'struct mii_bus' has no member named 'phy_map'
> drivers/net/ethernet/toshiba/tc35815.c:623:24: error:
> 	'struct mii_bus' has no member named 'phy_map'
> 
> Instead of looping over the list of phy addresses to find a phy chip,
> use phy_find_first(). While the intent of the original code was to return
> an error if more than one phy was specified, this code path was never
> executed because the loop aborted after finding the first phy. The
> original code is therefore semantically identical to phy_find_first(),
> thus it is simpler and more straightforward to use phy_find_first()
> directly.
> 
> Fixes: 7f854420fbfe ("phy: Add API for {un}registering an mdio device to a bus")
> Cc: Andrew Lunn <andrew@lunn.ch>
> Signed-off-by: Guenter Roeck <linux@roeck-us.net>

Acked-by: Andrew Lunn <andrew@lunn.ch>

Thanks
	Andrew

> ---
> v2: Use phy_find_first() instead of open-coding it.
> 
>  drivers/net/ethernet/toshiba/tc35815.c | 17 ++---------------
>  1 file changed, 2 insertions(+), 15 deletions(-)
> 
> diff --git a/drivers/net/ethernet/toshiba/tc35815.c b/drivers/net/ethernet/toshiba/tc35815.c
> index fed5e3dfbc8f..71efe0092bec 100644
> --- a/drivers/net/ethernet/toshiba/tc35815.c
> +++ b/drivers/net/ethernet/toshiba/tc35815.c
> @@ -608,23 +608,10 @@ static void tc_handle_link_change(struct net_device *dev)
>  static int tc_mii_probe(struct net_device *dev)
>  {
>  	struct tc35815_local *lp = netdev_priv(dev);
> -	struct phy_device *phydev = NULL;
> -	int phy_addr;
> +	struct phy_device *phydev;
>  	u32 dropmask;
>  
> -	/* find the first phy */
> -	for (phy_addr = 0; phy_addr < PHY_MAX_ADDR; phy_addr++) {
> -		if (lp->mii_bus->phy_map[phy_addr]) {
> -			if (phydev) {
> -				printk(KERN_ERR "%s: multiple PHYs found\n",
> -				       dev->name);
> -				return -EINVAL;
> -			}
> -			phydev = lp->mii_bus->phy_map[phy_addr];
> -			break;
> -		}
> -	}
> -
> +	phydev = phy_find_first(lp->mii_bus);
>  	if (!phydev) {
>  		printk(KERN_ERR "%s: no PHY found\n", dev->name);
>  		return -ENODEV;
> -- 
> 2.1.4
> 

[toc] | [prev] | [next] | [standalone]


#1305828 — Re: [PATCH -next v2 1/2] net: tc35815: Fix build error due to missed API change

FromDavid Miller <davem@davemloft.net>
Date2016-01-11 05:40 +0100
SubjectRe: [PATCH -next v2 1/2] net: tc35815: Fix build error due to missed API change
Message-ID<qPCqS-5KZ-11@gated-at.bofh.it>
In reply to#1305616
From: Guenter Roeck <linux@roeck-us.net>
Date: Sun, 10 Jan 2016 07:10:44 -0800

> Commit 7f854420fbfe ("phy: Add API for {un}registering an mdio device to
> a bus") introduces an API to access mii_bus structures, but missed to
> update the tc35815 driver. This results in the following error message.
> 
> drivers/net/ethernet/toshiba/tc35815.c: In function 'tc_mii_probe':
> drivers/net/ethernet/toshiba/tc35815.c:617:18: error:
> 	'struct mii_bus' has no member named 'phy_map'
> drivers/net/ethernet/toshiba/tc35815.c:623:24: error:
> 	'struct mii_bus' has no member named 'phy_map'
> 
> Instead of looping over the list of phy addresses to find a phy chip,
> use phy_find_first(). While the intent of the original code was to return
> an error if more than one phy was specified, this code path was never
> executed because the loop aborted after finding the first phy. The
> original code is therefore semantically identical to phy_find_first(),
> thus it is simpler and more straightforward to use phy_find_first()
> directly.
> 
> Fixes: 7f854420fbfe ("phy: Add API for {un}registering an mdio device to a bus")
> Cc: Andrew Lunn <andrew@lunn.ch>
> Signed-off-by: Guenter Roeck <linux@roeck-us.net>

Applied.

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web