Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1302848 > unrolled thread

[PATCH] zorro: use kobj_to_dev()

Started byGeliang Tang <geliangtang@163.com>
First post2016-01-06 16:30 +0100
Last post2016-01-10 14:10 +0100
Articles 2 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH] zorro: use kobj_to_dev() Geliang Tang <geliangtang@163.com> - 2016-01-06 16:30 +0100
    Re: [PATCH] zorro: use kobj_to_dev() Geert Uytterhoeven <geert@linux-m68k.org> - 2016-01-10 14:10 +0100

#1302848 — [PATCH] zorro: use kobj_to_dev()

FromGeliang Tang <geliangtang@163.com>
Date2016-01-06 16:30 +0100
Subject[PATCH] zorro: use kobj_to_dev()
Message-ID<qNYca-2Y2-29@gated-at.bofh.it>
Use kobj_to_dev() instead of open-coding it.

Signed-off-by: Geliang Tang <geliangtang@163.com>
---
 drivers/zorro/zorro-sysfs.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/drivers/zorro/zorro-sysfs.c b/drivers/zorro/zorro-sysfs.c
index 36b210f..9282dbf 100644
--- a/drivers/zorro/zorro-sysfs.c
+++ b/drivers/zorro/zorro-sysfs.c
@@ -65,8 +65,7 @@ static ssize_t zorro_read_config(struct file *filp, struct kobject *kobj,
 				 struct bin_attribute *bin_attr,
 				 char *buf, loff_t off, size_t count)
 {
-	struct zorro_dev *z = to_zorro_dev(container_of(kobj, struct device,
-					   kobj));
+	struct zorro_dev *z = to_zorro_dev(kobj_to_dev(kobj));
 	struct ConfigDev cd;
 
 	/* Construct a ConfigDev */
-- 
2.5.0


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1305553

FromGeert Uytterhoeven <geert@linux-m68k.org>
Date2016-01-10 14:10 +0100
Message-ID<qPnUR-4Ak-9@gated-at.bofh.it>
In reply to#1302848
On Wed, Jan 6, 2016 at 4:28 PM, Geliang Tang <geliangtang@163.com> wrote:
> Use kobj_to_dev() instead of open-coding it.
>
> Signed-off-by: Geliang Tang <geliangtang@163.com>

Thanks, applied and queued for v4.6.

Gr{oetje,eeting}s,

                        Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                -- Linus Torvalds

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web