Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1295993 > unrolled thread
| Started by | Arnd Bergmann <arnd@arndb.de> |
|---|---|
| First post | 2015-12-21 15:10 +0100 |
| Last post | 2015-12-21 16:50 +0100 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: next-20151221 build: 2 failures 13 warnings (next-20151221) Arnd Bergmann <arnd@arndb.de> - 2015-12-21 15:10 +0100
Re: next-20151221 build: 2 failures 13 warnings (next-20151221) Mark Brown <broonie@kernel.org> - 2015-12-21 16:50 +0100
| From | Arnd Bergmann <arnd@arndb.de> |
|---|---|
| Date | 2015-12-21 15:10 +0100 |
| Subject | Re: next-20151221 build: 2 failures 13 warnings (next-20151221) |
| Message-ID | <qI9jY-7tH-11@gated-at.bofh.it> |
Just looking at the remaining warnings/errors in linux-next: On Monday 21 December 2015, Build bot for Mark Brown wrote: > ../fs/orangefs/orangefs-kernel.h:773:2: error: implicit declaration of function 'ornagefs_inode_lock' [-Werror=implicit-function-declaration] > ../fs/orangefs/orangefs-kernel.h:773:2: error: implicit declaration of function 'ornagefs_inode_lock' [-Werror=implicit-function-declaration] > ../fs/orangefs/orangefs-kernel.h:773:2: error: implicit declaration of function 'ornagefs_inode_lock' [-Werror=implicit-function-declaration] > ../fs/orangefs/orangefs-kernel.h:773:2: error: implicit declaration of function 'ornagefs_inode_lock' [-Werror=implicit-function-declaration] I just sent a patch for this. > arm64-allmodconfig : PASS, 0 errors, 5 warnings, 0 section mismatches > > Warnings: > ../drivers/gpu/drm/vc4/vc4_validate.c:864:4: warning: format '%d' expects argument of type 'int', but argument 4 has type 'size_t' [-Wformat=] I have a trivial patch, need to send it out. > ../drivers/staging/emxx_udc/emxx_udc.c:843:45: warning: cast from pointer to integer of different size [-Wpointer-to-int-cast] > ../drivers/staging/emxx_udc/emxx_udc.c:1085:45: warning: cast from pointer to integer of different size [-Wpointer-to-int-cast] > ../drivers/staging/emxx_udc/emxx_udc.c:2731:6: warning: cast from pointer to integer of different size [-Wpointer-to-int-cast] Submitted this one again last week, I had sent it a month ago, but the maintainer was busy. > ../drivers/tty/serial/amba-pl011.c:190:27: warning: 'vendor_zte' defined but not used [-Wunused-variable] rmk pointed out the problem when the patch was sent originally, no idea what we should do about it other than reverting the patch that introduced the unused code. > Warnings: > <stdin>:1307:2: warning: #warning syscall copy_file_range not implemented [-Wcpp] Not sure how we can improve this, the same thing seems to happen every time a new syscall gets introduced. The actual change is trivial, but we need a better method to sync all architectures. > ../kernel/printk/nmi.c:143:3: warning: format '%lu' expects argument of type 'long unsigned int', but argument 3 has type 'size_t' [-Wformat] Sent a patch the other day. > ../drivers/gpio/gpiolib.c:225:31: warning: 'iterator' may be used uninitialized in this function [-Wmaybe-uninitialized] Introduced by Bamvor, currently discussing a solution with him and Linus. We can either shut up the compiler or rewrite the function in a nicer way. > arm-multi_v7_defconfig : PASS, 0 errors, 8 warnings, 0 section mismatches > > Warnings: > arch/arm/configs/multi_v7_defconfig:433:warning: symbol value 'm' invalid for MFD_DA9063 I need to look into this, probably the result of a defconfig change we merged, but it's not clear whether the driver should be a module, or the defconfig should have it built-in. > ../net/bluetooth/mgmt.c:5471:8: warning: 'r192' may be used uninitialized in this function [-Wmaybe-uninitialized] > ../net/bluetooth/mgmt.c:5471:8: warning: 'h192' may be used uninitialized in this function [-Wmaybe-uninitialized] I don't see these with gcc-5.1 > ../crypto/wp512.c:987:1: warning: the frame size of 1112 bytes is larger than 1024 bytes [-Wframe-larger-than=] no this one. If we want to fix it, it's probably best to change the optimization level of the file, something gets misoptimzed here and it's clear it should not use that much stack. Arnd -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [next] | [standalone]
| From | Mark Brown <broonie@kernel.org> |
|---|---|
| Date | 2015-12-21 16:50 +0100 |
| Message-ID | <qIaSJ-8ka-21@gated-at.bofh.it> |
| In reply to | #1295993 |
[Multipart message — attachments visible in raw view] — view raw
On Mon, Dec 21, 2015 at 03:05:33PM +0100, Arnd Bergmann wrote: Please fix your mail client to word wrap within paragraphs at something substantially less than 80 columns. Doing this makes your messages much easier to read and reply to. > Just looking at the remaining warnings/errors in linux-next: > > Warnings: > > <stdin>:1307:2: warning: #warning syscall copy_file_range not implemented [-Wcpp] > Not sure how we can improve this, the same thing seems to happen every time a new syscall gets > introduced. The actual change is trivial, but we need a better method to sync all architectures. Now we've got the warning count down sufficiently the autobuilders may actually be just fine here. > > arm-multi_v7_defconfig : PASS, 0 errors, 8 warnings, 0 section mismatches > > Warnings: > > arch/arm/configs/multi_v7_defconfig:433:warning: symbol value 'm' invalid for MFD_DA9063 > I need to look into this, probably the result of a defconfig change we merged, but it's not > clear whether the driver should be a module, or the defconfig should have it built-in. The driver should at least support building modularly, there was a patch sent to MFD IIRC but I guess it's not applied yet (Lee is on vacation I believe which probably won't help).
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web