Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1292514 > unrolled thread
| Started by | Tim Bird <tim.bird@sonymobile.com> |
|---|---|
| First post | 2015-12-15 21:20 +0100 |
| Last post | 2015-12-19 05:20 +0100 |
| Articles | 11 — 6 participants |
Back to article view | Back to linux.kernel
[PATCH v4 1/3] dt-binding: power: Add otg regulator binding Tim Bird <tim.bird@sonymobile.com> - 2015-12-15 21:20 +0100
[PATCH v4 2/3] power: qcom_smbb: Add otg regulator for control of vbus Tim Bird <tim.bird@sonymobile.com> - 2015-12-15 21:20 +0100
Re: [PATCH v4 2/3] power: qcom_smbb: Add otg regulator for control of vbus Bjorn Andersson <bjorn.andersson@sonymobile.com> - 2015-12-15 23:30 +0100
Re: [PATCH v4 2/3] power: qcom_smbb: Add otg regulator for control of vbus Andy Gross <andy.gross@linaro.org> - 2015-12-15 23:40 +0100
[PATCH v4 3/3] ARM: dts: qcom: add charger otg regulator Tim Bird <tim.bird@sonymobile.com> - 2015-12-15 21:20 +0100
Re: [PATCH v4 3/3] ARM: dts: qcom: add charger otg regulator Bjorn Andersson <bjorn.andersson@sonymobile.com> - 2015-12-15 23:30 +0100
Re: [PATCH v4 1/3] dt-binding: power: Add otg regulator binding Bjorn Andersson <bjorn.andersson@sonymobile.com> - 2015-12-15 23:30 +0100
Re: [PATCH v4 1/3] dt-binding: power: Add otg regulator binding Andy Gross <andy.gross@linaro.org> - 2015-12-15 23:40 +0100
Re: [PATCH v4 1/3] dt-binding: power: Add otg regulator binding Sebastian Reichel <sre@kernel.org> - 2015-12-16 00:20 +0100
Re: [PATCH v4 1/3] dt-binding: power: Add otg regulator binding Mark Brown <broonie@kernel.org> - 2015-12-16 12:30 +0100
Re: [PATCH v4 1/3] dt-binding: power: Add otg regulator binding Rob Herring <robh@kernel.org> - 2015-12-19 05:20 +0100
| From | Tim Bird <tim.bird@sonymobile.com> |
|---|---|
| Date | 2015-12-15 21:20 +0100 |
| Subject | [PATCH v4 1/3] dt-binding: power: Add otg regulator binding |
| Message-ID | <qG4eK-x5-11@gated-at.bofh.it> |
Add a binding for the regulator which controls the OTG chargepath switch.
The OTG switch gets its power from pm8941_5vs1, and that should be
expressed as a usb_otg_in-supply property in the DT node for the
charger driver. The regulator name is "otg-vbus".
Signed-off-by: Tim Bird <tim.bird@sonymobile.com>
---
Changes since v3
- switch supply name to have underscores instead of dashes
- (switched back to match the name used in data sheets)
- switch regulator node name to otg-vbus
Changes since v1
- switch supply name to have dashes instead of underscores
- remove superfluous DT explanations in the otg node description
---
.../devicetree/bindings/power_supply/qcom_smbb.txt | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)
diff --git a/Documentation/devicetree/bindings/power_supply/qcom_smbb.txt b/Documentation/devicetree/bindings/power_supply/qcom_smbb.txt
index 65b88fa..06f8a5d 100644
--- a/Documentation/devicetree/bindings/power_supply/qcom_smbb.txt
+++ b/Documentation/devicetree/bindings/power_supply/qcom_smbb.txt
@@ -105,6 +105,22 @@ PROPERTIES
regulation must be done externally to fully comply with
the JEITA safety guidelines if this flag is set.
+- usb_otg_in-supply:
+ Usage: optional
+ Value type: <phandle>
+ Description: Reference to the regulator supplying power to the USB_OTG_IN
+ pin.
+
+child nodes:
+- otg-vbus:
+ Usage: optional
+ Description: This node defines a regulator used to control the direction
+ of VBUS voltage - specifically: whether to supply voltage
+ to VBUS for host mode operation of the OTG port, or allow
+ input voltage from external VBUS for charging. In the
+ hardware, the supply for this regulator comes from
+ usb_otg_in-supply.
+
EXAMPLE
charger@1000 {
compatible = "qcom,pm8941-charger";
@@ -128,4 +144,7 @@ charger@1000 {
qcom,fast-charge-current-limit = <1000000>;
qcom,dc-charge-current-limit = <1000000>;
+ usb_otg_in-supply = <&pm8941_5vs1>;
+
+ otg-vbus {};
};
--
2.6.3
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [next] | [standalone]
| From | Tim Bird <tim.bird@sonymobile.com> |
|---|---|
| Date | 2015-12-15 21:20 +0100 |
| Subject | [PATCH v4 2/3] power: qcom_smbb: Add otg regulator for control of vbus |
| Message-ID | <qG4eK-x5-25@gated-at.bofh.it> |
| In reply to | #1292514 |
Add a regulator to control the OTG chargepath switch. This
is used by USB code to control VBUS direction - out for host mode
on the OTG port, and in for charging mode.
Signed-off-by: Tim Bird <tim.bird@sonymobile.com>
---
Changes since v3:
- changed DT node name to otg-vbus
- removed fixed-voltage setup from otg regulator rdesc
Changes since v1:
- changed name of supply to remove underscores
---
drivers/power/qcom_smbb.c | 72 +++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 72 insertions(+)
diff --git a/drivers/power/qcom_smbb.c b/drivers/power/qcom_smbb.c
index 5eb1e9e..8998f4d 100644
--- a/drivers/power/qcom_smbb.c
+++ b/drivers/power/qcom_smbb.c
@@ -34,6 +34,9 @@
#include <linux/power_supply.h>
#include <linux/regmap.h>
#include <linux/slab.h>
+#include <linux/regulator/driver.h>
+#include <linux/regulator/machine.h>
+#include <linux/regulator/of_regulator.h>
#define SMBB_CHG_VMAX 0x040
#define SMBB_CHG_VSAFE 0x041
@@ -71,6 +74,8 @@
#define BTC_CTRL_HOT_EXT_N BIT(0)
#define SMBB_USB_IMAX 0x344
+#define SMBB_USB_OTG_CTL 0x348
+#define OTG_CTL_EN BIT(0)
#define SMBB_USB_ENUM_TIMER_STOP 0x34e
#define ENUM_TIMER_STOP BIT(0)
#define SMBB_USB_SEC_ACCESS 0x3d0
@@ -123,6 +128,9 @@ struct smbb_charger {
struct power_supply *dc_psy;
struct power_supply *bat_psy;
struct regmap *regmap;
+
+ struct regulator_desc otg_rdesc;
+ struct regulator_dev *otg_reg;
};
static int smbb_vbat_weak_fn(unsigned int index)
@@ -778,12 +786,56 @@ static const struct power_supply_desc dc_psy_desc = {
.property_is_writeable = smbb_charger_writable_property,
};
+static int smbb_chg_otg_enable(struct regulator_dev *rdev)
+{
+ struct smbb_charger *chg = rdev_get_drvdata(rdev);
+ int rc;
+
+ rc = regmap_update_bits(chg->regmap, chg->addr + SMBB_USB_OTG_CTL,
+ OTG_CTL_EN, OTG_CTL_EN);
+ if (rc)
+ dev_err(chg->dev, "failed to update OTG_CTL\n");
+ return rc;
+}
+
+static int smbb_chg_otg_disable(struct regulator_dev *rdev)
+{
+ struct smbb_charger *chg = rdev_get_drvdata(rdev);
+ int rc;
+
+ rc = regmap_update_bits(chg->regmap, chg->addr + SMBB_USB_OTG_CTL,
+ OTG_CTL_EN, 0);
+ if (rc)
+ dev_err(chg->dev, "failed to update OTG_CTL\n");
+ return rc;
+}
+
+static int smbb_chg_otg_is_enabled(struct regulator_dev *rdev)
+{
+ struct smbb_charger *chg = rdev_get_drvdata(rdev);
+ unsigned int value = 0;
+ int rc;
+
+ rc = regmap_read(chg->regmap, chg->addr + SMBB_USB_OTG_CTL, &value);
+ if (rc)
+ dev_err(chg->dev, "failed to read OTG_CTL\n");
+
+ return !!(value & OTG_CTL_EN);
+}
+
+static struct regulator_ops smbb_chg_otg_ops = {
+ .enable = smbb_chg_otg_enable,
+ .disable = smbb_chg_otg_disable,
+ .is_enabled = smbb_chg_otg_is_enabled,
+};
+
static int smbb_charger_probe(struct platform_device *pdev)
{
struct power_supply_config bat_cfg = {};
struct power_supply_config usb_cfg = {};
struct power_supply_config dc_cfg = {};
struct smbb_charger *chg;
+ struct regulator_config config = { };
int rc, i;
chg = devm_kzalloc(&pdev->dev, sizeof(*chg), GFP_KERNEL);
@@ -884,6 +936,26 @@ static int smbb_charger_probe(struct platform_device *pdev)
}
}
+ /*
+ * otg regulator is used to control VBUS voltage direction
+ * when USB switches between host and gadget mode
+ */
+ chg->otg_rdesc.id = -1;
+ chg->otg_rdesc.name = "otg-vbus";
+ chg->otg_rdesc.ops = &smbb_chg_otg_ops;
+ chg->otg_rdesc.owner = THIS_MODULE;
+ chg->otg_rdesc.type = REGULATOR_VOLTAGE;
+ chg->otg_rdesc.supply_name = "usb-otg-in";
+ chg->otg_rdesc.of_match = "otg-vbus";
+
+ config.dev = &pdev->dev;
+ config.driver_data = chg;
+
+ chg->otg_reg = devm_regulator_register(&pdev->dev, &chg->otg_rdesc,
+ &config);
+ if (IS_ERR(chg->otg_reg))
+ return PTR_ERR(chg->otg_reg);
+
chg->jeita_ext_temp = of_property_read_bool(pdev->dev.of_node,
"qcom,jeita-extended-temp-range");
--
2.6.3
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Bjorn Andersson <bjorn.andersson@sonymobile.com> |
|---|---|
| Date | 2015-12-15 23:30 +0100 |
| Subject | Re: [PATCH v4 2/3] power: qcom_smbb: Add otg regulator for control of vbus |
| Message-ID | <qG6gy-1N2-13@gated-at.bofh.it> |
| In reply to | #1292516 |
On Tue 15 Dec 11:52 PST 2015, Tim Bird wrote: > Add a regulator to control the OTG chargepath switch. This > is used by USB code to control VBUS direction - out for host mode > on the OTG port, and in for charging mode. > > Signed-off-by: Tim Bird <tim.bird@sonymobile.com> > --- > Changes since v3: > - changed DT node name to otg-vbus > - removed fixed-voltage setup from otg regulator rdesc > Changes since v1: > - changed name of supply to remove underscores > --- Acked-by: Bjorn Andersson <bjorn.andersson@sonymobile.com> Regards, Bjorn -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Andy Gross <andy.gross@linaro.org> |
|---|---|
| Date | 2015-12-15 23:40 +0100 |
| Subject | Re: [PATCH v4 2/3] power: qcom_smbb: Add otg regulator for control of vbus |
| Message-ID | <qG6qe-1QP-7@gated-at.bofh.it> |
| In reply to | #1292516 |
On Tue, Dec 15, 2015 at 11:52:11AM -0800, Tim Bird wrote: > Add a regulator to control the OTG chargepath switch. This > is used by USB code to control VBUS direction - out for host mode > on the OTG port, and in for charging mode. > > Signed-off-by: Tim Bird <tim.bird@sonymobile.com> > --- > Changes since v3: > - changed DT node name to otg-vbus > - removed fixed-voltage setup from otg regulator rdesc > Changes since v1: > - changed name of supply to remove underscores > --- Reviewed-by: Andy Gross <andy.gross@linaro.org> -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Tim Bird <tim.bird@sonymobile.com> |
|---|---|
| Date | 2015-12-15 21:20 +0100 |
| Subject | [PATCH v4 3/3] ARM: dts: qcom: add charger otg regulator |
| Message-ID | <qG4eL-x5-33@gated-at.bofh.it> |
| In reply to | #1292514 |
Add the otg regulator provided by the charger block.
Signed-off-by: Tim Bird <tim.bird@sonymobile.com>
---
Changes since V3:
- change name of charger regulator to "otg-vbus"
---
arch/arm/boot/dts/qcom-pm8941.dtsi | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/arch/arm/boot/dts/qcom-pm8941.dtsi b/arch/arm/boot/dts/qcom-pm8941.dtsi
index b0d4439..d0ffca7 100644
--- a/arch/arm/boot/dts/qcom-pm8941.dtsi
+++ b/arch/arm/boot/dts/qcom-pm8941.dtsi
@@ -45,6 +45,10 @@
"chg-gone",
"usb-valid",
"dc-valid";
+
+ usb_otg_in-supply = <&pm8941_5vs1>;
+
+ chg_otg: otg-vbus { };
};
pm8941_gpios: gpios@c000 {
--
2.6.3
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Bjorn Andersson <bjorn.andersson@sonymobile.com> |
|---|---|
| Date | 2015-12-15 23:30 +0100 |
| Subject | Re: [PATCH v4 3/3] ARM: dts: qcom: add charger otg regulator |
| Message-ID | <qG6gx-1N2-1@gated-at.bofh.it> |
| In reply to | #1292517 |
On Tue 15 Dec 11:52 PST 2015, Tim Bird wrote:
> Add the otg regulator provided by the charger block.
>
> Signed-off-by: Tim Bird <tim.bird@sonymobile.com>
> ---
> Changes since V3:
> - change name of charger regulator to "otg-vbus"
> ---
> arch/arm/boot/dts/qcom-pm8941.dtsi | 4 ++++
> 1 file changed, 4 insertions(+)
>
> diff --git a/arch/arm/boot/dts/qcom-pm8941.dtsi b/arch/arm/boot/dts/qcom-pm8941.dtsi
> index b0d4439..d0ffca7 100644
> --- a/arch/arm/boot/dts/qcom-pm8941.dtsi
> +++ b/arch/arm/boot/dts/qcom-pm8941.dtsi
> @@ -45,6 +45,10 @@
> "chg-gone",
> "usb-valid",
> "dc-valid";
> +
> + usb_otg_in-supply = <&pm8941_5vs1>;
Although this could be coming from some other supply I think it's
perfectly fine that we define this on a platform level.
> +
> + chg_otg: otg-vbus { };
> };
>
> pm8941_gpios: gpios@c000 {
Reviewed-by: Bjorn Andersson <bjorn.andersson@sonymobile.com>
Regards,
Bjorn
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Bjorn Andersson <bjorn.andersson@sonymobile.com> |
|---|---|
| Date | 2015-12-15 23:30 +0100 |
| Message-ID | <qG6gy-1N2-3@gated-at.bofh.it> |
| In reply to | #1292514 |
On Tue 15 Dec 11:52 PST 2015, Tim Bird wrote: > Add a binding for the regulator which controls the OTG chargepath switch. > The OTG switch gets its power from pm8941_5vs1, and that should be > expressed as a usb_otg_in-supply property in the DT node for the > charger driver. The regulator name is "otg-vbus". > > Signed-off-by: Tim Bird <tim.bird@sonymobile.com> > --- > Changes since v3 > - switch supply name to have underscores instead of dashes > - (switched back to match the name used in data sheets) Thanks, now it matches the datasheet again. > - switch regulator node name to otg-vbus > Changes since v1 > - switch supply name to have dashes instead of underscores > - remove superfluous DT explanations in the otg node description > --- Acked-by: Bjorn Andersson <bjorn.andersson@sonymobile.com> Regards, Bjorn -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Andy Gross <andy.gross@linaro.org> |
|---|---|
| Date | 2015-12-15 23:40 +0100 |
| Message-ID | <qG6qe-1QP-5@gated-at.bofh.it> |
| In reply to | #1292514 |
On Tue, Dec 15, 2015 at 11:52:10AM -0800, Tim Bird wrote: > Add a binding for the regulator which controls the OTG chargepath switch. > The OTG switch gets its power from pm8941_5vs1, and that should be > expressed as a usb_otg_in-supply property in the DT node for the > charger driver. The regulator name is "otg-vbus". > > Signed-off-by: Tim Bird <tim.bird@sonymobile.com> > --- > Changes since v3 > - switch supply name to have underscores instead of dashes > - (switched back to match the name used in data sheets) > - switch regulator node name to otg-vbus > Changes since v1 > - switch supply name to have dashes instead of underscores > - remove superfluous DT explanations in the otg node description Reviewed-by: Andy Gross <andy.gross@linaro.org> -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Sebastian Reichel <sre@kernel.org> |
|---|---|
| Date | 2015-12-16 00:20 +0100 |
| Message-ID | <qG72W-2k7-27@gated-at.bofh.it> |
| In reply to | #1292514 |
[Multipart message — attachments visible in raw view] — view raw
Hi, On Tue, Dec 15, 2015 at 11:52:10AM -0800, Tim Bird wrote: > Add a binding for the regulator which controls the OTG chargepath switch. > The OTG switch gets its power from pm8941_5vs1, and that should be > expressed as a usb_otg_in-supply property in the DT node for the > charger driver. The regulator name is "otg-vbus". I would like to get an acked-by from either the regulator framework maintainers, or DT binding maintainers (or both ;)) on the binding. -- Sebastian
[toc] | [prev] | [next] | [standalone]
| From | Mark Brown <broonie@kernel.org> |
|---|---|
| Date | 2015-12-16 12:30 +0100 |
| Message-ID | <qGirn-175-15@gated-at.bofh.it> |
| In reply to | #1292634 |
[Multipart message — attachments visible in raw view] — view raw
On Wed, Dec 16, 2015 at 12:13:50AM +0100, Sebastian Reichel wrote: > On Tue, Dec 15, 2015 at 11:52:10AM -0800, Tim Bird wrote: > > Add a binding for the regulator which controls the OTG chargepath switch. > > The OTG switch gets its power from pm8941_5vs1, and that should be > > expressed as a usb_otg_in-supply property in the DT node for the > > charger driver. The regulator name is "otg-vbus". > I would like to get an acked-by from either the regulator framework > maintainers, or DT binding maintainers (or both ;)) on the binding. Please submit any patches you want reviewing using the process in SubmittingPatches. If this is a regulator driver it should be in drivers/regulator though.
[toc] | [prev] | [next] | [standalone]
| From | Rob Herring <robh@kernel.org> |
|---|---|
| Date | 2015-12-19 05:20 +0100 |
| Message-ID | <qHh9T-6J4-5@gated-at.bofh.it> |
| In reply to | #1292514 |
On Tue, Dec 15, 2015 at 11:52:10AM -0800, Tim Bird wrote: > Add a binding for the regulator which controls the OTG chargepath switch. > The OTG switch gets its power from pm8941_5vs1, and that should be > expressed as a usb_otg_in-supply property in the DT node for the > charger driver. The regulator name is "otg-vbus". > > Signed-off-by: Tim Bird <tim.bird@sonymobile.com> > --- > Changes since v3 > - switch supply name to have underscores instead of dashes > - (switched back to match the name used in data sheets) > - switch regulator node name to otg-vbus > Changes since v1 > - switch supply name to have dashes instead of underscores > - remove superfluous DT explanations in the otg node description > --- > .../devicetree/bindings/power_supply/qcom_smbb.txt | 19 +++++++++++++++++++ > 1 file changed, 19 insertions(+) Acked-by: Rob Herring <robh@kernel.org> -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web