Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1286268 > unrolled thread
| Started by | Sanidhya Solanki <jpage.lkml@gmail.com> |
|---|---|
| First post | 2015-12-08 07:40 +0100 |
| Last post | 2015-12-08 14:10 +0100 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
[PATCH] Staging: Skein: Moved macros from skein_block.c to header file. Sanidhya Solanki <jpage.lkml@gmail.com> - 2015-12-08 07:40 +0100
Re: [PATCH] Staging: Skein: Moved macros from skein_block.c to header file. Jason Cooper <jason@lakedaemon.net> - 2015-12-08 14:10 +0100
| From | Sanidhya Solanki <jpage.lkml@gmail.com> |
|---|---|
| Date | 2015-12-08 07:40 +0100 |
| Subject | [PATCH] Staging: Skein: Moved macros from skein_block.c to header file. |
| Message-ID | <qDk6m-79U-3@gated-at.bofh.it> |
The original code defined macros in the source code, making it
harder to read. Moved them to the header file, as per the TODO file.
Upadated the TODO file.
Signed-off-by: Sanidhya Solanki <jpage.lkml@gmail.com>
---
drivers/staging/skein/TODO | 1 -
drivers/staging/skein/skein_block.c | 6 ------
drivers/staging/skein/skein_block.h | 7 +++++++
3 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/skein/TODO b/drivers/staging/skein/TODO
index cd3508d..e3de0c7 100644
--- a/drivers/staging/skein/TODO
+++ b/drivers/staging/skein/TODO
@@ -1,6 +1,5 @@
skein/threefish TODO
- - move macros into appropriate header files
- add / pass test vectors
- module support
diff --git a/drivers/staging/skein/skein_block.c b/drivers/staging/skein/skein_block.c
index 45b4732..2120392 100644
--- a/drivers/staging/skein/skein_block.c
+++ b/drivers/staging/skein/skein_block.c
@@ -26,12 +26,6 @@
#define SKEIN_LOOP 001 /* default: unroll 256 and 512, but not 1024 */
#endif
-#define BLK_BITS (WCNT * 64) /* some useful definitions for code here */
-#define KW_TWK_BASE (0)
-#define KW_KEY_BASE (3)
-#define ks (kw + KW_KEY_BASE)
-#define ts (kw + KW_TWK_BASE)
-
#ifdef SKEIN_DEBUG
#define debug_save_tweak(ctx) \
{ \
diff --git a/drivers/staging/skein/skein_block.h b/drivers/staging/skein/skein_block.h
index 9d40f4a..0fd4bfe 100644
--- a/drivers/staging/skein/skein_block.h
+++ b/drivers/staging/skein/skein_block.h
@@ -7,6 +7,13 @@
** This algorithm and source code is released to the public domain.
**
************************************************************************/
+
+#define BLK_BITS (WCNT * 64) /* some useful definitions for code here */
+#define KW_TWK_BASE (0)
+#define KW_KEY_BASE (3)
+#define ks (kw + KW_KEY_BASE)
+#define ts (kw + KW_TWK_BASE)
+
#ifndef _SKEIN_BLOCK_H_
#define _SKEIN_BLOCK_H_
--
2.5.0
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [next] | [standalone]
| From | Jason Cooper <jason@lakedaemon.net> |
|---|---|
| Date | 2015-12-08 14:10 +0100 |
| Subject | Re: [PATCH] Staging: Skein: Moved macros from skein_block.c to header file. |
| Message-ID | <qDqbM-2Nk-27@gated-at.bofh.it> |
| In reply to | #1286268 |
Sanidhya,
*Much* better. Only two two small nits (things which Greg may be able
to fix up when applying), and one comment.
nit: Patch subject should be 'staging: skein: ...'
On Mon, Dec 07, 2015 at 09:37:24PM -0500, Sanidhya Solanki wrote:
> The original code defined macros in the source code, making it
> harder to read. Moved them to the header file, as per the TODO file.
>
> Upadated the TODO file.
nit: typo 'Updated'
>
> Signed-off-by: Sanidhya Solanki <jpage.lkml@gmail.com>
> ---
> drivers/staging/skein/TODO | 1 -
> drivers/staging/skein/skein_block.c | 6 ------
> drivers/staging/skein/skein_block.h | 7 +++++++
> 3 files changed, 7 insertions(+), 7 deletions(-)
>
> diff --git a/drivers/staging/skein/TODO b/drivers/staging/skein/TODO
> index cd3508d..e3de0c7 100644
> --- a/drivers/staging/skein/TODO
> +++ b/drivers/staging/skein/TODO
> @@ -1,6 +1,5 @@
> skein/threefish TODO
>
> - - move macros into appropriate header files
There are a lot more macros to relocate than what we see below. I'd
prefer to edit the TODO only after it's all cleaned up. Sorry if I
wasn't clear before. I was assuming previous versions of your patches
were tests, and that once you had the process down, you'd hit all of the
macros.
So, the question is: Would you like this to be the first patch so you
can see the whole process once? If so, we need to leave the TODO item
intact. Otherwise, I think you've got the whole submission process down
now so you can go ahead and do all the macros.
Just let us know.
thx,
Jason.
> - add / pass test vectors
> - module support
>
> diff --git a/drivers/staging/skein/skein_block.c b/drivers/staging/skein/skein_block.c
> index 45b4732..2120392 100644
> --- a/drivers/staging/skein/skein_block.c
> +++ b/drivers/staging/skein/skein_block.c
> @@ -26,12 +26,6 @@
> #define SKEIN_LOOP 001 /* default: unroll 256 and 512, but not 1024 */
> #endif
>
> -#define BLK_BITS (WCNT * 64) /* some useful definitions for code here */
> -#define KW_TWK_BASE (0)
> -#define KW_KEY_BASE (3)
> -#define ks (kw + KW_KEY_BASE)
> -#define ts (kw + KW_TWK_BASE)
> -
> #ifdef SKEIN_DEBUG
> #define debug_save_tweak(ctx) \
> { \
> diff --git a/drivers/staging/skein/skein_block.h b/drivers/staging/skein/skein_block.h
> index 9d40f4a..0fd4bfe 100644
> --- a/drivers/staging/skein/skein_block.h
> +++ b/drivers/staging/skein/skein_block.h
> @@ -7,6 +7,13 @@
> ** This algorithm and source code is released to the public domain.
> **
> ************************************************************************/
> +
> +#define BLK_BITS (WCNT * 64) /* some useful definitions for code here */
> +#define KW_TWK_BASE (0)
> +#define KW_KEY_BASE (3)
> +#define ks (kw + KW_KEY_BASE)
> +#define ts (kw + KW_TWK_BASE)
> +
> #ifndef _SKEIN_BLOCK_H_
> #define _SKEIN_BLOCK_H_
>
> --
> 2.5.0
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web