Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1284813 > unrolled thread

crypto/nx842: Ignore queue overflow informative error

Started byHaren Myneni <haren@linux.vnet.ibm.com>
First post2015-12-06 08:50 +0100
Last post2015-12-07 20:40 +0100
Articles 4 — 3 participants

Back to article view | Back to linux.kernel


Contents

  crypto/nx842: Ignore queue overflow informative error Haren Myneni <haren@linux.vnet.ibm.com> - 2015-12-06 08:50 +0100
    Re: crypto/nx842: Ignore queue overflow informative error Daniel Axtens <dja@axtens.net> - 2015-12-07 00:00 +0100
      Re: crypto/nx842: Ignore queue overflow informative error Dan Streetman <ddstreet@ieee.org> - 2015-12-07 20:50 +0100
    Re: crypto/nx842: Ignore queue overflow informative error Dan Streetman <ddstreet@ieee.org> - 2015-12-07 20:40 +0100

#1284813 — crypto/nx842: Ignore queue overflow informative error

FromHaren Myneni <haren@linux.vnet.ibm.com>
Date2015-12-06 08:50 +0100
Subjectcrypto/nx842: Ignore queue overflow informative error
Message-ID<qCCeZ-441-1@gated-at.bofh.it>
NX842 coprocessor sets bit 3 if queue is overflow. It is just for
information to the user. So the driver prints this informative message
and ignores it.
    
Signed-off-by: Haren Myneni <haren@us.ibm.com>

diff --git a/arch/powerpc/include/asm/icswx.h b/arch/powerpc/include/asm/icswx.h
index 9f8402b..d1a2a2d 100644
--- a/arch/powerpc/include/asm/icswx.h
+++ b/arch/powerpc/include/asm/icswx.h
@@ -164,6 +164,7 @@ struct coprocessor_request_block {
 #define ICSWX_INITIATED		(0x8)
 #define ICSWX_BUSY		(0x4)
 #define ICSWX_REJECTED		(0x2)
+#define ICSWX_BIT3		(0x1)	/* undefined or set from XERSO. */
 
 static inline int icswx(__be32 ccw, struct coprocessor_request_block *crb)
 {
diff --git a/drivers/crypto/nx/nx-842-powernv.c b/drivers/crypto/nx/nx-842-powernv.c
index 9ef51fa..321b8e8 100644
--- a/drivers/crypto/nx/nx-842-powernv.c
+++ b/drivers/crypto/nx/nx-842-powernv.c
@@ -442,6 +442,15 @@ static int nx842_powernv_function(const unsigned char *in, unsigned int inlen,
 			     (unsigned int)ccw,
 			     (unsigned int)be32_to_cpu(crb->ccw));
 
+	/*
+	 * NX842 coprocessor uses 3rd bit to report queue overflow which is
+	 * not an error, just for information to user. So, ignore this bit.
+	 */
+	if (ret & ICSWX_BIT3) {
+		pr_info_ratelimited("842 coprocessor queue overflow\n");
+		ret &= ~ICSWX_BIT3;
+	}
+
 	switch (ret) {
 	case ICSWX_INITIATED:
 		ret = wait_for_csb(wmem, csb);


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1284941

FromDaniel Axtens <dja@axtens.net>
Date2015-12-07 00:00 +0100
Message-ID<qCQrE-4Bq-7@gated-at.bofh.it>
In reply to#1284813

[Multipart message — attachments visible in raw view] — view raw

Haren Myneni <haren@linux.vnet.ibm.com> writes:

> NX842 coprocessor sets bit 3 if queue is overflow. It is just for
> information to the user. So the driver prints this informative message
> and ignores it.

What queue, and what happens when the queue overflows? It seems like
*something* would need to be done, somewhere, by someone?

I realise that as a piece of IBM hardware this is probably an incredibly
optimistic question, but is this behaviour documented publically anywhere?
(As a distant second best, is it documented internally anywhere that I
can read?)

> --- a/drivers/crypto/nx/nx-842-powernv.c
> +++ b/drivers/crypto/nx/nx-842-powernv.c
> @@ -442,6 +442,15 @@ static int nx842_powernv_function(const unsigned char *in, unsigned int inlen,
>  			     (unsigned int)ccw,
>  			     (unsigned int)be32_to_cpu(crb->ccw));
>  
> +	/*
> +	 * NX842 coprocessor uses 3rd bit to report queue overflow which is
> +	 * not an error, just for information to user. So, ignore this bit.
> +	 */
> +	if (ret & ICSWX_BIT3) {
> +		pr_info_ratelimited("842 coprocessor queue overflow\n");
It doesn't look like this is done anywhere else in the file, but should
this be prefixed with something? Something like "nx-842: Coprocessor
queue overflow"?

Regards,
Daniel

> +		ret &= ~ICSWX_BIT3;
> +	}
> +
>  	switch (ret) {
>  	case ICSWX_INITIATED:
>  		ret = wait_for_csb(wmem, csb);
>
>
> _______________________________________________
> Linuxppc-dev mailing list
> Linuxppc-dev@lists.ozlabs.org
> https://lists.ozlabs.org/listinfo/linuxppc-dev

[toc] | [prev] | [next] | [standalone]


#1285877

FromDan Streetman <ddstreet@ieee.org>
Date2015-12-07 20:50 +0100
Message-ID<qD9Xk-pc-17@gated-at.bofh.it>
In reply to#1284941
On Sun, Dec 6, 2015 at 5:57 PM, Daniel Axtens <dja@axtens.net> wrote:
> Haren Myneni <haren@linux.vnet.ibm.com> writes:
>
>> NX842 coprocessor sets bit 3 if queue is overflow. It is just for
>> information to the user. So the driver prints this informative message
>> and ignores it.
>
> What queue, and what happens when the queue overflows? It seems like
> *something* would need to be done, somewhere, by someone?
>
> I realise that as a piece of IBM hardware this is probably an incredibly
> optimistic question, but is this behaviour documented publically anywhere?
> (As a distant second best, is it documented internally anywhere that I
> can read?)

When I worked there, it unfortunately wasn't public and there was no
future plan to make it public, but things might have changed since I
left.  Maybe it will be included in future openpower documentation...?

>
>> --- a/drivers/crypto/nx/nx-842-powernv.c
>> +++ b/drivers/crypto/nx/nx-842-powernv.c
>> @@ -442,6 +442,15 @@ static int nx842_powernv_function(const unsigned char *in, unsigned int inlen,
>>                            (unsigned int)ccw,
>>                            (unsigned int)be32_to_cpu(crb->ccw));
>>
>> +     /*
>> +      * NX842 coprocessor uses 3rd bit to report queue overflow which is
>> +      * not an error, just for information to user. So, ignore this bit.
>> +      */
>> +     if (ret & ICSWX_BIT3) {
>> +             pr_info_ratelimited("842 coprocessor queue overflow\n");
> It doesn't look like this is done anywhere else in the file, but should
> this be prefixed with something? Something like "nx-842: Coprocessor
> queue overflow"?

it defines pr_fmt at the top of the file so it will be prefixed with
the module name.

>
> Regards,
> Daniel
>
>> +             ret &= ~ICSWX_BIT3;
>> +     }
>> +
>>       switch (ret) {
>>       case ICSWX_INITIATED:
>>               ret = wait_for_csb(wmem, csb);
>>
>>
>> _______________________________________________
>> Linuxppc-dev mailing list
>> Linuxppc-dev@lists.ozlabs.org
>> https://lists.ozlabs.org/listinfo/linuxppc-dev
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1285870

FromDan Streetman <ddstreet@ieee.org>
Date2015-12-07 20:40 +0100
Message-ID<qD9ND-lE-9@gated-at.bofh.it>
In reply to#1284813
On Sun, Dec 6, 2015 at 2:46 AM, Haren Myneni <haren@linux.vnet.ibm.com> wrote:
>
> NX842 coprocessor sets bit 3 if queue is overflow. It is just for
> information to the user. So the driver prints this informative message
> and ignores it.
>
> Signed-off-by: Haren Myneni <haren@us.ibm.com>
>
> diff --git a/arch/powerpc/include/asm/icswx.h b/arch/powerpc/include/asm/icswx.h
> index 9f8402b..d1a2a2d 100644
> --- a/arch/powerpc/include/asm/icswx.h
> +++ b/arch/powerpc/include/asm/icswx.h
> @@ -164,6 +164,7 @@ struct coprocessor_request_block {
>  #define ICSWX_INITIATED                (0x8)
>  #define ICSWX_BUSY             (0x4)
>  #define ICSWX_REJECTED         (0x2)
> +#define ICSWX_BIT3             (0x1)   /* undefined or set from XERSO. */

Since this isn't defined by the icswx rfc workbook, it probably
shouldn't go here, it would make more sense to put it into nx-842.h
and call it something like "ICSWX_NX_QUEUE_OVERFLOW" or similar
NX-specific meaningful name.

>
>  static inline int icswx(__be32 ccw, struct coprocessor_request_block *crb)
>  {
> diff --git a/drivers/crypto/nx/nx-842-powernv.c b/drivers/crypto/nx/nx-842-powernv.c
> index 9ef51fa..321b8e8 100644
> --- a/drivers/crypto/nx/nx-842-powernv.c
> +++ b/drivers/crypto/nx/nx-842-powernv.c
> @@ -442,6 +442,15 @@ static int nx842_powernv_function(const unsigned char *in, unsigned int inlen,
>                              (unsigned int)ccw,
>                              (unsigned int)be32_to_cpu(crb->ccw));
>
> +       /*
> +        * NX842 coprocessor uses 3rd bit to report queue overflow which is
> +        * not an error, just for information to user. So, ignore this bit.
> +        */

a meaningfully named bit define means you don't need to explain it
with a comment :-)

However, I suggest that you do explain *why* a queue overflow isn't an
error - either here or (probably better) at the #define of the bit -
because that isn't obvious.

> +       if (ret & ICSWX_BIT3) {
> +               pr_info_ratelimited("842 coprocessor queue overflow\n");

if it's not an error, should this be pr_debug_ratelimited instead?
What is an end user expected to do if they see this msg in the log?

> +               ret &= ~ICSWX_BIT3;
> +       }
> +
>         switch (ret) {
>         case ICSWX_INITIATED:
>                 ret = wait_for_csb(wmem, csb);
>
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web