Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1281882 > unrolled thread

[PATCH 1/3] drivers: memory: clean up section counting

Started bySeth Jennings <sjennings@variantweb.net>
First post2015-12-02 16:10 +0100
Last post2015-12-02 16:10 +0100
Articles 2 — 1 participant

Back to article view | Back to linux.kernel


Contents

  [PATCH 1/3] drivers: memory: clean up section counting Seth Jennings <sjennings@variantweb.net> - 2015-12-02 16:10 +0100
    [PATCH 2/3] drivers: memory: rename remove_memory_block() to remove_memory_section() Seth Jennings <sjennings@variantweb.net> - 2015-12-02 16:10 +0100

#1281882 — [PATCH 1/3] drivers: memory: clean up section counting

FromSeth Jennings <sjennings@variantweb.net>
Date2015-12-02 16:10 +0100
Subject[PATCH 1/3] drivers: memory: clean up section counting
Message-ID<qBhcB-nj-3@gated-at.bofh.it>
Right now, section_count is calculated in add_memory_block().
However, init_memory_block() increments section_count as well,
which, at first, seems like it would lead to an off-by-one error.
There is no harm done because add_memory_block() immediately overwrites
the mem->section_count, but it is messy.

This commit moves the increment out of the common init_memory_block()
(called by both add_memory_block() and register_new_memory()) and
adds it to register_new_memory().

Signed-off-by: Seth Jennings <sjennings@variantweb.net>
---
 drivers/base/memory.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/base/memory.c b/drivers/base/memory.c
index 2804aed..ca2ce02 100644
--- a/drivers/base/memory.c
+++ b/drivers/base/memory.c
@@ -614,7 +614,6 @@ static int init_memory_block(struct memory_block **memory,
 			base_memory_block_id(scn_nr) * sections_per_block;
 	mem->end_section_nr = mem->start_section_nr + sections_per_block - 1;
 	mem->state = state;
-	mem->section_count++;
 	start_pfn = section_nr_to_pfn(mem->start_section_nr);
 	mem->phys_device = arch_get_memory_phys_device(start_pfn);
 
@@ -668,6 +667,7 @@ int register_new_memory(int nid, struct mem_section *section)
 		ret = init_memory_block(&mem, section, MEM_OFFLINE);
 		if (ret)
 			goto out;
+		mem->section_count++;
 	}
 
 	if (mem->section_count == sections_per_block)
-- 
2.5.0
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1281889 — [PATCH 2/3] drivers: memory: rename remove_memory_block() to remove_memory_section()

FromSeth Jennings <sjennings@variantweb.net>
Date2015-12-02 16:10 +0100
Subject[PATCH 2/3] drivers: memory: rename remove_memory_block() to remove_memory_section()
Message-ID<qBhcC-nj-29@gated-at.bofh.it>
In reply to#1281882
The function removes a section, not a block.  Rename to reflect
actual functionality.

Signed-off-by: Seth Jennings <sjennings@variantweb.net>
---
 drivers/base/memory.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/base/memory.c b/drivers/base/memory.c
index ca2ce02..dd30744 100644
--- a/drivers/base/memory.c
+++ b/drivers/base/memory.c
@@ -688,7 +688,7 @@ unregister_memory(struct memory_block *memory)
 	device_unregister(&memory->dev);
 }
 
-static int remove_memory_block(unsigned long node_id,
+static int remove_memory_section(unsigned long node_id,
 			       struct mem_section *section, int phys_device)
 {
 	struct memory_block *mem;
@@ -712,7 +712,7 @@ int unregister_memory_section(struct mem_section *section)
 	if (!present_section(section))
 		return -EINVAL;
 
-	return remove_memory_block(0, section, 0);
+	return remove_memory_section(0, section, 0);
 }
 #endif /* CONFIG_MEMORY_HOTREMOVE */
 
-- 
2.5.0
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web