Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1283069 > unrolled thread
| Started by | Geliang Tang <geliangtang@163.com> |
|---|---|
| First post | 2015-12-03 15:20 +0100 |
| Last post | 2015-12-07 17:30 +0100 |
| Articles | 7 — 3 participants |
Back to article view | Back to linux.kernel
[PATCH] mm/memcontrol.c: use list_{first,next}_entry Geliang Tang <geliangtang@163.com> - 2015-12-03 15:20 +0100
Re: [PATCH] mm/memcontrol.c: use list_{first,next}_entry Michal Hocko <mhocko@kernel.org> - 2015-12-03 17:30 +0100
Re: [PATCH] mm/memcontrol.c: use list_{first,next}_entry Johannes Weiner <hannes@cmpxchg.org> - 2015-12-03 20:30 +0100
Re: [PATCH] mm/memcontrol.c: use list_{first,next}_entry Michal Hocko <mhocko@kernel.org> - 2015-12-04 09:50 +0100
Re: [PATCH] mm/memcontrol.c: use list_{first,next}_entry Geliang Tang <geliangtang@163.com> - 2015-12-05 04:00 +0100
Re: [PATCH] mm/memcontrol.c: use list_{first,next}_entry Johannes Weiner <hannes@cmpxchg.org> - 2015-12-05 17:30 +0100
Re: [PATCH] mm/memcontrol.c: use list_{first,next}_entry Michal Hocko <mhocko@kernel.org> - 2015-12-07 17:30 +0100
| From | Geliang Tang <geliangtang@163.com> |
|---|---|
| Date | 2015-12-03 15:20 +0100 |
| Subject | [PATCH] mm/memcontrol.c: use list_{first,next}_entry |
| Message-ID | <qBCTN-6fn-13@gated-at.bofh.it> |
To make the intention clearer, use list_{first,next}_entry instead
of list_entry.
Signed-off-by: Geliang Tang <geliangtang@163.com>
---
mm/memcontrol.c | 9 +++------
1 file changed, 3 insertions(+), 6 deletions(-)
diff --git a/mm/memcontrol.c b/mm/memcontrol.c
index 79a29d5..a6301ea 100644
--- a/mm/memcontrol.c
+++ b/mm/memcontrol.c
@@ -5395,16 +5395,12 @@ static void uncharge_list(struct list_head *page_list)
unsigned long nr_file = 0;
unsigned long nr_huge = 0;
unsigned long pgpgout = 0;
- struct list_head *next;
struct page *page;
- next = page_list->next;
+ page = list_first_entry(page_list, struct page, lru);
do {
unsigned int nr_pages = 1;
- page = list_entry(next, struct page, lru);
- next = page->lru.next;
-
VM_BUG_ON_PAGE(PageLRU(page), page);
VM_BUG_ON_PAGE(page_count(page), page);
@@ -5440,7 +5436,8 @@ static void uncharge_list(struct list_head *page_list)
page->mem_cgroup = NULL;
pgpgout++;
- } while (next != page_list);
+ } while (!list_is_last(&page->lru, page_list) &&
+ (page = list_next_entry(page, lru)));
if (memcg)
uncharge_batch(memcg, pgpgout, nr_anon, nr_file,
--
2.5.0
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [next] | [standalone]
| From | Michal Hocko <mhocko@kernel.org> |
|---|---|
| Date | 2015-12-03 17:30 +0100 |
| Message-ID | <qBEVA-7vN-15@gated-at.bofh.it> |
| In reply to | #1283069 |
On Thu 03-12-15 22:16:55, Geliang Tang wrote:
> To make the intention clearer, use list_{first,next}_entry instead
> of list_entry.
Does this really help readability? This function simply uncharges the
given list of pages. Why cannot we simply use list_for_each_entry
instead...
> Signed-off-by: Geliang Tang <geliangtang@163.com>
> ---
> mm/memcontrol.c | 9 +++------
> 1 file changed, 3 insertions(+), 6 deletions(-)
>
> diff --git a/mm/memcontrol.c b/mm/memcontrol.c
> index 79a29d5..a6301ea 100644
> --- a/mm/memcontrol.c
> +++ b/mm/memcontrol.c
> @@ -5395,16 +5395,12 @@ static void uncharge_list(struct list_head *page_list)
> unsigned long nr_file = 0;
> unsigned long nr_huge = 0;
> unsigned long pgpgout = 0;
> - struct list_head *next;
> struct page *page;
>
> - next = page_list->next;
> + page = list_first_entry(page_list, struct page, lru);
> do {
> unsigned int nr_pages = 1;
>
> - page = list_entry(next, struct page, lru);
> - next = page->lru.next;
> -
> VM_BUG_ON_PAGE(PageLRU(page), page);
> VM_BUG_ON_PAGE(page_count(page), page);
>
> @@ -5440,7 +5436,8 @@ static void uncharge_list(struct list_head *page_list)
> page->mem_cgroup = NULL;
>
> pgpgout++;
> - } while (next != page_list);
> + } while (!list_is_last(&page->lru, page_list) &&
> + (page = list_next_entry(page, lru)));
>
> if (memcg)
> uncharge_batch(memcg, pgpgout, nr_anon, nr_file,
> --
> 2.5.0
>
--
Michal Hocko
SUSE Labs
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Johannes Weiner <hannes@cmpxchg.org> |
|---|---|
| Date | 2015-12-03 20:30 +0100 |
| Message-ID | <qBHJM-QO-21@gated-at.bofh.it> |
| In reply to | #1283170 |
On Thu, Dec 03, 2015 at 05:27:18PM +0100, Michal Hocko wrote:
> On Thu 03-12-15 22:16:55, Geliang Tang wrote:
> > To make the intention clearer, use list_{first,next}_entry instead
> > of list_entry.
>
> Does this really help readability? This function simply uncharges the
> given list of pages. Why cannot we simply use list_for_each_entry
> instead...
You asked the same thing when reviewing the patch for the first
time. :-) I think it's time to add a comment.
From e8ba3f31bb43ed4091b997b6ee8857dc8bbcd349 Mon Sep 17 00:00:00 2001
From: Johannes Weiner <hannes@cmpxchg.org>
Date: Thu, 3 Dec 2015 14:21:45 -0500
Subject: [PATCH] mm: memcontrol: clarify the uncharge_list() loop
uncharge_list() does an unusual list walk because the function can
take regular lists with dedicated list_heads as well as singleton
lists where a single page is passed via its page->lru list node.
This can sometimes lead to confusion, as well as suggestions to
replace the loop with a list_for_each_entry(), which wouldn't work.
Signed-off-by: Johannes Weiner <hannes@cmpxchg.org>
---
mm/memcontrol.c | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/mm/memcontrol.c b/mm/memcontrol.c
index 9acfb16..f7ee1c0 100644
--- a/mm/memcontrol.c
+++ b/mm/memcontrol.c
@@ -5422,6 +5422,10 @@ static void uncharge_list(struct list_head *page_list)
struct list_head *next;
struct page *page;
+ /*
+ * Note that the list can be a single page->lru; hence the
+ * do-while loop instead of a simple list_for_each_entry().
+ */
next = page_list->next;
do {
unsigned int nr_pages = 1;
--
2.6.3
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Michal Hocko <mhocko@kernel.org> |
|---|---|
| Date | 2015-12-04 09:50 +0100 |
| Message-ID | <qBUdZ-kv-15@gated-at.bofh.it> |
| In reply to | #1283278 |
On Thu 03-12-15 14:27:50, Johannes Weiner wrote:
> On Thu, Dec 03, 2015 at 05:27:18PM +0100, Michal Hocko wrote:
> > On Thu 03-12-15 22:16:55, Geliang Tang wrote:
> > > To make the intention clearer, use list_{first,next}_entry instead
> > > of list_entry.
> >
> > Does this really help readability? This function simply uncharges the
> > given list of pages. Why cannot we simply use list_for_each_entry
> > instead...
>
> You asked the same thing when reviewing the patch for the first
> time. :-) I think it's time to add a comment.
Ohh, I completely forgot about mem_cgroup_uncharge doing
uncharge_list(&page->lru)
> >From e8ba3f31bb43ed4091b997b6ee8857dc8bbcd349 Mon Sep 17 00:00:00 2001
> From: Johannes Weiner <hannes@cmpxchg.org>
> Date: Thu, 3 Dec 2015 14:21:45 -0500
> Subject: [PATCH] mm: memcontrol: clarify the uncharge_list() loop
>
> uncharge_list() does an unusual list walk because the function can
> take regular lists with dedicated list_heads as well as singleton
> lists where a single page is passed via its page->lru list node.
>
> This can sometimes lead to confusion, as well as suggestions to
> replace the loop with a list_for_each_entry(), which wouldn't work.
Yes, this is helpful.
> Signed-off-by: Johannes Weiner <hannes@cmpxchg.org>
Acked-by: Michal Hocko <mhocko@suse.com>
> ---
> mm/memcontrol.c | 4 ++++
> 1 file changed, 4 insertions(+)
>
> diff --git a/mm/memcontrol.c b/mm/memcontrol.c
> index 9acfb16..f7ee1c0 100644
> --- a/mm/memcontrol.c
> +++ b/mm/memcontrol.c
> @@ -5422,6 +5422,10 @@ static void uncharge_list(struct list_head *page_list)
> struct list_head *next;
> struct page *page;
>
> + /*
> + * Note that the list can be a single page->lru; hence the
> + * do-while loop instead of a simple list_for_each_entry().
> + */
> next = page_list->next;
> do {
> unsigned int nr_pages = 1;
> --
> 2.6.3
--
Michal Hocko
SUSE Labs
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Geliang Tang <geliangtang@163.com> |
|---|---|
| Date | 2015-12-05 04:00 +0100 |
| Message-ID | <qCbeO-2Kv-3@gated-at.bofh.it> |
| In reply to | #1283170 |
On Thu, Dec 03, 2015 at 05:27:18PM +0100, Michal Hocko wrote:
> On Thu 03-12-15 22:16:55, Geliang Tang wrote:
> > To make the intention clearer, use list_{first,next}_entry instead
> > of list_entry.
>
> Does this really help readability? This function simply uncharges the
> given list of pages. Why cannot we simply use list_for_each_entry
> instead...
I have tested it, list_for_each_entry can't work. Dose it mean that my
patch is OK? Or please give me some other advices.
Thanks.
- Geliang
> > Signed-off-by: Geliang Tang <geliangtang@163.com>
> > ---
> > mm/memcontrol.c | 9 +++------
> > 1 file changed, 3 insertions(+), 6 deletions(-)
> >
> > diff --git a/mm/memcontrol.c b/mm/memcontrol.c
> > index 79a29d5..a6301ea 100644
> > --- a/mm/memcontrol.c
> > +++ b/mm/memcontrol.c
> > @@ -5395,16 +5395,12 @@ static void uncharge_list(struct list_head *page_list)
> > unsigned long nr_file = 0;
> > unsigned long nr_huge = 0;
> > unsigned long pgpgout = 0;
> > - struct list_head *next;
> > struct page *page;
> >
> > - next = page_list->next;
> > + page = list_first_entry(page_list, struct page, lru);
> > do {
> > unsigned int nr_pages = 1;
> >
> > - page = list_entry(next, struct page, lru);
> > - next = page->lru.next;
> > -
> > VM_BUG_ON_PAGE(PageLRU(page), page);
> > VM_BUG_ON_PAGE(page_count(page), page);
> >
> > @@ -5440,7 +5436,8 @@ static void uncharge_list(struct list_head *page_list)
> > page->mem_cgroup = NULL;
> >
> > pgpgout++;
> > - } while (next != page_list);
> > + } while (!list_is_last(&page->lru, page_list) &&
> > + (page = list_next_entry(page, lru)));
> >
> > if (memcg)
> > uncharge_batch(memcg, pgpgout, nr_anon, nr_file,
> > --
> > 2.5.0
> >
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Johannes Weiner <hannes@cmpxchg.org> |
|---|---|
| Date | 2015-12-05 17:30 +0100 |
| Message-ID | <qCnSF-3my-3@gated-at.bofh.it> |
| In reply to | #1284442 |
On Sat, Dec 05, 2015 at 10:55:42AM +0800, Geliang Tang wrote:
> On Thu, Dec 03, 2015 at 05:27:18PM +0100, Michal Hocko wrote:
> > On Thu 03-12-15 22:16:55, Geliang Tang wrote:
> > > To make the intention clearer, use list_{first,next}_entry instead
> > > of list_entry.
> >
> > Does this really help readability? This function simply uncharges the
> > given list of pages. Why cannot we simply use list_for_each_entry
> > instead...
>
> I have tested it, list_for_each_entry can't work. Dose it mean that my
> patch is OK? Or please give me some other advices.
Your patch is okay. Please feel free to add my
Acked-by: Johannes Weiner <hannes@cmpxchg.org>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Michal Hocko <mhocko@kernel.org> |
|---|---|
| Date | 2015-12-07 17:30 +0100 |
| Message-ID | <qD6PO-6WV-51@gated-at.bofh.it> |
| In reply to | #1284442 |
On Sat 05-12-15 10:55:42, Geliang Tang wrote:
> On Thu, Dec 03, 2015 at 05:27:18PM +0100, Michal Hocko wrote:
> > On Thu 03-12-15 22:16:55, Geliang Tang wrote:
> > > To make the intention clearer, use list_{first,next}_entry instead
> > > of list_entry.
> >
> > Does this really help readability? This function simply uncharges the
> > given list of pages. Why cannot we simply use list_for_each_entry
> > instead...
>
> I have tested it, list_for_each_entry can't work. Dose it mean that my
> patch is OK? Or please give me some other advices.
I dunno. Your change is technically correct of course. I find the exit
condition easier to read without your patch though.
--
Michal Hocko
SUSE Labs
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web