Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1274292 > unrolled thread
| Started by | Phil Sutter <phil@nwl.cc> |
|---|---|
| First post | 2015-11-20 18:20 +0100 |
| Last post | 2015-12-06 04:50 +0100 |
| Articles | 20 on this page of 27 — 6 participants |
Back to article view | Back to linux.kernel
[PATCH v2 0/4] improve fault-tolerance of rhashtable runtime-test Phil Sutter <phil@nwl.cc> - 2015-11-20 18:20 +0100
[PATCH v2 1/4] rhashtable-test: add cond_resched() to thread test Phil Sutter <phil@nwl.cc> - 2015-11-20 18:20 +0100
Re: [PATCH v2 0/4] improve fault-tolerance of rhashtable runtime-test David Miller <davem@davemloft.net> - 2015-11-23 18:40 +0100
Re: [PATCH v2 0/4] improve fault-tolerance of rhashtable runtime-test Herbert Xu <herbert@gondor.apana.org.au> - 2015-11-30 10:40 +0100
Re: [PATCH v2 0/4] improve fault-tolerance of rhashtable runtime-test Phil Sutter <phil@nwl.cc> - 2015-11-30 11:20 +0100
Re: [PATCH v2 0/4] improve fault-tolerance of rhashtable runtime-test Herbert Xu <herbert@gondor.apana.org.au> - 2015-11-30 11:20 +0100
rhashtable: Prevent spurious EBUSY errors on insertion Herbert Xu <herbert@gondor.apana.org.au> - 2015-12-03 13:50 +0100
Re: rhashtable: Prevent spurious EBUSY errors on insertion Phil Sutter <phil@nwl.cc> - 2015-12-03 16:40 +0100
Re: rhashtable: Prevent spurious EBUSY errors on insertion David Miller <davem@davemloft.net> - 2015-12-04 20:40 +0100
rhashtable: ENOMEM errors when hit with a flood of insertions Herbert Xu <herbert@gondor.apana.org.au> - 2015-12-03 14:00 +0100
RE: rhashtable: ENOMEM errors when hit with a flood of insertions David Laight <David.Laight@ACULAB.COM> - 2015-12-03 16:20 +0100
Re: rhashtable: ENOMEM errors when hit with a flood of insertions Eric Dumazet <eric.dumazet@gmail.com> - 2015-12-03 17:10 +0100
Re: rhashtable: ENOMEM errors when hit with a flood of insertions Herbert Xu <herbert@gondor.apana.org.au> - 2015-12-04 01:10 +0100
rhashtable: Use __vmalloc with GFP_ATOMIC for table allocation Herbert Xu <herbert@gondor.apana.org.au> - 2015-12-04 15:50 +0100
Re: rhashtable: Use __vmalloc with GFP_ATOMIC for table allocation Eric Dumazet <eric.dumazet@gmail.com> - 2015-12-04 18:50 +0100
Re: rhashtable: Use __vmalloc with GFP_ATOMIC for table allocation Phil Sutter <phil@nwl.cc> - 2015-12-04 19:20 +0100
Re: rhashtable: Use __vmalloc with GFP_ATOMIC for table allocation Herbert Xu <herbert@gondor.apana.org.au> - 2015-12-05 08:10 +0100
Re: rhashtable: Use __vmalloc with GFP_ATOMIC for table allocation Thomas Graf <tgraf@suug.ch> - 2015-12-07 16:40 +0100
Re: rhashtable: Use __vmalloc with GFP_ATOMIC for table allocation David Miller <davem@davemloft.net> - 2015-12-07 20:40 +0100
Re: rhashtable: Use __vmalloc with GFP_ATOMIC for table allocation Thomas Graf <tgraf@suug.ch> - 2015-12-09 03:20 +0100
Re: rhashtable: Use __vmalloc with GFP_ATOMIC for table allocation Herbert Xu <herbert@gondor.apana.org.au> - 2015-12-09 03:30 +0100
Re: rhashtable: Use __vmalloc with GFP_ATOMIC for table allocation Herbert Xu <herbert@gondor.apana.org.au> - 2015-12-09 03:40 +0100
Re: rhashtable: Use __vmalloc with GFP_ATOMIC for table allocation Thomas Graf <tgraf@suug.ch> - 2015-12-09 03:50 +0100
Re: rhashtable: Use __vmalloc with GFP_ATOMIC for table allocation Thomas Graf <tgraf@suug.ch> - 2015-12-09 03:40 +0100
Re: rhashtable: Use __vmalloc with GFP_ATOMIC for table allocation David Miller <davem@davemloft.net> - 2015-12-04 23:00 +0100
Re: rhashtable: Use __vmalloc with GFP_ATOMIC for table allocation Herbert Xu <herbert@gondor.apana.org.au> - 2015-12-05 08:10 +0100
Re: rhashtable: Use __vmalloc with GFP_ATOMIC for table allocation David Miller <davem@davemloft.net> - 2015-12-06 04:50 +0100
Page 1 of 2 [1] 2 Next page →
| From | Phil Sutter <phil@nwl.cc> |
|---|---|
| Date | 2015-11-20 18:20 +0100 |
| Subject | [PATCH v2 0/4] improve fault-tolerance of rhashtable runtime-test |
| Message-ID | <qwXvP-1JB-15@gated-at.bofh.it> |
The following series aims to improve lib/test_rhashtable in different
situations:
Patch 1 allows the kernel to reschedule so the test does not block too
long on slow systems.
Patch 2 fixes behaviour under pressure, retrying inserts in non-permanent
error case (-EBUSY).
Patch 3 auto-adjusts the upper table size limit according to the number
of threads (in concurrency test). In fact, the current default is
already too small.
Patch 4 makes it possible to retry inserts even in supposedly permanent
error case (-ENOMEM) to expose rhashtable's remaining problem of
-ENOMEM being not as permanent as it is expected to be.
Changes since v1:
- Introduce insert_retry() which is then used in single-threaded test as
well.
- Do not retry inserts by default if -ENOMEM was returned.
- Rename the retry counter to be a bit more verbose about what it
contains.
- Add patch 4 as a debugging aid.
Phil Sutter (4):
rhashtable-test: add cond_resched() to thread test
rhashtable-test: retry insert operations
rhashtable-test: calculate max_entries value by default
rhashtable-test: allow to retry even if -ENOMEM was returned
lib/test_rhashtable.c | 76 +++++++++++++++++++++++++++++++++------------------
1 file changed, 50 insertions(+), 26 deletions(-)
--
2.1.2
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [next] | [standalone]
| From | Phil Sutter <phil@nwl.cc> |
|---|---|
| Date | 2015-11-20 18:20 +0100 |
| Subject | [PATCH v2 1/4] rhashtable-test: add cond_resched() to thread test |
| Message-ID | <qwXvQ-1JB-33@gated-at.bofh.it> |
| In reply to | #1274292 |
This should fix for soft lockup bugs triggered on slow systems.
Signed-off-by: Phil Sutter <phil@nwl.cc>
---
lib/test_rhashtable.c | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/lib/test_rhashtable.c b/lib/test_rhashtable.c
index 8c1ad1c..63654e3 100644
--- a/lib/test_rhashtable.c
+++ b/lib/test_rhashtable.c
@@ -236,6 +236,8 @@ static int thread_lookup_test(struct thread_data *tdata)
obj->value, key);
err++;
}
+
+ cond_resched();
}
return err;
}
@@ -251,6 +253,7 @@ static int threadfunc(void *data)
for (i = 0; i < entries; i++) {
tdata->objs[i].value = (tdata->id << 16) | i;
+ cond_resched();
err = rhashtable_insert_fast(&ht, &tdata->objs[i].node,
test_rht_params);
if (err == -ENOMEM || err == -EBUSY) {
@@ -285,6 +288,8 @@ static int threadfunc(void *data)
goto out;
}
tdata->objs[i].value = TEST_INSERT_FAIL;
+
+ cond_resched();
}
err = thread_lookup_test(tdata);
if (err) {
--
2.1.2
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | David Miller <davem@davemloft.net> |
|---|---|
| Date | 2015-11-23 18:40 +0100 |
| Subject | Re: [PATCH v2 0/4] improve fault-tolerance of rhashtable runtime-test |
| Message-ID | <qy3fP-4Y1-3@gated-at.bofh.it> |
| In reply to | #1274292 |
From: Phil Sutter <phil@nwl.cc> Date: Fri, 20 Nov 2015 18:17:16 +0100 > The following series aims to improve lib/test_rhashtable in different > situations: > > Patch 1 allows the kernel to reschedule so the test does not block too > long on slow systems. > Patch 2 fixes behaviour under pressure, retrying inserts in non-permanent > error case (-EBUSY). > Patch 3 auto-adjusts the upper table size limit according to the number > of threads (in concurrency test). In fact, the current default is > already too small. > Patch 4 makes it possible to retry inserts even in supposedly permanent > error case (-ENOMEM) to expose rhashtable's remaining problem of > -ENOMEM being not as permanent as it is expected to be. > > Changes since v1: > - Introduce insert_retry() which is then used in single-threaded test as > well. > - Do not retry inserts by default if -ENOMEM was returned. > - Rename the retry counter to be a bit more verbose about what it > contains. > - Add patch 4 as a debugging aid. Series applied, thanks Phil. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Herbert Xu <herbert@gondor.apana.org.au> |
|---|---|
| Date | 2015-11-30 10:40 +0100 |
| Message-ID | <qAt6b-1Ny-17@gated-at.bofh.it> |
| In reply to | #1274292 |
Phil Sutter <phil@nwl.cc> wrote: > The following series aims to improve lib/test_rhashtable in different > situations: > > Patch 1 allows the kernel to reschedule so the test does not block too > long on slow systems. > Patch 2 fixes behaviour under pressure, retrying inserts in non-permanent > error case (-EBUSY). > Patch 3 auto-adjusts the upper table size limit according to the number > of threads (in concurrency test). In fact, the current default is > already too small. > Patch 4 makes it possible to retry inserts even in supposedly permanent > error case (-ENOMEM) to expose rhashtable's remaining problem of > -ENOMEM being not as permanent as it is expected to be. I'm sorry but this patch series is simply bogus. If rhashtable is indeed returning such errors under normal conditions then rhashtable is broken and we must fix it instead of working around it in the test code! FWIW I still haven't been able to reproduce this problem, perhaps because my machines have too few CPUs? So can someone please help me reproduce this? Because just loading test_rhashtable isn't doing it. Thanks, -- Email: Herbert Xu <herbert@gondor.apana.org.au> Home Page: http://gondor.apana.org.au/~herbert/ PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Phil Sutter <phil@nwl.cc> |
|---|---|
| Date | 2015-11-30 11:20 +0100 |
| Message-ID | <qAtIR-2gq-1@gated-at.bofh.it> |
| In reply to | #1279733 |
On Mon, Nov 30, 2015 at 05:37:55PM +0800, Herbert Xu wrote: > Phil Sutter <phil@nwl.cc> wrote: > > The following series aims to improve lib/test_rhashtable in different > > situations: > > > > Patch 1 allows the kernel to reschedule so the test does not block too > > long on slow systems. > > Patch 2 fixes behaviour under pressure, retrying inserts in non-permanent > > error case (-EBUSY). > > Patch 3 auto-adjusts the upper table size limit according to the number > > of threads (in concurrency test). In fact, the current default is > > already too small. > > Patch 4 makes it possible to retry inserts even in supposedly permanent > > error case (-ENOMEM) to expose rhashtable's remaining problem of > > -ENOMEM being not as permanent as it is expected to be. > > I'm sorry but this patch series is simply bogus. The whole series?! > If rhashtable is indeed returning such errors under normal > conditions then rhashtable is broken and we must fix it instead > of working around it in the test code! You're stating the obvious. Remember, the reason I prepared patch 4 was because you wanted to fix just that bug in rhashtable in the first place. Just to make this clear: Patches 1-3 are reasonable on their own, the only connection to the bug is that patch 2 makes it visible (at least on my system it wasn't before). > FWIW I still haven't been able to reproduce this problem, perhaps > because my machines have too few CPUs? Did you try with my bogus patch series applied? How many CPUs does your test system actually have? > So can someone please help me reproduce this? Because just loading > test_rhashtable isn't doing it. As said, maybe you need to increase the number of spawned threads (tcount=50 or so). Cheers, Phil -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Herbert Xu <herbert@gondor.apana.org.au> |
|---|---|
| Date | 2015-11-30 11:20 +0100 |
| Message-ID | <qAtIR-2gq-15@gated-at.bofh.it> |
| In reply to | #1279745 |
On Mon, Nov 30, 2015 at 11:14:01AM +0100, Phil Sutter wrote: > On Mon, Nov 30, 2015 at 05:37:55PM +0800, Herbert Xu wrote: > > Phil Sutter <phil@nwl.cc> wrote: > > > The following series aims to improve lib/test_rhashtable in different > > > situations: > > > > > > Patch 1 allows the kernel to reschedule so the test does not block too > > > long on slow systems. > > > Patch 2 fixes behaviour under pressure, retrying inserts in non-permanent > > > error case (-EBUSY). > > > Patch 3 auto-adjusts the upper table size limit according to the number > > > of threads (in concurrency test). In fact, the current default is > > > already too small. > > > Patch 4 makes it possible to retry inserts even in supposedly permanent > > > error case (-ENOMEM) to expose rhashtable's remaining problem of > > > -ENOMEM being not as permanent as it is expected to be. > > > > I'm sorry but this patch series is simply bogus. > > The whole series?! Well at least patch two and four seem clearly wrong because no rhashtable user should need to retry insertions. > Did you try with my bogus patch series applied? How many CPUs does your > test system actually have? > > > So can someone please help me reproduce this? Because just loading > > test_rhashtable isn't doing it. > > As said, maybe you need to increase the number of spawned threads > (tcount=50 or so). OK that's better. I think I see the problem. The test in rhashtable_insert_rehash is racy and if two threads both try to grow the table one of them may be tricked into doing a rehash instead. I'm working on a fix. Thanks, -- Email: Herbert Xu <herbert@gondor.apana.org.au> Home Page: http://gondor.apana.org.au/~herbert/ PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Herbert Xu <herbert@gondor.apana.org.au> |
|---|---|
| Date | 2015-12-03 13:50 +0100 |
| Subject | rhashtable: Prevent spurious EBUSY errors on insertion |
| Message-ID | <qBBuH-53y-37@gated-at.bofh.it> |
| In reply to | #1279747 |
On Mon, Nov 30, 2015 at 06:18:59PM +0800, Herbert Xu wrote:
>
> OK that's better. I think I see the problem. The test in
> rhashtable_insert_rehash is racy and if two threads both try
> to grow the table one of them may be tricked into doing a rehash
> instead.
>
> I'm working on a fix.
OK this patch fixes the EBUSY problem as far as I can tell. Please
let me know if you still observe EBUSY with it. I'll respond to the
ENOMEM problem in another email.
---8<---
Thomas and Phil observed that under stress rhashtable insertion
sometimes failed with EBUSY, even though this error should only
ever been seen when we're under attack and our hash chain length
has grown to an unacceptable level, even after a rehash.
It turns out that the logic for detecting whether there is an
existing rehash is faulty. In particular, when two threads both
try to grow the same table at the same time, one of them may see
the newly grown table and thus erroneously conclude that it had
been rehashed. This is what leads to the EBUSY error.
This patch fixes this by remembering the current last table we
used during insertion so that rhashtable_insert_rehash can detect
when another thread has also done a resize/rehash. When this is
detected we will give up our resize/rehash and simply retry the
insertion with the new table.
Reported-by: Thomas Graf <tgraf@suug.ch>
Reported-by: Phil Sutter <phil@nwl.cc>
Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au>
diff --git a/include/linux/rhashtable.h b/include/linux/rhashtable.h
index 843ceca..e50b31d 100644
--- a/include/linux/rhashtable.h
+++ b/include/linux/rhashtable.h
@@ -19,6 +19,7 @@
#include <linux/atomic.h>
#include <linux/compiler.h>
+#include <linux/err.h>
#include <linux/errno.h>
#include <linux/jhash.h>
#include <linux/list_nulls.h>
@@ -339,10 +340,11 @@ static inline int lockdep_rht_bucket_is_held(const struct bucket_table *tbl,
int rhashtable_init(struct rhashtable *ht,
const struct rhashtable_params *params);
-int rhashtable_insert_slow(struct rhashtable *ht, const void *key,
- struct rhash_head *obj,
- struct bucket_table *old_tbl);
-int rhashtable_insert_rehash(struct rhashtable *ht);
+struct bucket_table *rhashtable_insert_slow(struct rhashtable *ht,
+ const void *key,
+ struct rhash_head *obj,
+ struct bucket_table *old_tbl);
+int rhashtable_insert_rehash(struct rhashtable *ht, struct bucket_table *tbl);
int rhashtable_walk_init(struct rhashtable *ht, struct rhashtable_iter *iter);
void rhashtable_walk_exit(struct rhashtable_iter *iter);
@@ -598,9 +600,11 @@ restart:
new_tbl = rht_dereference_rcu(tbl->future_tbl, ht);
if (unlikely(new_tbl)) {
- err = rhashtable_insert_slow(ht, key, obj, new_tbl);
- if (err == -EAGAIN)
+ tbl = rhashtable_insert_slow(ht, key, obj, new_tbl);
+ if (!IS_ERR_OR_NULL(tbl))
goto slow_path;
+
+ err = PTR_ERR(tbl);
goto out;
}
@@ -611,7 +615,7 @@ restart:
if (unlikely(rht_grow_above_100(ht, tbl))) {
slow_path:
spin_unlock_bh(lock);
- err = rhashtable_insert_rehash(ht);
+ err = rhashtable_insert_rehash(ht, tbl);
rcu_read_unlock();
if (err)
return err;
diff --git a/lib/rhashtable.c b/lib/rhashtable.c
index a54ff89..2ff7ed9 100644
--- a/lib/rhashtable.c
+++ b/lib/rhashtable.c
@@ -389,33 +389,31 @@ static bool rhashtable_check_elasticity(struct rhashtable *ht,
return false;
}
-int rhashtable_insert_rehash(struct rhashtable *ht)
+int rhashtable_insert_rehash(struct rhashtable *ht,
+ struct bucket_table *tbl)
{
struct bucket_table *old_tbl;
struct bucket_table *new_tbl;
- struct bucket_table *tbl;
unsigned int size;
int err;
old_tbl = rht_dereference_rcu(ht->tbl, ht);
- tbl = rhashtable_last_table(ht, old_tbl);
size = tbl->size;
+ err = -EBUSY;
+
if (rht_grow_above_75(ht, tbl))
size *= 2;
/* Do not schedule more than one rehash */
else if (old_tbl != tbl)
- return -EBUSY;
+ goto fail;
+
+ err = -ENOMEM;
new_tbl = bucket_table_alloc(ht, size, GFP_ATOMIC);
- if (new_tbl == NULL) {
- /* Schedule async resize/rehash to try allocation
- * non-atomic context.
- */
- schedule_work(&ht->run_work);
- return -ENOMEM;
- }
+ if (new_tbl == NULL)
+ goto fail;
err = rhashtable_rehash_attach(ht, tbl, new_tbl);
if (err) {
@@ -426,12 +424,24 @@ int rhashtable_insert_rehash(struct rhashtable *ht)
schedule_work(&ht->run_work);
return err;
+
+fail:
+ /* Do not fail the insert if someone else did a rehash. */
+ if (likely(rcu_dereference_raw(tbl->future_tbl)))
+ return 0;
+
+ /* Schedule async rehash to retry allocation in process context. */
+ if (err == -ENOMEM)
+ schedule_work(&ht->run_work);
+
+ return err;
}
EXPORT_SYMBOL_GPL(rhashtable_insert_rehash);
-int rhashtable_insert_slow(struct rhashtable *ht, const void *key,
- struct rhash_head *obj,
- struct bucket_table *tbl)
+struct bucket_table *rhashtable_insert_slow(struct rhashtable *ht,
+ const void *key,
+ struct rhash_head *obj,
+ struct bucket_table *tbl)
{
struct rhash_head *head;
unsigned int hash;
@@ -467,7 +477,12 @@ int rhashtable_insert_slow(struct rhashtable *ht, const void *key,
exit:
spin_unlock(rht_bucket_lock(tbl, hash));
- return err;
+ if (err == 0)
+ return NULL;
+ else if (err == -EAGAIN)
+ return tbl;
+ else
+ return ERR_PTR(err);
}
EXPORT_SYMBOL_GPL(rhashtable_insert_slow);
--
Email: Herbert Xu <herbert@gondor.apana.org.au>
Home Page: http://gondor.apana.org.au/~herbert/
PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Phil Sutter <phil@nwl.cc> |
|---|---|
| Date | 2015-12-03 16:40 +0100 |
| Subject | Re: rhashtable: Prevent spurious EBUSY errors on insertion |
| Message-ID | <qBE9c-6XG-7@gated-at.bofh.it> |
| In reply to | #1283009 |
On Thu, Dec 03, 2015 at 08:41:29PM +0800, Herbert Xu wrote: > On Mon, Nov 30, 2015 at 06:18:59PM +0800, Herbert Xu wrote: > > > > OK that's better. I think I see the problem. The test in > > rhashtable_insert_rehash is racy and if two threads both try > > to grow the table one of them may be tricked into doing a rehash > > instead. > > > > I'm working on a fix. > > OK this patch fixes the EBUSY problem as far as I can tell. Please > let me know if you still observe EBUSY with it. I'll respond to the > ENOMEM problem in another email. > > ---8<--- > Thomas and Phil observed that under stress rhashtable insertion > sometimes failed with EBUSY, even though this error should only > ever been seen when we're under attack and our hash chain length > has grown to an unacceptable level, even after a rehash. > > It turns out that the logic for detecting whether there is an > existing rehash is faulty. In particular, when two threads both > try to grow the same table at the same time, one of them may see > the newly grown table and thus erroneously conclude that it had > been rehashed. This is what leads to the EBUSY error. > > This patch fixes this by remembering the current last table we > used during insertion so that rhashtable_insert_rehash can detect > when another thread has also done a resize/rehash. When this is > detected we will give up our resize/rehash and simply retry the > insertion with the new table. > > Reported-by: Thomas Graf <tgraf@suug.ch> > Reported-by: Phil Sutter <phil@nwl.cc> > Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au> Tested-by: Phil Sutter <phil@nwl.cc> -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | David Miller <davem@davemloft.net> |
|---|---|
| Date | 2015-12-04 20:40 +0100 |
| Subject | Re: rhashtable: Prevent spurious EBUSY errors on insertion |
| Message-ID | <qC4n0-6Wi-15@gated-at.bofh.it> |
| In reply to | #1283009 |
From: Herbert Xu <herbert@gondor.apana.org.au> Date: Thu, 3 Dec 2015 20:41:29 +0800 > Thomas and Phil observed that under stress rhashtable insertion > sometimes failed with EBUSY, even though this error should only > ever been seen when we're under attack and our hash chain length > has grown to an unacceptable level, even after a rehash. > > It turns out that the logic for detecting whether there is an > existing rehash is faulty. In particular, when two threads both > try to grow the same table at the same time, one of them may see > the newly grown table and thus erroneously conclude that it had > been rehashed. This is what leads to the EBUSY error. > > This patch fixes this by remembering the current last table we > used during insertion so that rhashtable_insert_rehash can detect > when another thread has also done a resize/rehash. When this is > detected we will give up our resize/rehash and simply retry the > insertion with the new table. > > Reported-by: Thomas Graf <tgraf@suug.ch> > Reported-by: Phil Sutter <phil@nwl.cc> > Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au> Looks good, applied, thanks Herbert. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Herbert Xu <herbert@gondor.apana.org.au> |
|---|---|
| Date | 2015-12-03 14:00 +0100 |
| Subject | rhashtable: ENOMEM errors when hit with a flood of insertions |
| Message-ID | <qBBEn-58q-15@gated-at.bofh.it> |
| In reply to | #1279747 |
On Mon, Nov 30, 2015 at 06:18:59PM +0800, Herbert Xu wrote: > > OK that's better. I think I see the problem. The test in > rhashtable_insert_rehash is racy and if two threads both try > to grow the table one of them may be tricked into doing a rehash > instead. > > I'm working on a fix. While the EBUSY errors are gone for me, I can still see plenty of ENOMEM errors. In fact it turns out that the reason is quite understandable. When you pound the rhashtable hard so that it doesn't actually get a chance to grow the table in process context, then the table will only grow with GFP_ATOMIC allocations. For me this starts failing regularly at around 2^19 entries, which requires about 1024 contiguous pages if I'm not mistaken. I've got fairly straightforward solution for this, but it does mean that we have to add another level of complexity to the rhashtable implementation. So before I go there I want to be absolutely sure that we need it. I guess the question is do we care about users that pound rhashtable in this fashion? My answer would be yes but I'd like to hear your opinions. My solution is to use a slightly more complex/less efficient hash table when we fail the allocation in interrupt context. Instead of allocating contiguous pages, we'll simply switch to allocating individual pages and have a master page that points to them. On a 64-bit platform, each page can accomodate 512 entries. So with a two-level deep setup (meaning one extra access for a hash lookup), this would accomodate 2^18 entries. Three levels (two extra lookups) will give us 2^27 entries, which should be enough. When we do this we should of course schedule an async rehash so that as soon as we get a chance we can move the entries into a normal hash table that needs only a single lookup. Cheers, -- Email: Herbert Xu <herbert@gondor.apana.org.au> Home Page: http://gondor.apana.org.au/~herbert/ PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | David Laight <David.Laight@ACULAB.COM> |
|---|---|
| Date | 2015-12-03 16:20 +0100 |
| Subject | RE: rhashtable: ENOMEM errors when hit with a flood of insertions |
| Message-ID | <qBDPQ-6Rh-25@gated-at.bofh.it> |
| In reply to | #1283024 |
From: Herbert Xu > Sent: 03 December 2015 12:51 > On Mon, Nov 30, 2015 at 06:18:59PM +0800, Herbert Xu wrote: > > > > OK that's better. I think I see the problem. The test in > > rhashtable_insert_rehash is racy and if two threads both try > > to grow the table one of them may be tricked into doing a rehash > > instead. > > > > I'm working on a fix. > > While the EBUSY errors are gone for me, I can still see plenty > of ENOMEM errors. In fact it turns out that the reason is quite > understandable. When you pound the rhashtable hard so that it > doesn't actually get a chance to grow the table in process context, > then the table will only grow with GFP_ATOMIC allocations. > > For me this starts failing regularly at around 2^19 entries, which > requires about 1024 contiguous pages if I'm not mistaken. ISTM that you should always let the insert succeed - even if it makes the average/maximum chain length increase beyond some limit. Any limit on the number of hashed items should have been done earlier by the calling code. The slight performance decrease caused by scanning longer chains is almost certainly more 'user friendly' than an error return. Hoping to get 1024+ contiguous VA pages does seem over-optimistic. With a 2-level lookup you could make all the 2nd level tables a fixed size (maybe 4 or 8 pages?) and extend the first level table as needed. David -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Eric Dumazet <eric.dumazet@gmail.com> |
|---|---|
| Date | 2015-12-03 17:10 +0100 |
| Subject | Re: rhashtable: ENOMEM errors when hit with a flood of insertions |
| Message-ID | <qBECe-7oz-17@gated-at.bofh.it> |
| In reply to | #1283024 |
On Thu, 2015-12-03 at 20:51 +0800, Herbert Xu wrote: > On Mon, Nov 30, 2015 at 06:18:59PM +0800, Herbert Xu wrote: > > > > OK that's better. I think I see the problem. The test in > > rhashtable_insert_rehash is racy and if two threads both try > > to grow the table one of them may be tricked into doing a rehash > > instead. > > > > I'm working on a fix. > > While the EBUSY errors are gone for me, I can still see plenty > of ENOMEM errors. In fact it turns out that the reason is quite > understandable. When you pound the rhashtable hard so that it > doesn't actually get a chance to grow the table in process context, > then the table will only grow with GFP_ATOMIC allocations. > > For me this starts failing regularly at around 2^19 entries, which > requires about 1024 contiguous pages if I'm not mistaken. Well, it will fail before this point if memory is fragmented. Anyway, __vmalloc() can be used with GFP_ATOMIC, have you tried this ? diff --git a/lib/rhashtable.c b/lib/rhashtable.c index a54ff8949f91..9ef5d74963b2 100644 --- a/lib/rhashtable.c +++ b/lib/rhashtable.c @@ -120,8 +120,9 @@ static struct bucket_table *bucket_table_alloc(struct rhashtable *ht, if (size <= (PAGE_SIZE << PAGE_ALLOC_COSTLY_ORDER) || gfp != GFP_KERNEL) tbl = kzalloc(size, gfp | __GFP_NOWARN | __GFP_NORETRY); - if (tbl == NULL && gfp == GFP_KERNEL) - tbl = vzalloc(size); + if (tbl == NULL) + tbl = __vmalloc(size, gfp | __GFP_HIGHMEM | __GFP_ZERO, + PAGE_KERNEL); if (tbl == NULL) return NULL; -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Herbert Xu <herbert@gondor.apana.org.au> |
|---|---|
| Date | 2015-12-04 01:10 +0100 |
| Subject | Re: rhashtable: ENOMEM errors when hit with a flood of insertions |
| Message-ID | <qBM6K-3He-5@gated-at.bofh.it> |
| In reply to | #1283159 |
On Thu, Dec 03, 2015 at 08:08:39AM -0800, Eric Dumazet wrote: > > Well, it will fail before this point if memory is fragmented. Indeed, I was surprised that it even worked up to that point, possibly because the previous resizes might have actually been done in process context. > Anyway, __vmalloc() can be used with GFP_ATOMIC, have you tried this ? Ah I didn't know that. That would be much simpler. I'll give it a try. Thanks Eric! -- Email: Herbert Xu <herbert@gondor.apana.org.au> Home Page: http://gondor.apana.org.au/~herbert/ PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Herbert Xu <herbert@gondor.apana.org.au> |
|---|---|
| Date | 2015-12-04 15:50 +0100 |
| Subject | rhashtable: Use __vmalloc with GFP_ATOMIC for table allocation |
| Message-ID | <qBZQm-3Yo-27@gated-at.bofh.it> |
| In reply to | #1283159 |
On Thu, Dec 03, 2015 at 08:08:39AM -0800, Eric Dumazet wrote: > > Anyway, __vmalloc() can be used with GFP_ATOMIC, have you tried this ? OK I've tried it and I no longer get any ENOMEM errors! ---8<--- When an rhashtable user pounds rhashtable hard with back-to-back insertions we may end up growing the table in GFP_ATOMIC context. Unfortunately when the table reaches a certain size this often fails because we don't have enough physically contiguous pages to hold the new table. Eric Dumazet suggested (and in fact wrote this patch) using __vmalloc instead which can be used in GFP_ATOMIC context. Reported-by: Phil Sutter <phil@nwl.cc> Suggested-by: Eric Dumazet <eric.dumazet@gmail.com> Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au> diff --git a/lib/rhashtable.c b/lib/rhashtable.c index a54ff89..1c624db 100644 --- a/lib/rhashtable.c +++ b/lib/rhashtable.c @@ -120,8 +120,9 @@ static struct bucket_table *bucket_table_alloc(struct rhashtable *ht, if (size <= (PAGE_SIZE << PAGE_ALLOC_COSTLY_ORDER) || gfp != GFP_KERNEL) tbl = kzalloc(size, gfp | __GFP_NOWARN | __GFP_NORETRY); - if (tbl == NULL && gfp == GFP_KERNEL) - tbl = vzalloc(size); + if (tbl == NULL) + tbl = __vmalloc(size, gfp | __GFP_HIGHMEM | __GFP_ZERO, + PAGE_KERNEL); if (tbl == NULL) return NULL; -- Email: Herbert Xu <herbert@gondor.apana.org.au> Home Page: http://gondor.apana.org.au/~herbert/ PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Eric Dumazet <eric.dumazet@gmail.com> |
|---|---|
| Date | 2015-12-04 18:50 +0100 |
| Subject | Re: rhashtable: Use __vmalloc with GFP_ATOMIC for table allocation |
| Message-ID | <qC2Ez-5Oo-55@gated-at.bofh.it> |
| In reply to | #1283881 |
On Fri, 2015-12-04 at 18:01 +0100, Phil Sutter wrote: > On Fri, Dec 04, 2015 at 10:39:56PM +0800, Herbert Xu wrote: > > On Thu, Dec 03, 2015 at 08:08:39AM -0800, Eric Dumazet wrote: > > > > > > Anyway, __vmalloc() can be used with GFP_ATOMIC, have you tried this ? > > > > OK I've tried it and I no longer get any ENOMEM errors! > > I can't confirm this, sadly. Using 50 threads, results seem to be stable > and good. But increasing the number of threads I can provoke ENOMEM > condition again. See attached log which shows a failing test run with > 100 threads. > > I tried to extract logs of a test run with as few as possible failing > threads, but wasn't successful. It seems like the error amplifies > itself: While having stable success with less than 70 threads, going > beyond a margin I could not identify exactly, much more threads failed > than expected. For instance, the attached log shows 70 out of 100 > threads failing, while for me every single test with 50 threads was > successful. > > HTH, Phil But this patch is about GFP_ATOMIC allocations, I doubt your test is using GFP_ATOMIC. Threads (process context) should use GFP_KERNEL allocations. BTW, if 100 threads are simultaneously trying to vmalloc(32 MB), this might not be very wise :( Only one should really do this, while others are waiting. If we really want parallelism (multiple cpus coordinating their effort), it should be done very differently. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Phil Sutter <phil@nwl.cc> |
|---|---|
| Date | 2015-12-04 19:20 +0100 |
| Subject | Re: rhashtable: Use __vmalloc with GFP_ATOMIC for table allocation |
| Message-ID | <qC37B-6ec-23@gated-at.bofh.it> |
| In reply to | #1284119 |
On Fri, Dec 04, 2015 at 09:45:20AM -0800, Eric Dumazet wrote: > On Fri, 2015-12-04 at 18:01 +0100, Phil Sutter wrote: > > On Fri, Dec 04, 2015 at 10:39:56PM +0800, Herbert Xu wrote: > > > On Thu, Dec 03, 2015 at 08:08:39AM -0800, Eric Dumazet wrote: > > > > > > > > Anyway, __vmalloc() can be used with GFP_ATOMIC, have you tried this ? > > > > > > OK I've tried it and I no longer get any ENOMEM errors! > > > > I can't confirm this, sadly. Using 50 threads, results seem to be stable > > and good. But increasing the number of threads I can provoke ENOMEM > > condition again. See attached log which shows a failing test run with > > 100 threads. > > > > I tried to extract logs of a test run with as few as possible failing > > threads, but wasn't successful. It seems like the error amplifies > > itself: While having stable success with less than 70 threads, going > > beyond a margin I could not identify exactly, much more threads failed > > than expected. For instance, the attached log shows 70 out of 100 > > threads failing, while for me every single test with 50 threads was > > successful. > > But this patch is about GFP_ATOMIC allocations, I doubt your test is > using GFP_ATOMIC. > > Threads (process context) should use GFP_KERNEL allocations. Well, I assumed Herbert did his tests using test_rhashtable, and therefore fixed whatever code-path that triggers. Maybe I'm wrong, though. Looking at the vmalloc allocation failure trace, it seems like it's trying to indeed use GFP_ATOMIC from inside those threads: If I don't miss anything, bucket_table_alloc is called from rhashtable_insert_rehash, which passes GFP_ATOMIC unconditionally. But then again bucket_table_alloc should use kzalloc if 'gfp != GFP_KERNEL', so I'm probably just cross-eyed right now. > BTW, if 100 threads are simultaneously trying to vmalloc(32 MB), this > might not be very wise :( > > Only one should really do this, while others are waiting. Sure, that was my previous understanding of how this thing works. > If we really want parallelism (multiple cpus coordinating their effort), > it should be done very differently. Maybe my approach of stress-testing rhashtable was too naive in the first place. Thanks, Phil -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Herbert Xu <herbert@gondor.apana.org.au> |
|---|---|
| Date | 2015-12-05 08:10 +0100 |
| Subject | Re: rhashtable: Use __vmalloc with GFP_ATOMIC for table allocation |
| Message-ID | <qCf8K-5AQ-3@gated-at.bofh.it> |
| In reply to | #1284139 |
On Fri, Dec 04, 2015 at 07:15:55PM +0100, Phil Sutter wrote: > > > Only one should really do this, while others are waiting. > > Sure, that was my previous understanding of how this thing works. Yes that's clearly how it should be. Unfortunately while adding the locking to do this, I found out that you can't actually call __vmalloc with BH disabled so this is a no-go. Unless we can make __vmalloc work with BH disabled, I guess we'll have to go back to multi-level lookups unless someone has a better suggestion. Cheers, -- Email: Herbert Xu <herbert@gondor.apana.org.au> Home Page: http://gondor.apana.org.au/~herbert/ PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Thomas Graf <tgraf@suug.ch> |
|---|---|
| Date | 2015-12-07 16:40 +0100 |
| Subject | Re: rhashtable: Use __vmalloc with GFP_ATOMIC for table allocation |
| Message-ID | <qD63o-6mE-13@gated-at.bofh.it> |
| In reply to | #1284471 |
On 12/05/15 at 03:06pm, Herbert Xu wrote: > On Fri, Dec 04, 2015 at 07:15:55PM +0100, Phil Sutter wrote: > > > > > Only one should really do this, while others are waiting. > > > > Sure, that was my previous understanding of how this thing works. > > Yes that's clearly how it should be. Unfortunately while adding > the locking to do this, I found out that you can't actually call > __vmalloc with BH disabled so this is a no-go. > > Unless we can make __vmalloc work with BH disabled, I guess we'll > have to go back to multi-level lookups unless someone has a better > suggestion. Thanks for fixing the race. As for the remaining problem, I think we'll have to find a way to serve a hard pounding user if we want to convert TCP hashtables later on. Did you look into what __vmalloc prevents to work with BH disabled? -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | David Miller <davem@davemloft.net> |
|---|---|
| Date | 2015-12-07 20:40 +0100 |
| Subject | Re: rhashtable: Use __vmalloc with GFP_ATOMIC for table allocation |
| Message-ID | <qD9NE-lE-33@gated-at.bofh.it> |
| In reply to | #1285612 |
From: Thomas Graf <tgraf@suug.ch> Date: Mon, 7 Dec 2015 16:35:24 +0100 > Did you look into what __vmalloc prevents to work with BH disabled? You can't issue the cross-cpu TLB flushes from atomic contexts. It's the kernel page table updates that create the restriction. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Thomas Graf <tgraf@suug.ch> |
|---|---|
| Date | 2015-12-09 03:20 +0100 |
| Subject | Re: rhashtable: Use __vmalloc with GFP_ATOMIC for table allocation |
| Message-ID | <qDCwj-25G-27@gated-at.bofh.it> |
| In reply to | #1285873 |
On 12/05/15 at 03:06pm, Herbert Xu wrote: > Unless we can make __vmalloc work with BH disabled, I guess we'll > have to go back to multi-level lookups unless someone has a better > suggestion. Assuming that we only encounter this scenario with very large table sizes, it might be OK to assume that deferring the actual resize via the worker thread while continuing to insert above 100% utilization in atomic context is safe. On 12/07/15 at 02:29pm, David Miller wrote: > You can't issue the cross-cpu TLB flushes from atomic contexts. > It's the kernel page table updates that create the restriction. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
Page 1 of 2 [1] 2 Next page →
Back to top | Article view | linux.kernel
csiph-web