Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1279282 > unrolled thread

Re: [ovirt-devel] Networking fails for VM running on Centos6.7.Works on Centos6.5

Started byDan Kenigsberg <danken@redhat.com>
First post2015-11-29 09:00 +0100
Last post2015-11-29 21:10 +0100
Articles 3 — 3 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [ovirt-devel] Networking fails for VM running on Centos6.7.Works  on Centos6.5 Dan Kenigsberg <danken@redhat.com> - 2015-11-29 09:00 +0100
    Re: [ovirt-users] [ovirt-devel] Networking fails for VM running on  Centos6.7.Works on Centos6.5 Giorgio Bersano <giorgio.bersano@gmail.com> - 2015-11-29 21:00 +0100
    Re: [ovirt-devel] Networking fails for VM running on Centos6.7.Works  on Centos6.5 mad Engineer <themadengin33r@gmail.com> - 2015-11-29 21:10 +0100

#1279282 — Re: [ovirt-devel] Networking fails for VM running on Centos6.7.Works on Centos6.5

FromDan Kenigsberg <danken@redhat.com>
Date2015-11-29 09:00 +0100
SubjectRe: [ovirt-devel] Networking fails for VM running on Centos6.7.Works on Centos6.5
Message-ID<qA53P-3nY-5@gated-at.bofh.it>
On Sat, Nov 28, 2015 at 08:10:06PM +0530, mad Engineer wrote:
> hello all i am having strange network issue with vms that are running on
> centos 6.7 ovirt nodes.
> 
> I recently added one more ovirt node which is running centos6.7 and
> upgraded from centos6.5 to centos6.7 on all other nodes.
> 
> All VMs running on nodes with centos6.7 as host Operating system fail to
> reach network gateway,but if i reboot that same host to centos6.5 kernel
> everything works fine(with out changing any network configuration).
> 
> Initially i thought it as configuration issue but its there on all nodes.if
> i reboot to old kernel everything is working.
> 
> I am aware about ghost vlan0 issue in centos6.6 kernel.Not aware about any
> issue in centos6.7 Also all my servers are up to date.
> 
> 
> All physical interfaces are in access mode VLAN connected to nexus 5k
> switches.
> 
> 
> working kernel- 2.6.32-431.20.3.el6.x86_64
> 
> non working kernel- 2.6.32-573.8.1.el6.x86_64

Can you provide the topology of your VM network config (vlan, bond, bond
options, bridge options)? Do you have an IP address on the bridge?

(I have not seen this happen myself)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1279410 — Re: [ovirt-users] [ovirt-devel] Networking fails for VM running on Centos6.7.Works on Centos6.5

FromGiorgio Bersano <giorgio.bersano@gmail.com>
Date2015-11-29 21:00 +0100
SubjectRe: [ovirt-users] [ovirt-devel] Networking fails for VM running on Centos6.7.Works on Centos6.5
Message-ID<qAgiC-1U5-17@gated-at.bofh.it>
In reply to#1279282
2015-11-29 8:59 GMT+01:00 Dan Kenigsberg <danken@redhat.com>:
> On Sat, Nov 28, 2015 at 08:10:06PM +0530, mad Engineer wrote:
>> hello all i am having strange network issue with vms that are running on
>> centos 6.7 ovirt nodes.
>>
>> I recently added one more ovirt node which is running centos6.7 and
>> upgraded from centos6.5 to centos6.7 on all other nodes.
>>
>> All VMs running on nodes with centos6.7 as host Operating system fail to
>> reach network gateway,but if i reboot that same host to centos6.5 kernel
>> everything works fine(with out changing any network configuration).
>>
>> Initially i thought it as configuration issue but its there on all nodes.if
>> i reboot to old kernel everything is working.
>>
>> I am aware about ghost vlan0 issue in centos6.6 kernel.Not aware about any
>> issue in centos6.7 Also all my servers are up to date.
>>
>>
>> All physical interfaces are in access mode VLAN connected to nexus 5k
>> switches.
>>
>>
>> working kernel- 2.6.32-431.20.3.el6.x86_64
>>
>> non working kernel- 2.6.32-573.8.1.el6.x86_64

Do you have the possibility to test with
kernel-2.6.32-504.16.2.el6.x86_64 (it's in CentOS Vault now) ?

What I have seen in our environment is that - regarding this problem -
it is the latest correctly working kernel.
There are clear signs of misbehaviours due to changes in the VLAN code
between that kernel and the next one (2.6.32-504.23.4.el6.x86_64). Not
always, it could also depend on the nic driver involved.

Also take a look at https://bugs.centos.org/view.php?id=9467 and
https://bugzilla.redhat.com/show_bug.cgi?id=1263561 .

> Can you provide the topology of your VM network config (vlan, bond, bond
> options, bridge options)? Do you have an IP address on the bridge?
>
> (I have not seen this happen myself)

Dan, did you see this
https://www.mail-archive.com/users@ovirt.org/msg28561.html  thread?

We have seen this bug in oVirt (bond+VLAN+bridges) but also in simple
KVM with VLAN+bridges and with plain servers using VLANS directly over
nic. Therefore I think the topology is almost unrelated and the
problem regards VLAN code.

I would be very interested in
https://bugzilla.redhat.com/show_bug.cgi?id=1264316 but public access
is denied. Do you have access to it? I hope so.

Best regards,
Giorgio.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1279411

Frommad Engineer <themadengin33r@gmail.com>
Date2015-11-29 21:10 +0100
Message-ID<qAgsi-2cQ-3@gated-at.bofh.it>
In reply to#1279282
each vm has 4 nics connected to 4 different  bridges which is
connected to 4 different physical interface in access mode VLAN.No
bonding between interfaces.I have IP assigned on "ovirtmgmt" bridge
which is used for storage,migration,console and VM internet access.All
interfaces are 10G with MTU 9000.
During my test only change i made was booting to centos6.5 kernel.

Facing another issue with PXE booting guest machines switching to old
kernel fixes this too

On Sun, Nov 29, 2015 at 1:29 PM, Dan Kenigsberg <danken@redhat.com> wrote:
> On Sat, Nov 28, 2015 at 08:10:06PM +0530, mad Engineer wrote:
>> hello all i am having strange network issue with vms that are running on
>> centos 6.7 ovirt nodes.
>>
>> I recently added one more ovirt node which is running centos6.7 and
>> upgraded from centos6.5 to centos6.7 on all other nodes.
>>
>> All VMs running on nodes with centos6.7 as host Operating system fail to
>> reach network gateway,but if i reboot that same host to centos6.5 kernel
>> everything works fine(with out changing any network configuration).
>>
>> Initially i thought it as configuration issue but its there on all nodes.if
>> i reboot to old kernel everything is working.
>>
>> I am aware about ghost vlan0 issue in centos6.6 kernel.Not aware about any
>> issue in centos6.7 Also all my servers are up to date.
>>
>>
>> All physical interfaces are in access mode VLAN connected to nexus 5k
>> switches.
>>
>>
>> working kernel- 2.6.32-431.20.3.el6.x86_64
>>
>> non working kernel- 2.6.32-573.8.1.el6.x86_64
>
> Can you provide the topology of your VM network config (vlan, bond, bond
> options, bridge options)? Do you have an IP address on the bridge?
>
> (I have not seen this happen myself)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web