Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1280646 > unrolled thread
| Started by | Peter Ujfalusi <peter.ujfalusi@ti.com> |
|---|---|
| First post | 2015-12-01 09:50 +0100 |
| Last post | 2015-12-01 09:50 +0100 |
| Articles | 1 — 1 participant |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [RFC v02 02/15] dmaengine: core: Move and merge the code paths using private_candidate Peter Ujfalusi <peter.ujfalusi@ti.com> - 2015-12-01 09:50 +0100
| From | Peter Ujfalusi <peter.ujfalusi@ti.com> |
|---|---|
| Date | 2015-12-01 09:50 +0100 |
| Subject | Re: [RFC v02 02/15] dmaengine: core: Move and merge the code paths using private_candidate |
| Message-ID | <qAONj-7gM-1@gated-at.bofh.it> |
On 11/30/2015 04:42 PM, Andy Shevchenko wrote: > On Mon, Nov 30, 2015 at 3:45 PM, Peter Ujfalusi <peter.ujfalusi@ti.com> wrote: >> Channel matching with private_candidate() is used in two paths, the error >> checking is slightly different in them and they are duplicating code also. >> Move the code under dma_get_channel() to provide consistent execution and >> going to allow us to reuse this mode of channel lookup later. >> >> Signed-off-by: Peter Ujfalusi <peter.ujfalusi@ti.com> >> --- >> drivers/dma/dmaengine.c | 81 +++++++++++++++++++++++++------------------------ >> 1 file changed, 42 insertions(+), 39 deletions(-) >> >> diff --git a/drivers/dma/dmaengine.c b/drivers/dma/dmaengine.c >> index 52c3eee48e2e..1249165fb4b2 100644 >> --- a/drivers/dma/dmaengine.c >> +++ b/drivers/dma/dmaengine.c >> @@ -549,6 +549,42 @@ static struct dma_chan *private_candidate(const dma_cap_mask_t *mask, >> return NULL; >> } >> >> +static struct dma_chan *dma_get_channel(struct dma_device *device, > > Naming scheme inside dmaengine.c looks like a mess. Yes, I agree. > > Since it's static function that utilizes private_candidate() may I > propose the name like find_candidate() ? I had __* version as well, but the find_candidate() sounds better. Thanks, Péter -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to top | Article view | linux.kernel
csiph-web