Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1219862 > unrolled thread

[PATCH 0/3] Add initial support for slimport anx78xx

Started byEnric Balletbo i Serra <eballetbo@gmail.com>
First post2015-09-06 23:20 +0200
Last post2015-09-07 08:50 +0200
Articles 5 — 3 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH 0/3] Add initial support for slimport anx78xx Enric Balletbo i Serra <eballetbo@gmail.com> - 2015-09-06 23:20 +0200
    [PATCH 1/3] of: Add vendor prefix for Analogix Semiconductor, Inc. Enric Balletbo i Serra <eballetbo@gmail.com> - 2015-09-06 23:20 +0200
    Re: [PATCH 3/3] staging: slimport: Add anx7814 driver support by  analogix. Greg KH <gregkh@linuxfoundation.org> - 2015-09-07 01:30 +0200
      Re: [PATCH 3/3] staging: slimport: Add anx7814 driver support by analogix. Enric Balletbo Serra <eballetbo@gmail.com> - 2015-09-07 07:50 +0200
        Re: [PATCH 3/3] staging: slimport: Add anx7814 driver support by  analogix. Greg KH <gregkh@linuxfoundation.org> - 2015-09-07 08:50 +0200

#1219862 — [PATCH 0/3] Add initial support for slimport anx78xx

FromEnric Balletbo i Serra <eballetbo@gmail.com>
Date2015-09-06 23:20 +0200
Subject[PATCH 0/3] Add initial support for slimport anx78xx
Message-ID<q5PvX-23m-3@gated-at.bofh.it>
Hi all,

The following series add initial support for the Slimport ANX7814 transmitter, a
ultra-low power Full-HD (1080p60) transmitter designed for portable device.

The driver was originally created and based from the work of Junhua Xia from
Analogix. This driver is a refactor of the original driver and fixes different
coding style lines, and different errors/warnings reported by checkpatch. Also
there were thing that I notive that we need to change like:

 - Convert the numbered GPIO API to the new descriptor based GPIO API.
 - Review the DT binding
 - Add missing MODULE_DEVICE_TABLE(of, ...);
 - Fix Makefiles and Kconfig to build conditionally.
 - Use SIMPLE_DEV_PM_OPS() instead of the deprecated i2c .suspend and
  .resume callbacks.
 - Move to use managed device resources.
 - Remove dead/unused code.
 - And others ...

This is the first version so probably will have mistakes so feel free to ping to
incorporate other changes that I need to do in next series.

Best regards,

Enric Balletbo i Serra (3):
  of: Add vendor prefix for Analogix Semiconductor, Inc.
  devicetree: Add new ANX7814 SlimPort transmitter binding.
  staging: slimport: Add anx7814 driver support by analogix.

 .../devicetree/bindings/vendor-prefixes.txt        |    1 +
 .../devicetree/bindings/video/bridge/anx7814.txt   |   22 +
 drivers/staging/Kconfig                            |    2 +
 drivers/staging/Makefile                           |    1 +
 drivers/staging/slimport/Kconfig                   |    7 +
 drivers/staging/slimport/Makefile                  |    4 +
 drivers/staging/slimport/slimport.c                |  301 ++
 drivers/staging/slimport/slimport.h                |   49 +
 drivers/staging/slimport/slimport_tx_drv.c         | 3293 ++++++++++++++++++++
 drivers/staging/slimport/slimport_tx_drv.h         |  254 ++
 drivers/staging/slimport/slimport_tx_reg.h         |  786 +++++
 11 files changed, 4720 insertions(+)
 create mode 100644 Documentation/devicetree/bindings/video/bridge/anx7814.txt
 create mode 100644 drivers/staging/slimport/Kconfig
 create mode 100644 drivers/staging/slimport/Makefile
 create mode 100644 drivers/staging/slimport/slimport.c
 create mode 100644 drivers/staging/slimport/slimport.h
 create mode 100644 drivers/staging/slimport/slimport_tx_drv.c
 create mode 100644 drivers/staging/slimport/slimport_tx_drv.h
 create mode 100644 drivers/staging/slimport/slimport_tx_reg.h

-- 
2.1.0

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1219863 — [PATCH 1/3] of: Add vendor prefix for Analogix Semiconductor, Inc.

FromEnric Balletbo i Serra <eballetbo@gmail.com>
Date2015-09-06 23:20 +0200
Subject[PATCH 1/3] of: Add vendor prefix for Analogix Semiconductor, Inc.
Message-ID<q5PvY-23m-19@gated-at.bofh.it>
In reply to#1219862
Analogix Semiconductor develops analog and mixed-signal devices for digital
media and communications interconnect applications.

Signed-off-by: Enric Balletbo i Serra <enric.balletbo@collabora.com>
---
 Documentation/devicetree/bindings/vendor-prefixes.txt | 1 +
 1 file changed, 1 insertion(+)

diff --git a/Documentation/devicetree/bindings/vendor-prefixes.txt b/Documentation/devicetree/bindings/vendor-prefixes.txt
index ac5f0c3..e914a02 100644
--- a/Documentation/devicetree/bindings/vendor-prefixes.txt
+++ b/Documentation/devicetree/bindings/vendor-prefixes.txt
@@ -22,6 +22,7 @@ ampire	Ampire Co., Ltd.
 ams	AMS AG
 amstaos	AMS-Taos Inc.
 apm	Applied Micro Circuits Corporation (APM)
+analogix	Analogix Semiconductor, Inc.
 aptina	Aptina Imaging
 arasan	Arasan Chip Systems
 arm	ARM Ltd.
-- 
2.1.0

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1219872 — Re: [PATCH 3/3] staging: slimport: Add anx7814 driver support by analogix.

FromGreg KH <gregkh@linuxfoundation.org>
Date2015-09-07 01:30 +0200
SubjectRe: [PATCH 3/3] staging: slimport: Add anx7814 driver support by analogix.
Message-ID<q5RxM-4Tp-1@gated-at.bofh.it>
In reply to#1219862
On Sun, Sep 06, 2015 at 11:14:02PM +0200, Enric Balletbo i Serra wrote:
> The ANX7814 is an ultra-low power Full-HD (1080p60) SlimPort transmitter
> designed for portable devices.
> 
> This driver adds initial support and supports HDMI to DP pass-through mode.
> 
> Signed-off-by: Enric Balletbo i Serra <enric.balletbo@collabora.com>
> ---
>  drivers/staging/Kconfig                    |    2 +
>  drivers/staging/Makefile                   |    1 +
>  drivers/staging/slimport/Kconfig           |    7 +
>  drivers/staging/slimport/Makefile          |    4 +
>  drivers/staging/slimport/slimport.c        |  301 +++
>  drivers/staging/slimport/slimport.h        |   49 +
>  drivers/staging/slimport/slimport_tx_drv.c | 3293 ++++++++++++++++++++++++++++
>  drivers/staging/slimport/slimport_tx_drv.h |  254 +++
>  drivers/staging/slimport/slimport_tx_reg.h |  786 +++++++

Why is this a staging driver?
What prevents it from being merged into the "real" part of the kernel
tree?

All staging drivers need a TODO file, listing what needs to be done and
who is in charge of it.  I can't take this without that added.

thanks,

greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1219937 — Re: [PATCH 3/3] staging: slimport: Add anx7814 driver support by analogix.

FromEnric Balletbo Serra <eballetbo@gmail.com>
Date2015-09-07 07:50 +0200
SubjectRe: [PATCH 3/3] staging: slimport: Add anx7814 driver support by analogix.
Message-ID<q5Xtv-4V5-1@gated-at.bofh.it>
In reply to#1219872
2015-09-07 1:27 GMT+02:00 Greg KH <gregkh@linuxfoundation.org>:
> On Sun, Sep 06, 2015 at 11:14:02PM +0200, Enric Balletbo i Serra wrote:
>> The ANX7814 is an ultra-low power Full-HD (1080p60) SlimPort transmitter
>> designed for portable devices.
>>
>> This driver adds initial support and supports HDMI to DP pass-through mode.
>>
>> Signed-off-by: Enric Balletbo i Serra <enric.balletbo@collabora.com>
>> ---
>>  drivers/staging/Kconfig                    |    2 +
>>  drivers/staging/Makefile                   |    1 +
>>  drivers/staging/slimport/Kconfig           |    7 +
>>  drivers/staging/slimport/Makefile          |    4 +
>>  drivers/staging/slimport/slimport.c        |  301 +++
>>  drivers/staging/slimport/slimport.h        |   49 +
>>  drivers/staging/slimport/slimport_tx_drv.c | 3293 ++++++++++++++++++++++++++++
>>  drivers/staging/slimport/slimport_tx_drv.h |  254 +++
>>  drivers/staging/slimport/slimport_tx_reg.h |  786 +++++++
>
> Why is this a staging driver?
> What prevents it from being merged into the "real" part of the kernel
> tree?
>

I'll be glad to move the driver to their subsystem if you think it's a
the better place. Basically there are two reasons why I send the
driver to the staging directory. The first one is because my test
environment is a bit limited, with my environment I can only test the
HDMI to DisplayPort pass-through mode so the driver builds but it's
partially tested. The second one is that I expect I'll need to
refactor some code, specially in slimport_tx_drv.c file to be
accepted, I decided not change too much this file from the original to
not break the functionality, so I thought that will be better send
first to the staging driver to have first reviews.

> All staging drivers need a TODO file, listing what needs to be done and
> who is in charge of it.  I can't take this without that added.
>

ok, I'll add in the next series once received some feedback (or move
to the video subsystem)

Thanks,
Enric

> thanks,
>
> greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1219949 — Re: [PATCH 3/3] staging: slimport: Add anx7814 driver support by analogix.

FromGreg KH <gregkh@linuxfoundation.org>
Date2015-09-07 08:50 +0200
SubjectRe: [PATCH 3/3] staging: slimport: Add anx7814 driver support by analogix.
Message-ID<q5YpA-6fh-15@gated-at.bofh.it>
In reply to#1219937
On Mon, Sep 07, 2015 at 07:41:08AM +0200, Enric Balletbo Serra wrote:
> 2015-09-07 1:27 GMT+02:00 Greg KH <gregkh@linuxfoundation.org>:
> > On Sun, Sep 06, 2015 at 11:14:02PM +0200, Enric Balletbo i Serra wrote:
> >> The ANX7814 is an ultra-low power Full-HD (1080p60) SlimPort transmitter
> >> designed for portable devices.
> >>
> >> This driver adds initial support and supports HDMI to DP pass-through mode.
> >>
> >> Signed-off-by: Enric Balletbo i Serra <enric.balletbo@collabora.com>
> >> ---
> >>  drivers/staging/Kconfig                    |    2 +
> >>  drivers/staging/Makefile                   |    1 +
> >>  drivers/staging/slimport/Kconfig           |    7 +
> >>  drivers/staging/slimport/Makefile          |    4 +
> >>  drivers/staging/slimport/slimport.c        |  301 +++
> >>  drivers/staging/slimport/slimport.h        |   49 +
> >>  drivers/staging/slimport/slimport_tx_drv.c | 3293 ++++++++++++++++++++++++++++
> >>  drivers/staging/slimport/slimport_tx_drv.h |  254 +++
> >>  drivers/staging/slimport/slimport_tx_reg.h |  786 +++++++
> >
> > Why is this a staging driver?
> > What prevents it from being merged into the "real" part of the kernel
> > tree?
> >
> 
> I'll be glad to move the driver to their subsystem if you think it's a
> the better place. Basically there are two reasons why I send the
> driver to the staging directory. The first one is because my test
> environment is a bit limited, with my environment I can only test the
> HDMI to DisplayPort pass-through mode so the driver builds but it's
> partially tested. The second one is that I expect I'll need to
> refactor some code, specially in slimport_tx_drv.c file to be
> accepted, I decided not change too much this file from the original to
> not break the functionality, so I thought that will be better send
> first to the staging driver to have first reviews.
> 
> > All staging drivers need a TODO file, listing what needs to be done and
> > who is in charge of it.  I can't take this without that added.
> >
> 
> ok, I'll add in the next series once received some feedback (or move
> to the video subsystem)

I suggest trying to get it merged "properly" first before having to
fall-back to the staging subsystem.

thanks,

greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web