Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1211366 > unrolled thread
| Started by | David Daney <ddaney.cavm@gmail.com> |
|---|---|
| First post | 2015-08-22 01:20 +0200 |
| Last post | 2015-08-25 20:40 +0200 |
| Articles | 3 — 3 participants |
Back to article view | Back to linux.kernel
[PATCH] phylib: Make PHYs children of their MDIO bus, not the bus' parent. David Daney <ddaney.cavm@gmail.com> - 2015-08-22 01:20 +0200
Re: [PATCH] phylib: Make PHYs children of their MDIO bus, not the bus' parent. Florian Fainelli <f.fainelli@gmail.com> - 2015-08-22 02:10 +0200
Re: [PATCH] phylib: Make PHYs children of their MDIO bus, not the bus' parent. David Miller <davem@davemloft.net> - 2015-08-25 20:40 +0200
| From | David Daney <ddaney.cavm@gmail.com> |
|---|---|
| Date | 2015-08-22 01:20 +0200 |
| Subject | [PATCH] phylib: Make PHYs children of their MDIO bus, not the bus' parent. |
| Message-ID | <q03Lk-1jq-11@gated-at.bofh.it> |
From: David Daney <david.daney@cavium.com>
commit 18ee49ddb0d2 ("phylib: rename mii_bus::dev to mii_bus::parent")
changed the parent of PHY devices from the bus to the bus parent.
Then, commit 4dea547fef1b ("phylib: rework to prepare for OF
registration of PHYs") moved the code into phy_device.c
At this point, it is somewhat unclear why the change was seen as
necessary. But, when we look at the device model tree in
/sys/devices, it is clearly incorrect. The PHYs should be children of
their MDIO bus.
Change the PHY's parent device to be the MDIO bus device.
Cc: Lennert Buytenhek <buytenh@wantstofly.org>
Cc: Grant Likely <grant.likely@secretlab.ca>
Signed-off-by: David Daney <david.daney@cavium.com>
---
drivers/net/phy/phy_device.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/net/phy/phy_device.c b/drivers/net/phy/phy_device.c
index 0302483..55f0178 100644
--- a/drivers/net/phy/phy_device.c
+++ b/drivers/net/phy/phy_device.c
@@ -176,7 +176,7 @@ struct phy_device *phy_device_create(struct mii_bus *bus, int addr, int phy_id,
if (c45_ids)
dev->c45_ids = *c45_ids;
dev->bus = bus;
- dev->dev.parent = bus->parent;
+ dev->dev.parent = &bus->dev;
dev->dev.bus = &mdio_bus_type;
dev->irq = bus->irq != NULL ? bus->irq[addr] : PHY_POLL;
dev_set_name(&dev->dev, PHY_ID_FMT, bus->id, addr);
--
1.7.11.7
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [next] | [standalone]
| From | Florian Fainelli <f.fainelli@gmail.com> |
|---|---|
| Date | 2015-08-22 02:10 +0200 |
| Subject | Re: [PATCH] phylib: Make PHYs children of their MDIO bus, not the bus' parent. |
| Message-ID | <q04xH-2sO-1@gated-at.bofh.it> |
| In reply to | #1211366 |
On 21/08/15 16:16, David Daney wrote:
> From: David Daney <david.daney@cavium.com>
>
> commit 18ee49ddb0d2 ("phylib: rename mii_bus::dev to mii_bus::parent")
> changed the parent of PHY devices from the bus to the bus parent.
>
> Then, commit 4dea547fef1b ("phylib: rework to prepare for OF
> registration of PHYs") moved the code into phy_device.c
>
> At this point, it is somewhat unclear why the change was seen as
> necessary. But, when we look at the device model tree in
> /sys/devices, it is clearly incorrect. The PHYs should be children of
> their MDIO bus.
>
> Change the PHY's parent device to be the MDIO bus device.
>
> Cc: Lennert Buytenhek <buytenh@wantstofly.org>
> Cc: Grant Likely <grant.likely@secretlab.ca>
> Signed-off-by: David Daney <david.daney@cavium.com>
Acked-by: Florian Fainelli <f.fainelli@gmail.com>
--
Florian
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | David Miller <davem@davemloft.net> |
|---|---|
| Date | 2015-08-25 20:40 +0200 |
| Subject | Re: [PATCH] phylib: Make PHYs children of their MDIO bus, not the bus' parent. |
| Message-ID | <q1riy-6ju-9@gated-at.bofh.it> |
| In reply to | #1211366 |
From: David Daney <ddaney.cavm@gmail.com>
Date: Fri, 21 Aug 2015 16:16:03 -0700
> From: David Daney <david.daney@cavium.com>
>
> commit 18ee49ddb0d2 ("phylib: rename mii_bus::dev to mii_bus::parent")
> changed the parent of PHY devices from the bus to the bus parent.
>
> Then, commit 4dea547fef1b ("phylib: rework to prepare for OF
> registration of PHYs") moved the code into phy_device.c
>
> At this point, it is somewhat unclear why the change was seen as
> necessary. But, when we look at the device model tree in
> /sys/devices, it is clearly incorrect. The PHYs should be children of
> their MDIO bus.
>
> Change the PHY's parent device to be the MDIO bus device.
>
> Cc: Lennert Buytenhek <buytenh@wantstofly.org>
> Cc: Grant Likely <grant.likely@secretlab.ca>
> Signed-off-by: David Daney <david.daney@cavium.com>
Applied, thanks.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web