Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1160978 > unrolled thread

Re: [PATCH v13 5/5] cgroup: implement the PIDs subsystem

Started byTejun Heo <tj@kernel.org>
First post2015-06-09 07:00 +0200
Last post2015-06-09 07:00 +0200
Articles 1 — 1 participant

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH v13 5/5] cgroup: implement the PIDs subsystem Tejun Heo <tj@kernel.org> - 2015-06-09 07:00 +0200

#1160978 — Re: [PATCH v13 5/5] cgroup: implement the PIDs subsystem

FromTejun Heo <tj@kernel.org>
Date2015-06-09 07:00 +0200
SubjectRe: [PATCH v13 5/5] cgroup: implement the PIDs subsystem
Message-ID<pzjNL-4t5-5@gated-at.bofh.it>
Hello, Aleksa.

On Sat, Jun 06, 2015 at 10:02:18AM +1000, Aleksa Sarai wrote:
...
> +/*
> + * Lockless hierarchical accounting (with enforceable limits) derived from
> + * mm/page_counter.c. Original copyright notice from page_counter code:
> + *
> + * -------------------------------------------------
> + * Lockless hierarchical page accounting & limiting
> + * Copyright (C) 2014 Red Hat, Inc., Johannes Weiner
> + * -------------------------------------------------
> + */

I don't think we need the above copyright notice.

...
> +struct cgroup_subsys pids_cgrp_subsys = {
> +	.css_alloc	= pids_css_alloc,
> +	.css_free	= pids_css_free,
> +	.attach		= pids_attach,
> +	.can_attach 	= pids_can_attach,
> +	.cancel_attach 	= pids_cancel_attach,
> +	.can_fork	= pids_can_fork,
> +	.cancel_fork	= pids_cancel_fork,
> +	.fork		= pids_fork,
> +	.exit		= pids_exit,
> +	.legacy_cftypes	= files,

Please also init dfl_cftypes the same way too.  Also, can you please
rename files to pids_files?

> +	.early_init	= 0,

And the above can be dropped.

Other than the above minor points, everything looks good to me but I
think we're a bit too close to the merge window to put this in now.
Once you update patch 4 and 5 according to the review, I'll apply them
after the next rc1 drops.

Thanks.

-- 
tejun
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [standalone]


Back to top | Article view | linux.kernel


csiph-web