Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1160946 > unrolled thread

Re: [PATCH v2 08/13] KVM: implement multiple address spaces

Started byXiao Guangrong <guangrong.xiao@linux.intel.com>
First post2015-06-09 05:30 +0200
Last post2015-06-09 05:30 +0200
Articles 1 — 1 participant

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH v2 08/13] KVM: implement multiple address spaces Xiao Guangrong <guangrong.xiao@linux.intel.com> - 2015-06-09 05:30 +0200

#1160946 — Re: [PATCH v2 08/13] KVM: implement multiple address spaces

FromXiao Guangrong <guangrong.xiao@linux.intel.com>
Date2015-06-09 05:30 +0200
SubjectRe: [PATCH v2 08/13] KVM: implement multiple address spaces
Message-ID<pzioF-2w4-3@gated-at.bofh.it>

On 05/28/2015 01:05 AM, Paolo Bonzini wrote:

>   	/*
> @@ -772,6 +776,7 @@ int __kvm_set_memory_region(struct kvm *kvm,
>   	struct kvm_memory_slot *slot;
>   	struct kvm_memory_slot old, new;
>   	struct kvm_memslots *slots = NULL, *old_memslots;
> +	int as_id, id;
>   	enum kvm_mr_change change;
>
>   	r = check_memory_region_flags(mem);
> @@ -779,24 +784,27 @@ int __kvm_set_memory_region(struct kvm *kvm,
>   		goto out;
>
>   	r = -EINVAL;
> +	as_id = mem->slot >> 16;
> +	id = mem->slot & 65535;
> +

A minor comment, Could you put these decoding into a separate function?

Nice idea indeed.

Reviewed-by: Xiao Guangrong <guangrong.xiao@linux.intel.com>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [standalone]


Back to top | Article view | linux.kernel


csiph-web