Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1203804 > unrolled thread

[PATCH V1 Resend 00/11] vial: Drop unlikely before IS_ERR(_OR_NULL)

Started byViresh Kumar <viresh.kumar@linaro.org>
First post2015-08-10 08:20 +0200
Last post2015-08-10 08:20 +0200
Articles 4 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH V1 Resend 00/11] vial: Drop unlikely before IS_ERR(_OR_NULL) Viresh Kumar <viresh.kumar@linaro.org> - 2015-08-10 08:20 +0200
    [PATCH V1 Resend 11/11] net: Drop unlikely before IS_ERR(_OR_NULL) Viresh Kumar <viresh.kumar@linaro.org> - 2015-08-10 08:20 +0200
      Re: [PATCH V1 Resend 11/11] net: Drop unlikely before  IS_ERR(_OR_NULL) Neil Horman <nhorman@tuxdriver.com> - 2015-08-10 14:00 +0200
    [PATCH V1 Resend 09/11] blk-cgroup: Drop unlikely before IS_ERR(_OR_NULL) Viresh Kumar <viresh.kumar@linaro.org> - 2015-08-10 08:20 +0200

#1203804 — [PATCH V1 Resend 00/11] vial: Drop unlikely before IS_ERR(_OR_NULL)

FromViresh Kumar <viresh.kumar@linaro.org>
Date2015-08-10 08:20 +0200
Subject[PATCH V1 Resend 00/11] vial: Drop unlikely before IS_ERR(_OR_NULL)
Message-ID<pVOBb-5JE-7@gated-at.bofh.it>
Hi Andrew,

This cleans up the usage of IS_ERR(_OR_NULL)(), where the callers have
added additional unlikely compiler flag to them. It also fixes the
definition of IS_ERR_OR_NULL(), to use unlikely for all checks it does.

V1->V2:
- Some of the patches are already applied
- Dropped input subsystem patch as Dmitry thought its more readable
  currently.

Viresh Kumar (11):
  err.h: add (missing) unlikely() to IS_ERR_OR_NULL()
  PM / OPP: Drop unlikely before IS_ERR(_OR_NULL)
  drivers: devfreq: Drop unlikely before IS_ERR(_OR_NULL)
  drivers: md: Drop unlikely before IS_ERR(_OR_NULL)
  drivers: misc: Drop unlikely before IS_ERR(_OR_NULL)
  drivers: net: Drop unlikely before IS_ERR(_OR_NULL)
  drivers: rtc: Drop (un)likely before IS_ERR(_OR_NULL)
  fs: Drop unlikely before IS_ERR(_OR_NULL)
  blk-cgroup: Drop unlikely before IS_ERR(_OR_NULL)
  mm: Drop unlikely before IS_ERR(_OR_NULL)
  net: Drop unlikely before IS_ERR(_OR_NULL)

 drivers/base/power/opp.c                      | 6 +++---
 drivers/devfreq/devfreq.c                     | 4 ++--
 drivers/md/dm-snap-persistent.c               | 2 +-
 drivers/md/dm-verity.c                        | 2 +-
 drivers/md/persistent-data/dm-block-manager.c | 8 ++++----
 drivers/misc/c2port/core.c                    | 2 +-
 drivers/net/ethernet/ti/netcp_core.c          | 4 ++--
 drivers/rtc/interface.c                       | 2 +-
 drivers/rtc/rtc-bfin.c                        | 2 +-
 drivers/rtc/rtc-gemini.c                      | 2 +-
 fs/cifs/readdir.c                             | 2 +-
 fs/ecryptfs/inode.c                           | 2 +-
 fs/ext4/extents.c                             | 6 +++---
 fs/ext4/namei.c                               | 2 +-
 fs/namei.c                                    | 4 ++--
 fs/ncpfs/dir.c                                | 2 +-
 fs/nfs/objlayout/objio_osd.c                  | 2 +-
 fs/proc/proc_sysctl.c                         | 2 +-
 include/linux/blk-cgroup.h                    | 2 +-
 include/linux/err.h                           | 2 +-
 mm/huge_memory.c                              | 2 +-
 net/openvswitch/datapath.c                    | 2 +-
 net/sctp/socket.c                             | 2 +-
 net/socket.c                                  | 6 +++---
 24 files changed, 36 insertions(+), 36 deletions(-)

-- 
2.4.0

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1203805 — [PATCH V1 Resend 11/11] net: Drop unlikely before IS_ERR(_OR_NULL)

FromViresh Kumar <viresh.kumar@linaro.org>
Date2015-08-10 08:20 +0200
Subject[PATCH V1 Resend 11/11] net: Drop unlikely before IS_ERR(_OR_NULL)
Message-ID<pVOBd-5JE-57@gated-at.bofh.it>
In reply to#1203804
IS_ERR(_OR_NULL) already contain an 'unlikely' compiler flag and there
is no need to do that again from its callers. Drop it.

Signed-off-by: Viresh Kumar <viresh.kumar@linaro.org>
---
 net/openvswitch/datapath.c | 2 +-
 net/sctp/socket.c          | 2 +-
 net/socket.c               | 6 +++---
 3 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/net/openvswitch/datapath.c b/net/openvswitch/datapath.c
index ffe984f5b95c..a515e338cade 100644
--- a/net/openvswitch/datapath.c
+++ b/net/openvswitch/datapath.c
@@ -1143,7 +1143,7 @@ static int ovs_flow_cmd_set(struct sk_buff *skb, struct genl_info *info)
 						info, OVS_FLOW_CMD_NEW, false,
 						ufid_flags);
 
-		if (unlikely(IS_ERR(reply))) {
+		if (IS_ERR(reply)) {
 			error = PTR_ERR(reply);
 			goto err_unlock_ovs;
 		}
diff --git a/net/sctp/socket.c b/net/sctp/socket.c
index 17bef01b9aa3..897c01c029ca 100644
--- a/net/sctp/socket.c
+++ b/net/sctp/socket.c
@@ -4475,7 +4475,7 @@ static int sctp_getsockopt_peeloff(struct sock *sk, int len, char __user *optval
 	}
 
 	newfile = sock_alloc_file(newsock, 0, NULL);
-	if (unlikely(IS_ERR(newfile))) {
+	if (IS_ERR(newfile)) {
 		put_unused_fd(retval);
 		sock_release(newsock);
 		return PTR_ERR(newfile);
diff --git a/net/socket.c b/net/socket.c
index 9963a0b53a64..dd2c247c99e3 100644
--- a/net/socket.c
+++ b/net/socket.c
@@ -373,7 +373,7 @@ struct file *sock_alloc_file(struct socket *sock, int flags, const char *dname)
 
 	file = alloc_file(&path, FMODE_READ | FMODE_WRITE,
 		  &socket_file_ops);
-	if (unlikely(IS_ERR(file))) {
+	if (IS_ERR(file)) {
 		/* drop dentry, keep inode */
 		ihold(d_inode(path.dentry));
 		path_put(&path);
@@ -1303,7 +1303,7 @@ SYSCALL_DEFINE4(socketpair, int, family, int, type, int, protocol,
 	}
 
 	newfile1 = sock_alloc_file(sock1, flags, NULL);
-	if (unlikely(IS_ERR(newfile1))) {
+	if (IS_ERR(newfile1)) {
 		err = PTR_ERR(newfile1);
 		goto out_put_unused_both;
 	}
@@ -1467,7 +1467,7 @@ SYSCALL_DEFINE4(accept4, int, fd, struct sockaddr __user *, upeer_sockaddr,
 		goto out_put;
 	}
 	newfile = sock_alloc_file(newsock, flags, sock->sk->sk_prot_creator->name);
-	if (unlikely(IS_ERR(newfile))) {
+	if (IS_ERR(newfile)) {
 		err = PTR_ERR(newfile);
 		put_unused_fd(newfd);
 		sock_release(newsock);
-- 
2.4.0

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1204191 — Re: [PATCH V1 Resend 11/11] net: Drop unlikely before IS_ERR(_OR_NULL)

FromNeil Horman <nhorman@tuxdriver.com>
Date2015-08-10 14:00 +0200
SubjectRe: [PATCH V1 Resend 11/11] net: Drop unlikely before IS_ERR(_OR_NULL)
Message-ID<pVTUe-5qn-7@gated-at.bofh.it>
In reply to#1203805
Acked-by: Neil Horman <nhorman@tuxdriver.com>

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1203806 — [PATCH V1 Resend 09/11] blk-cgroup: Drop unlikely before IS_ERR(_OR_NULL)

FromViresh Kumar <viresh.kumar@linaro.org>
Date2015-08-10 08:20 +0200
Subject[PATCH V1 Resend 09/11] blk-cgroup: Drop unlikely before IS_ERR(_OR_NULL)
Message-ID<pVOBd-5JE-59@gated-at.bofh.it>
In reply to#1203804
IS_ERR(_OR_NULL) already contain an 'unlikely' compiler flag and there
is no need to do that again from its callers. Drop it.

Acked-by: Tejun Heo <tj@kernel.org>
Signed-off-by: Viresh Kumar <viresh.kumar@linaro.org>
---
 include/linux/blk-cgroup.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/include/linux/blk-cgroup.h b/include/linux/blk-cgroup.h
index 1b62d768c7df..a4cd1641e9e2 100644
--- a/include/linux/blk-cgroup.h
+++ b/include/linux/blk-cgroup.h
@@ -374,7 +374,7 @@ static inline struct request_list *blk_get_rl(struct request_queue *q,
 	 * root_rl in such cases.
 	 */
 	blkg = blkg_lookup_create(blkcg, q);
-	if (unlikely(IS_ERR(blkg)))
+	if (IS_ERR(blkg))
 		goto root_rl;
 
 	blkg_get(blkg);
-- 
2.4.0

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web