Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1201538 > unrolled thread

Re: [PATCH v8 00/21] Compile-time stack validation

Started byIngo Molnar <mingo@kernel.org>
First post2015-08-06 10:10 +0200
Last post2015-08-07 04:40 +0200
Articles 4 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH v8 00/21] Compile-time stack validation Ingo Molnar <mingo@kernel.org> - 2015-08-06 10:10 +0200
    Re: [PATCH v8 00/21] Compile-time stack validation Josh Poimboeuf <jpoimboe@redhat.com> - 2015-08-06 18:10 +0200
    Re: [PATCH v8 00/21] Compile-time stack validation Josh Poimboeuf <jpoimboe@redhat.com> - 2015-08-07 04:40 +0200
    Re: [PATCH v8 00/21] Compile-time stack validation Josh Poimboeuf <jpoimboe@redhat.com> - 2015-08-07 04:40 +0200

#1201538 — Re: [PATCH v8 00/21] Compile-time stack validation

FromIngo Molnar <mingo@kernel.org>
Date2015-08-06 10:10 +0200
SubjectRe: [PATCH v8 00/21] Compile-time stack validation
Message-ID<pUopt-2Ym-17@gated-at.bofh.it>
* Josh Poimboeuf <jpoimboe@redhat.com> wrote:

> This is v8 of the compile-time stack validation patch set, based on the
> tip/master branch.
> 
> The frame pointer macros are still called FRAME and ENDFRAME because I
> don't think we converged on anything else yet.  Otherwise I tried to
> address all the other review comments from v7.

So I think:

	FRAME_START
	FRAME_END

would be OK.

They could be added as new aliases, keeping the old ones as well, while in the new 
patches you should use this new form.

Thanks,

	Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1201880

FromJosh Poimboeuf <jpoimboe@redhat.com>
Date2015-08-06 18:10 +0200
Message-ID<pUvTY-5yr-35@gated-at.bofh.it>
In reply to#1201538
On Thu, Aug 06, 2015 at 10:07:50AM +0200, Ingo Molnar wrote:
> 
> * Josh Poimboeuf <jpoimboe@redhat.com> wrote:
> 
> > This is v8 of the compile-time stack validation patch set, based on the
> > tip/master branch.
> > 
> > The frame pointer macros are still called FRAME and ENDFRAME because I
> > don't think we converged on anything else yet.  Otherwise I tried to
> > address all the other review comments from v7.
> 
> So I think:
> 
> 	FRAME_START
> 	FRAME_END
> 
> would be OK.

Thanks, that sounds good to me.

> They could be added as new aliases, keeping the old ones as well, while in the new 
> patches you should use this new form.

Turns out nobody uses the existing FRAME/ENDFRAME macros, so I'll just
rename them.

-- 
Josh
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1202253

FromJosh Poimboeuf <jpoimboe@redhat.com>
Date2015-08-07 04:40 +0200
Message-ID<pUFJD-2Ja-7@gated-at.bofh.it>
In reply to#1201538
On Thu, Aug 06, 2015 at 12:23:32PM -0500, Josh Poimboeuf wrote:
> On Thu, Aug 06, 2015 at 10:07:50AM +0200, Ingo Molnar wrote:
> > 
> > * Josh Poimboeuf <jpoimboe@redhat.com> wrote:
> > 
> > > This is v8 of the compile-time stack validation patch set, based on the
> > > tip/master branch.
> > > 
> > > The frame pointer macros are still called FRAME and ENDFRAME because I
> > > don't think we converged on anything else yet.  Otherwise I tried to
> > > address all the other review comments from v7.
> > 
> > So I think:
> > 
> > 	FRAME_START
> > 	FRAME_END
> 
> (One last tweak to the bikeshed)
> 
> The antonym of END is BEGIN.  So how about:
> 
>   FRAME_BEGIN
>   FRAME_END

Ok, so thesaurus.com reminds me that words can have more than one
antonym, and that START and BEGIN are both antonyms of END.

Personally, when I START something I usually FINISH it or even STOP it.

So I'll stop the bikeshedding I started and go with BEGIN/END.

-- 
Josh
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1202254

FromJosh Poimboeuf <jpoimboe@redhat.com>
Date2015-08-07 04:40 +0200
Message-ID<pUFJD-2Ja-9@gated-at.bofh.it>
In reply to#1201538
On Thu, Aug 06, 2015 at 10:07:50AM +0200, Ingo Molnar wrote:
> 
> * Josh Poimboeuf <jpoimboe@redhat.com> wrote:
> 
> > This is v8 of the compile-time stack validation patch set, based on the
> > tip/master branch.
> > 
> > The frame pointer macros are still called FRAME and ENDFRAME because I
> > don't think we converged on anything else yet.  Otherwise I tried to
> > address all the other review comments from v7.
> 
> So I think:
> 
> 	FRAME_START
> 	FRAME_END

(One last tweak to the bikeshed)

The antonym of END is BEGIN.  So how about:

  FRAME_BEGIN
  FRAME_END


-- 
Josh
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web