Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1200674 > unrolled thread

[PATCH v6 4/8] usb: gadget: move find_ep() from epautoconf to gadget.h

Started byRobert Baldyga <r.baldyga@samsung.com>
First post2015-08-05 14:10 +0200
Last post2015-08-05 20:00 +0200
Articles 3 — 3 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  [PATCH v6 4/8] usb: gadget: move find_ep() from epautoconf to gadget.h Robert Baldyga <r.baldyga@samsung.com> - 2015-08-05 14:10 +0200
    Re: [PATCH v6 4/8] usb: gadget: move find_ep() from epautoconf to  gadget.h Alan Stern <stern@rowland.harvard.edu> - 2015-08-05 16:40 +0200
      Re: [PATCH v6 4/8] usb: gadget: move find_ep() from epautoconf to  gadget.h Felipe Balbi <balbi@ti.com> - 2015-08-05 20:00 +0200

#1200674 — [PATCH v6 4/8] usb: gadget: move find_ep() from epautoconf to gadget.h

FromRobert Baldyga <r.baldyga@samsung.com>
Date2015-08-05 14:10 +0200
Subject[PATCH v6 4/8] usb: gadget: move find_ep() from epautoconf to gadget.h
Message-ID<pU5G9-P2-21@gated-at.bofh.it>
Move find_ep() function to gadget.h, rename it to gadget_find_ep_by_name()
and make it static inline. It can be used in UDC drivers, especially in
'match_ep' callback after moving chip-specific endpoint matching logic from
epautoconf to UDC drivers.

Replace all calls of find_ep() function with gadget_find_ep_by_name().

Signed-off-by: Robert Baldyga <r.baldyga@samsung.com>
---
 drivers/usb/gadget/epautoconf.c | 30 +++++++++---------------------
 include/linux/usb/gadget.h      | 18 ++++++++++++++++++
 2 files changed, 27 insertions(+), 21 deletions(-)

diff --git a/drivers/usb/gadget/epautoconf.c b/drivers/usb/gadget/epautoconf.c
index d49af4f..a39ca03 100644
--- a/drivers/usb/gadget/epautoconf.c
+++ b/drivers/usb/gadget/epautoconf.c
@@ -22,18 +22,6 @@
 
 #include "gadget_chips.h"
 
-static struct usb_ep *
-find_ep (struct usb_gadget *gadget, const char *name)
-{
-	struct usb_ep	*ep;
-
-	list_for_each_entry (ep, &gadget->ep_list, ep_list) {
-		if (0 == strcmp (ep->name, name))
-			return ep;
-	}
-	return NULL;
-}
-
 /**
  * usb_ep_autoconfig_ss() - choose an endpoint matching the ep
  * descriptor and ep companion descriptor
@@ -103,11 +91,11 @@ struct usb_ep *usb_ep_autoconfig_ss(
 
 		if (type == USB_ENDPOINT_XFER_INT) {
 			/* ep-e, ep-f are PIO with only 64 byte fifos */
-			ep = find_ep(gadget, "ep-e");
+			ep = gadget_find_ep_by_name(gadget, "ep-e");
 			if (ep && usb_gadget_ep_match_desc(gadget,
 					ep, desc, ep_comp))
 				goto found_ep;
-			ep = find_ep(gadget, "ep-f");
+			ep = gadget_find_ep_by_name(gadget, "ep-f");
 			if (ep && usb_gadget_ep_match_desc(gadget,
 					ep, desc, ep_comp))
 				goto found_ep;
@@ -116,20 +104,20 @@ struct usb_ep *usb_ep_autoconfig_ss(
 		/* USB3380: use same address for usb and hardware endpoints */
 		snprintf(name, sizeof(name), "ep%d%s", usb_endpoint_num(desc),
 				usb_endpoint_dir_in(desc) ? "in" : "out");
-		ep = find_ep(gadget, name);
+		ep = gadget_find_ep_by_name(gadget, name);
 		if (ep && usb_gadget_ep_match_desc(gadget, ep, desc, ep_comp))
 			goto found_ep;
 	} else if (gadget_is_goku (gadget)) {
 		if (USB_ENDPOINT_XFER_INT == type) {
 			/* single buffering is enough */
-			ep = find_ep(gadget, "ep3-bulk");
+			ep = gadget_find_ep_by_name(gadget, "ep3-bulk");
 			if (ep && usb_gadget_ep_match_desc(gadget,
 					ep, desc, ep_comp))
 				goto found_ep;
 		} else if (USB_ENDPOINT_XFER_BULK == type
 				&& (USB_DIR_IN & desc->bEndpointAddress)) {
 			/* DMA may be available */
-			ep = find_ep(gadget, "ep2-bulk");
+			ep = gadget_find_ep_by_name(gadget, "ep2-bulk");
 			if (ep && usb_gadget_ep_match_desc(gadget,
 					ep, desc, ep_comp))
 				goto found_ep;
@@ -140,14 +128,14 @@ struct usb_ep *usb_ep_autoconfig_ss(
 		if ((USB_ENDPOINT_XFER_BULK == type) ||
 		    (USB_ENDPOINT_XFER_ISOC == type)) {
 			if (USB_DIR_IN & desc->bEndpointAddress)
-				ep = find_ep (gadget, "ep5in");
+				ep = gadget_find_ep_by_name(gadget, "ep5in");
 			else
-				ep = find_ep (gadget, "ep6out");
+				ep = gadget_find_ep_by_name(gadget, "ep6out");
 		} else if (USB_ENDPOINT_XFER_INT == type) {
 			if (USB_DIR_IN & desc->bEndpointAddress)
-				ep = find_ep(gadget, "ep1in");
+				ep = gadget_find_ep_by_name(gadget, "ep1in");
 			else
-				ep = find_ep(gadget, "ep2out");
+				ep = gadget_find_ep_by_name(gadget, "ep2out");
 		} else
 			ep = NULL;
 		if (ep && usb_gadget_ep_match_desc(gadget, ep, desc, ep_comp))
diff --git a/include/linux/usb/gadget.h b/include/linux/usb/gadget.h
index e04fd63..6a413ab 100644
--- a/include/linux/usb/gadget.h
+++ b/include/linux/usb/gadget.h
@@ -639,6 +639,24 @@ static inline struct usb_gadget *dev_to_usb_gadget(struct device *dev)
 #define gadget_for_each_ep(tmp, gadget) \
 	list_for_each_entry(tmp, &(gadget)->ep_list, ep_list)
 
+/**
+ * gadget_find_ep_by_name - returns ep whose name is the same as sting passed
+ *	in second parameter or NULL if searched endpoint not found
+ * @g: controller to check for quirk
+ * @name: name of searched endpoint
+ */
+static inline struct usb_ep *
+gadget_find_ep_by_name(struct usb_gadget *g, const char *name)
+{
+	struct usb_ep *ep;
+
+	gadget_for_each_ep(ep, g) {
+		if (!strcmp(ep->name, name))
+			return ep;
+	}
+
+	return NULL;
+}
 
 /**
  * usb_ep_align_maybe - returns @len aligned to ep's maxpacketsize if gadget
-- 
1.9.1

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1200830 — Re: [PATCH v6 4/8] usb: gadget: move find_ep() from epautoconf to gadget.h

FromAlan Stern <stern@rowland.harvard.edu>
Date2015-08-05 16:40 +0200
SubjectRe: [PATCH v6 4/8] usb: gadget: move find_ep() from epautoconf to gadget.h
Message-ID<pU81k-483-13@gated-at.bofh.it>
In reply to#1200674
On Wed, 5 Aug 2015, Robert Baldyga wrote:

> Move find_ep() function to gadget.h, rename it to gadget_find_ep_by_name()
> and make it static inline. It can be used in UDC drivers, especially in
> 'match_ep' callback after moving chip-specific endpoint matching logic from
> epautoconf to UDC drivers.

> --- a/include/linux/usb/gadget.h
> +++ b/include/linux/usb/gadget.h
> @@ -639,6 +639,24 @@ static inline struct usb_gadget *dev_to_usb_gadget(struct device *dev)
>  #define gadget_for_each_ep(tmp, gadget) \
>  	list_for_each_entry(tmp, &(gadget)->ep_list, ep_list)
>  
> +/**
> + * gadget_find_ep_by_name - returns ep whose name is the same as sting passed
> + *	in second parameter or NULL if searched endpoint not found
> + * @g: controller to check for quirk
> + * @name: name of searched endpoint
> + */
> +static inline struct usb_ep *
> +gadget_find_ep_by_name(struct usb_gadget *g, const char *name)
> +{
> +	struct usb_ep *ep;
> +
> +	gadget_for_each_ep(ep, g) {
> +		if (!strcmp(ep->name, name))
> +			return ep;
> +	}
> +
> +	return NULL;
> +}

Minor point: Is this function short enough to be worth inlining?  My 
general feeling has been that anything containing a nontrivial loop 
probably shouldn't be inlined, but I could be wrong.

Alan Stern

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1201029 — Re: [PATCH v6 4/8] usb: gadget: move find_ep() from epautoconf to gadget.h

FromFelipe Balbi <balbi@ti.com>
Date2015-08-05 20:00 +0200
SubjectRe: [PATCH v6 4/8] usb: gadget: move find_ep() from epautoconf to gadget.h
Message-ID<pUb8S-7b-5@gated-at.bofh.it>
In reply to#1200830

[Multipart message — attachments visible in raw view] — view raw

On Wed, Aug 05, 2015 at 10:30:54AM -0400, Alan Stern wrote:
> On Wed, 5 Aug 2015, Robert Baldyga wrote:
> 
> > Move find_ep() function to gadget.h, rename it to gadget_find_ep_by_name()
> > and make it static inline. It can be used in UDC drivers, especially in
> > 'match_ep' callback after moving chip-specific endpoint matching logic from
> > epautoconf to UDC drivers.
> 
> > --- a/include/linux/usb/gadget.h
> > +++ b/include/linux/usb/gadget.h
> > @@ -639,6 +639,24 @@ static inline struct usb_gadget *dev_to_usb_gadget(struct device *dev)
> >  #define gadget_for_each_ep(tmp, gadget) \
> >  	list_for_each_entry(tmp, &(gadget)->ep_list, ep_list)
> >  
> > +/**
> > + * gadget_find_ep_by_name - returns ep whose name is the same as sting passed
> > + *	in second parameter or NULL if searched endpoint not found
> > + * @g: controller to check for quirk
> > + * @name: name of searched endpoint
> > + */
> > +static inline struct usb_ep *
> > +gadget_find_ep_by_name(struct usb_gadget *g, const char *name)
> > +{
> > +	struct usb_ep *ep;
> > +
> > +	gadget_for_each_ep(ep, g) {
> > +		if (!strcmp(ep->name, name))
> > +			return ep;
> > +	}
> > +
> > +	return NULL;
> > +}
> 
> Minor point: Is this function short enough to be worth inlining?  My 
> general feeling has been that anything containing a nontrivial loop 
> probably shouldn't be inlined, but I could be wrong.

makes sense. Looks like moving it to udc-core.c and making it
EXPORT_SYMBOL_GPL() would be the way to go ?

-- 
balbi

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web