Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1197088 > unrolled thread
| Started by | Ludovic Desroches <ludovic.desroches@atmel.com> |
|---|---|
| First post | 2015-07-31 17:10 +0200 |
| Last post | 2015-08-10 09:00 +0200 |
| Articles | 5 — 3 participants |
Back to article view | Back to linux.kernel
[RFC PATCH 0/3] New Atmel PIO4 pinctrl/gpio driver Ludovic Desroches <ludovic.desroches@atmel.com> - 2015-07-31 17:10 +0200
Re: [RFC PATCH 2/3] ARM: at91/dt: add sama5d2 pinmux Josh Wu <josh.wu@atmel.com> - 2015-08-03 08:50 +0200
Re: [RFC PATCH 2/3] ARM: at91/dt: add sama5d2 pinmux Ludovic Desroches <ludovic.desroches@atmel.com> - 2015-08-03 09:00 +0200
Re: [RFC PATCH 0/3] New Atmel PIO4 pinctrl/gpio driver Sascha Hauer <s.hauer@pengutronix.de> - 2015-08-05 09:40 +0200
Re: [RFC PATCH 0/3] New Atmel PIO4 pinctrl/gpio driver Ludovic Desroches <ludovic.desroches@atmel.com> - 2015-08-10 09:00 +0200
| From | Ludovic Desroches <ludovic.desroches@atmel.com> |
|---|---|
| Date | 2015-07-31 17:10 +0200 |
| Subject | [RFC PATCH 0/3] New Atmel PIO4 pinctrl/gpio driver |
| Message-ID | <pSk6B-Yx-5@gated-at.bofh.it> |
Hi, Following our discussion, I send an RFC version of my driver. RFC because it is not totally achieved, some cleanup and feature addition is needed. At least, we could discuss about the 'core' part. I have used the pinmux property as Mediatek driver. Patch 3 is the internal dt files we are using. Thanks for your reviews. Ludovic Desroches (3): pinctrl: introduce driver for Atmel PIO4 controller ARM: at91/dt: add sama5d2 pinmux ARM: at91/dt: add pinctrl arch/arm/boot/dts/at91-sama5d2_xplained.dts | 386 ++++++++++ arch/arm/boot/dts/sama5d2-pinfunc.h | 760 +++++++++++++++++++ arch/arm/boot/dts/sama5d2.dtsi | 1076 +++++++++++++++++++++++++++ drivers/pinctrl/pinctrl-at91-pio4.c | 959 ++++++++++++++++++++++++ 4 files changed, 3181 insertions(+) create mode 100644 arch/arm/boot/dts/at91-sama5d2_xplained.dts create mode 100644 arch/arm/boot/dts/sama5d2-pinfunc.h create mode 100644 arch/arm/boot/dts/sama5d2.dtsi create mode 100644 drivers/pinctrl/pinctrl-at91-pio4.c -- 2.5.0 -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [next] | [standalone]
| From | Josh Wu <josh.wu@atmel.com> |
|---|---|
| Date | 2015-08-03 08:50 +0200 |
| Subject | Re: [RFC PATCH 2/3] ARM: at91/dt: add sama5d2 pinmux |
| Message-ID | <pThJn-3tB-3@gated-at.bofh.it> |
| In reply to | #1197088 |
Hi, Ludovic On 7/31/2015 11:08 PM, Ludovic Desroches wrote: > Signed-off-by: Ludovic Desroches <ludovic.desroches@atmel.com> > --- > arch/arm/boot/dts/sama5d2-pinfunc.h | 760 ++++++++++++++++++++++++++++++++++++ > 1 file changed, 760 insertions(+) > create mode 100644 arch/arm/boot/dts/sama5d2-pinfunc.h > > diff --git a/arch/arm/boot/dts/sama5d2-pinfunc.h b/arch/arm/boot/dts/sama5d2-pinfunc.h > new file mode 100644 > index 0000000..046d1d5 > --- /dev/null > +++ b/arch/arm/boot/dts/sama5d2-pinfunc.h > [snip...] > +#define PIN_PB24__FLEXCOM3_IO3 PINMUX_PIN(PIN_PB24, 5, 3) > +#define PIN_PB24__ISI_D10 PINMUX_PIN(PIN_PB24, 6, 3) As sama5d2 use ISC, so It's better to run s/ISI_/ISC_/ in this file, which is consistent with the datasheet. Best Regards, Josh Wu -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Ludovic Desroches <ludovic.desroches@atmel.com> |
|---|---|
| Date | 2015-08-03 09:00 +0200 |
| Subject | Re: [RFC PATCH 2/3] ARM: at91/dt: add sama5d2 pinmux |
| Message-ID | <pThT3-3J1-1@gated-at.bofh.it> |
| In reply to | #1198576 |
Hi Josh, On Mon, Aug 03, 2015 at 02:40:18PM +0800, Josh Wu wrote: > Hi, Ludovic > > On 7/31/2015 11:08 PM, Ludovic Desroches wrote: > >Signed-off-by: Ludovic Desroches <ludovic.desroches@atmel.com> > >--- > > arch/arm/boot/dts/sama5d2-pinfunc.h | 760 ++++++++++++++++++++++++++++++++++++ > > 1 file changed, 760 insertions(+) > > create mode 100644 arch/arm/boot/dts/sama5d2-pinfunc.h > > > >diff --git a/arch/arm/boot/dts/sama5d2-pinfunc.h b/arch/arm/boot/dts/sama5d2-pinfunc.h > >new file mode 100644 > >index 0000000..046d1d5 > >--- /dev/null > >+++ b/arch/arm/boot/dts/sama5d2-pinfunc.h > > > > [snip...] > > >+#define PIN_PB24__FLEXCOM3_IO3 PINMUX_PIN(PIN_PB24, 5, 3) > >+#define PIN_PB24__ISI_D10 PINMUX_PIN(PIN_PB24, 6, 3) > > As sama5d2 use ISC, so It's better to run s/ISI_/ISC_/ in this file, which > is consistent with the datasheet. > Ok, the one I used was a bit older and was still with ISI instead of ISC. I'll update this file. Regards Ludovic -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Sascha Hauer <s.hauer@pengutronix.de> |
|---|---|
| Date | 2015-08-05 09:40 +0200 |
| Message-ID | <pU1sR-32s-3@gated-at.bofh.it> |
| In reply to | #1197088 |
On Fri, Jul 31, 2015 at 05:08:07PM +0200, Ludovic Desroches wrote: > Hi, > > Following our discussion, I send an RFC version of my driver. RFC because it is > not totally achieved, some cleanup and feature addition is needed. > > At least, we could discuss about the 'core' part. I have used the pinmux > property as Mediatek driver. Patch 3 is the internal dt files we are using. As you can imagine I am fine with the binding, so I can add my acked-by once you send a non-RFC version. The only thing I never understood is what's so special about GPIOs that they have to bypass the pinctrl framework and instead a gpio_request magically translates a gpio into a pin. Wouldn't it make sense to at least add the pins in their GPIO mode to arch/arm/boot/dts/sama5d2-pinfunc.h? Sascha -- Pengutronix e.K. | | Industrial Linux Solutions | http://www.pengutronix.de/ | Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0 | Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 | -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Ludovic Desroches <ludovic.desroches@atmel.com> |
|---|---|
| Date | 2015-08-10 09:00 +0200 |
| Message-ID | <pVPdU-6C4-13@gated-at.bofh.it> |
| In reply to | #1200483 |
Hi Sascha, On Wed, Aug 05, 2015 at 09:31:17AM +0200, Sascha Hauer wrote: > On Fri, Jul 31, 2015 at 05:08:07PM +0200, Ludovic Desroches wrote: > > Hi, > > > > Following our discussion, I send an RFC version of my driver. RFC because it is > > not totally achieved, some cleanup and feature addition is needed. > > > > At least, we could discuss about the 'core' part. I have used the pinmux > > property as Mediatek driver. Patch 3 is the internal dt files we are using. > > As you can imagine I am fine with the binding, so I can add my acked-by > once you send a non-RFC version. > Great, I'm glad to hear that. > The only thing I never understood is what's so special about GPIOs that > they have to bypass the pinctrl framework and instead a gpio_request > magically translates a gpio into a pin. Not sure to really understand your concern here... Do you mean I could get rid of gpio_request_enable()? > Wouldn't it make sense to at > least add the pins in their GPIO mode to > arch/arm/boot/dts/sama5d2-pinfunc.h? It is done, PIN_PA0 could be used for this purpose. Regards Ludovic -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web