Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1186490 > unrolled thread

[PATCH v2 2/4] mfd: max77686: Use a generic name for the PMIC node in the example

Started byJavier Martinez Canillas <javier@osg.samsung.com>
First post2015-07-17 08:40 +0200
Last post2015-07-17 11:20 +0200
Articles 3 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  [PATCH v2 2/4] mfd: max77686: Use a generic name for the PMIC node in the example Javier Martinez Canillas <javier@osg.samsung.com> - 2015-07-17 08:40 +0200
    Re: [PATCH v2 2/4] mfd: max77686: Use a generic name for the PMIC  node in the example Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-07-17 11:20 +0200
      Re: [PATCH v2 2/4] mfd: max77686: Use a generic name for the PMIC  node in the example Javier Martinez Canillas <javier@osg.samsung.com> - 2015-07-17 11:20 +0200

#1186490 — [PATCH v2 2/4] mfd: max77686: Use a generic name for the PMIC node in the example

FromJavier Martinez Canillas <javier@osg.samsung.com>
Date2015-07-17 08:40 +0200
Subject[PATCH v2 2/4] mfd: max77686: Use a generic name for the PMIC node in the example
Message-ID<pN7tn-5UK-11@gated-at.bofh.it>
The ePAR standard says that: "the name of a node should be somewhat
generic, reflecting the function of the device and not its precise
programming model."

So, change the max77686 binding document example to use a generic
node name instead of using the chip's name.

Suggested-by: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>
Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>
---

Changes in v2: None

 Documentation/devicetree/bindings/mfd/max77686.txt | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/Documentation/devicetree/bindings/mfd/max77686.txt b/Documentation/devicetree/bindings/mfd/max77686.txt
index 8221102d3fc2..d2ed3c20a5c3 100644
--- a/Documentation/devicetree/bindings/mfd/max77686.txt
+++ b/Documentation/devicetree/bindings/mfd/max77686.txt
@@ -48,7 +48,7 @@ to get matched with their hardware counterparts as follow:
 
 Example:
 
-	max77686@09 {
+	max77686: pmic@09 {
 		compatible = "maxim,max77686";
 		interrupt-parent = <&wakeup_eint>;
 		interrupts = <26 0>;
-- 
2.4.3

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1186621 — Re: [PATCH v2 2/4] mfd: max77686: Use a generic name for the PMIC node in the example

FromSergei Shtylyov <sergei.shtylyov@cogentembedded.com>
Date2015-07-17 11:20 +0200
SubjectRe: [PATCH v2 2/4] mfd: max77686: Use a generic name for the PMIC node in the example
Message-ID<pN9Yd-18j-1@gated-at.bofh.it>
In reply to#1186490
Hello.

On 7/17/2015 9:29 AM, Javier Martinez Canillas wrote:

> The ePAR standard says that: "the name of a node should be somewhat

    ePAPR.

> generic, reflecting the function of the device and not its precise
> programming model."

> So, change the max77686 binding document example to use a generic
> node name instead of using the chip's name.

> Suggested-by: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>
> Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>

MBR, Sergei

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1186626 — Re: [PATCH v2 2/4] mfd: max77686: Use a generic name for the PMIC node in the example

FromJavier Martinez Canillas <javier@osg.samsung.com>
Date2015-07-17 11:20 +0200
SubjectRe: [PATCH v2 2/4] mfd: max77686: Use a generic name for the PMIC node in the example
Message-ID<pN9Yd-18j-13@gated-at.bofh.it>
In reply to#1186621
Hello Sergei,

On 07/17/2015 11:11 AM, Sergei Shtylyov wrote:
> Hello.
> 
> On 7/17/2015 9:29 AM, Javier Martinez Canillas wrote:
> 
>> The ePAR standard says that: "the name of a node should be somewhat
> 
>    ePAPR.
>

Thanks for pointing it out. I guess that Lee can fix the typo when applying?

>> generic, reflecting the function of the device and not its precise
>> programming model."
> 
>> So, change the max77686 binding document example to use a generic
>> node name instead of using the chip's name.
> 
>> Suggested-by: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>
>> Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>
> 
> MBR, Sergei
> 

Best regards,
-- 
Javier Martinez Canillas
Open Source Group
Samsung Research America
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web