Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1183976 > unrolled thread

[PATCH v2 00/23] staging: rtl8192e: Various cleanups

Started byMateusz Kulikowski <mateusz.kulikowski@gmail.com>
First post2015-07-14 22:20 +0200
Last post2015-07-15 09:10 +0200
Articles 4 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH v2 00/23] staging: rtl8192e: Various cleanups Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-14 22:20 +0200
    [PATCH v2 04/23] staging: rtl8192e: Remove unused enums Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-14 22:20 +0200
      Re: [PATCH v2 04/23] staging: rtl8192e: Remove unused enums Jakub Sitnicki <jsitnicki@gmail.com> - 2015-07-15 09:00 +0200
        Re: [PATCH v2 04/23] staging: rtl8192e: Remove unused enums Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-15 09:10 +0200

#1183976 — [PATCH v2 00/23] staging: rtl8192e: Various cleanups

FromMateusz Kulikowski <mateusz.kulikowski@gmail.com>
Date2015-07-14 22:20 +0200
Subject[PATCH v2 00/23] staging: rtl8192e: Various cleanups
Message-ID<pMeGB-2db-3@gated-at.bofh.it>
This series does some more cleanup for driver.

Changes in V2:
- Added patch 6/23 (Remove rtllib_stats structure as suggested by Dan)
- Updated patch 22/23 (remove whitespace - hint by Sudip)
- Rebased into current staging next (6fdb302c)
- Retested

Notes from V1:

Patches 1-13 just remove features that are not used.
Remaining patches make some functions static (where possible); 

If making function static required something more than moving 
fw declaration and removing it from header - it is a separate patch.
Otherwise - statification is done on per-file basis.

Series was target-tested (802.11N/2.4G/WPA2 network, DHCP, 
1MB download, ping).

Mateusz Kulikowski (23):
  staging: rtl8192e: Remove ToLegalChannel()
  staging: rtl8192e: Remove unused defines
  staging: rtl8192e: Remove undefs
  staging: rtl8192e: Remove unused enums
  staging: rtl8192e: Remove unused fields from rtllib_stats
  staging: rtl8192e: Remove rtllib_stats structure
  staging: rtl8192e: Remove unused ether_header structure
  staging: rtl8192e: Remove unused rtllib_device::freq_band
  staging: rtl8192e: Remove DOT11D_GetMaxTxPwrInDbm()
  staging: rtl8192e: Remove read|write_nic_io_(d)word|byte()
  staging: rtl8192e: Remove DMESG macro
  staging: rtl8192e: Remove rtl819x_process_cck_rxpathsel()
  staging: rtl8192e: probe: Remove bdma64 check
  staging: rtl8192e: Remove rtl8192_rx_cmd()
  staging: rtl8192e: rtl_dm: Make functions static
  staging: rtl8192e: rtllib_HTProc: Make functions static
  staging: rtl8192e: Make phy_RF8256_Config_ParaFile() static
  staging: rtl8192e: rtl_core: Make functions static
  staging: rtl8192e: r8192e_phy: Make functions static
  staging: rtl8192e: Make rtl8192_QueryIsShort() static
  staging: rtl8192e: rtllib_tx: Make functions static
  staging: rtl8192e: Make rtllib_rx_mgt() static
  staging: rtl8192e: rtllib_softmac: Make functions static

 drivers/staging/rtl8192e/dot11d.c                  |  39 ---
 drivers/staging/rtl8192e/dot11d.h                  |   6 -
 drivers/staging/rtl8192e/rtl8192e/r8190P_def.h     |  46 ----
 drivers/staging/rtl8192e/rtl8192e/r8190P_rtl8256.c |  18 +-
 drivers/staging/rtl8192e/rtl8192e/r8190P_rtl8256.h |   1 -
 drivers/staging/rtl8192e/rtl8192e/r8192E_dev.c     |  27 +--
 drivers/staging/rtl8192e/rtl8192e/r8192E_dev.h     |   1 -
 .../staging/rtl8192e/rtl8192e/r8192E_firmware.h    |   2 -
 drivers/staging/rtl8192e/rtl8192e/r8192E_phy.c     |   6 +-
 drivers/staging/rtl8192e/rtl8192e/r8192E_phy.h     |   3 -
 drivers/staging/rtl8192e/rtl8192e/rtl_core.c       | 261 +++------------------
 drivers/staging/rtl8192e/rtl8192e/rtl_core.h       |  33 ---
 drivers/staging/rtl8192e/rtl8192e/rtl_dm.c         |  12 +-
 drivers/staging/rtl8192e/rtl8192e/rtl_dm.h         |  22 --
 drivers/staging/rtl8192e/rtl8192e/rtl_ps.h         |   1 -
 drivers/staging/rtl8192e/rtl8192e/rtl_wx.c         |   7 -
 drivers/staging/rtl8192e/rtl819x_BA.h              |   5 -
 drivers/staging/rtl8192e/rtl819x_HT.h              |   2 -
 drivers/staging/rtl8192e/rtl819x_HTProc.c          |   5 +-
 drivers/staging/rtl8192e/rtl819x_Qos.h             |   5 -
 drivers/staging/rtl8192e/rtl819x_TS.h              |   2 -
 drivers/staging/rtl8192e/rtllib.h                  |  92 --------
 drivers/staging/rtl8192e/rtllib_debug.h            |   8 -
 drivers/staging/rtl8192e/rtllib_rx.c               |  11 +-
 drivers/staging/rtl8192e/rtllib_softmac.c          |  28 ++-
 drivers/staging/rtl8192e/rtllib_tx.c               |   9 +-
 26 files changed, 97 insertions(+), 555 deletions(-)

-- 
1.8.4.1

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1183977 — [PATCH v2 04/23] staging: rtl8192e: Remove unused enums

FromMateusz Kulikowski <mateusz.kulikowski@gmail.com>
Date2015-07-14 22:20 +0200
Subject[PATCH v2 04/23] staging: rtl8192e: Remove unused enums
Message-ID<pMeQh-2oq-11@gated-at.bofh.it>
In reply to#1183976
Remove ack_policy enum and some unused RTL_DEBUG enums.

Signed-off-by: Mateusz Kulikowski <mateusz.kulikowski@gmail.com>
---
 drivers/staging/rtl8192e/rtl819x_Qos.h  | 5 -----
 drivers/staging/rtl8192e/rtllib_debug.h | 6 ------
 2 files changed, 11 deletions(-)

diff --git a/drivers/staging/rtl8192e/rtl819x_Qos.h b/drivers/staging/rtl8192e/rtl819x_Qos.h
index 3aa35ce..fcc8fab 100644
--- a/drivers/staging/rtl8192e/rtl819x_Qos.h
+++ b/drivers/staging/rtl8192e/rtl819x_Qos.h
@@ -96,11 +96,6 @@ struct octet_string {
 	u16 Length;
 };
 
-enum ack_policy {
-	eAckPlc0_ACK		= 0x00,
-	eAckPlc1_NoACK		= 0x01,
-};
-
 #define AC0_BE	0
 #define AC1_BK	1
 #define AC2_VI	2
diff --git a/drivers/staging/rtl8192e/rtllib_debug.h b/drivers/staging/rtl8192e/rtllib_debug.h
index 42e88d6..2f47a7c 100644
--- a/drivers/staging/rtl8192e/rtllib_debug.h
+++ b/drivers/staging/rtl8192e/rtllib_debug.h
@@ -40,10 +40,7 @@ enum RTL_DEBUG {
 	COMP_DBG		= (1 << 1),
 	COMP_INIT		= (1 << 2),
 	COMP_RECV		= (1 << 3),
-	COMP_SEND		= (1 << 4),
-	COMP_CMD		= (1 << 5),
 	COMP_POWER		= (1 << 6),
-	COMP_EPROM		= (1 << 7),
 	COMP_SWBW		= (1 << 8),
 	COMP_SEC		= (1 << 9),
 	COMP_LPS		= (1 << 10),
@@ -58,15 +55,12 @@ enum RTL_DEBUG {
 	COMP_CH			= (1 << 19),
 	COMP_RF			= (1 << 20),
 	COMP_FIRMWARE		= (1 << 21),
-	COMP_HT			= (1 << 22),
 	COMP_RESET		= (1 << 23),
 	COMP_CMDPKT		= (1 << 24),
 	COMP_SCAN		= (1 << 25),
 	COMP_PS			= (1 << 26),
 	COMP_DOWN		= (1 << 27),
 	COMP_INTR		= (1 << 28),
-	COMP_LED		= (1 << 29),
-	COMP_MLME		= (1 << 30),
 	COMP_ERR		= (1 << 31)
 };
 
-- 
1.8.4.1

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1184369 — Re: [PATCH v2 04/23] staging: rtl8192e: Remove unused enums

FromJakub Sitnicki <jsitnicki@gmail.com>
Date2015-07-15 09:00 +0200
SubjectRe: [PATCH v2 04/23] staging: rtl8192e: Remove unused enums
Message-ID<pMoPD-8eQ-5@gated-at.bofh.it>
In reply to#1183977
On Tue, Jul 14, 2015 at 10:04 PM CEST, Mateusz Kulikowski <mateusz.kulikowski@gmail.com> wrote:
> Remove ack_policy enum and some unused RTL_DEBUG enums.
>
> Signed-off-by: Mateusz Kulikowski <mateusz.kulikowski@gmail.com>
> ---

[snip]

> diff --git a/drivers/staging/rtl8192e/rtllib_debug.h b/drivers/staging/rtl8192e/rtllib_debug.h
> index 42e88d6..2f47a7c 100644
> --- a/drivers/staging/rtl8192e/rtllib_debug.h
> +++ b/drivers/staging/rtl8192e/rtllib_debug.h
> @@ -40,10 +40,7 @@ enum RTL_DEBUG {
>  	COMP_DBG		= (1 << 1),
>  	COMP_INIT		= (1 << 2),
>  	COMP_RECV		= (1 << 3),
> -	COMP_SEND		= (1 << 4),
> -	COMP_CMD		= (1 << 5),
>  	COMP_POWER		= (1 << 6),
> -	COMP_EPROM		= (1 << 7),
>  	COMP_SWBW		= (1 << 8),
>  	COMP_SEC		= (1 << 9),
>  	COMP_LPS		= (1 << 10),
> @@ -58,15 +55,12 @@ enum RTL_DEBUG {
>  	COMP_CH			= (1 << 19),
>  	COMP_RF			= (1 << 20),
>  	COMP_FIRMWARE		= (1 << 21),
> -	COMP_HT			= (1 << 22),
>  	COMP_RESET		= (1 << 23),
>  	COMP_CMDPKT		= (1 << 24),
>  	COMP_SCAN		= (1 << 25),
>  	COMP_PS			= (1 << 26),
>  	COMP_DOWN		= (1 << 27),
>  	COMP_INTR		= (1 << 28),
> -	COMP_LED		= (1 << 29),
> -	COMP_MLME		= (1 << 30),
>  	COMP_ERR		= (1 << 31)
>  };

Is it possible that this change will make future readers wonder why
there are holes in the enum values, and hence hurts readability?

Cheers,
Jakub
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1184370 — Re: [PATCH v2 04/23] staging: rtl8192e: Remove unused enums

FromMateusz Kulikowski <mateusz.kulikowski@gmail.com>
Date2015-07-15 09:10 +0200
SubjectRe: [PATCH v2 04/23] staging: rtl8192e: Remove unused enums
Message-ID<pMoZk-dQ-3@gated-at.bofh.it>
In reply to#1184369

On July 15, 2015 8:34:02 AM GMT+02:00, Jakub Sitnicki <jsitnicki@gmail.com> wrote:
>On Tue, Jul 14, 2015 at 10:04 PM CEST, Mateusz Kulikowski
><mateusz.kulikowski@gmail.com> wrote:
>> Remove ack_policy enum and some unused RTL_DEBUG enums.
>>
>> Signed-off-by: Mateusz Kulikowski <mateusz.kulikowski@gmail.com>
>> ---
>
>[snip]
>
>> diff --git a/drivers/staging/rtl8192e/rtllib_debug.h
>b/drivers/staging/rtl8192e/rtllib_debug.h
>> index 42e88d6..2f47a7c 100644
>> --- a/drivers/staging/rtl8192e/rtllib_debug.h
>> +++ b/drivers/staging/rtl8192e/rtllib_debug.h
>> @@ -40,10 +40,7 @@ enum RTL_DEBUG {
>>  	COMP_DBG		= (1 << 1),
>>  	COMP_INIT		= (1 << 2),
>>  	COMP_RECV		= (1 << 3),
>> -	COMP_SEND		= (1 << 4),
>> -	COMP_CMD		= (1 << 5),
>>  	COMP_POWER		= (1 << 6),
>> -	COMP_EPROM		= (1 << 7),
>>  	COMP_SWBW		= (1 << 8),
>>  	COMP_SEC		= (1 << 9),
>>  	COMP_LPS		= (1 << 10),
>> @@ -58,15 +55,12 @@ enum RTL_DEBUG {
>>  	COMP_CH			= (1 << 19),
>>  	COMP_RF			= (1 << 20),
>>  	COMP_FIRMWARE		= (1 << 21),
>> -	COMP_HT			= (1 << 22),
>>  	COMP_RESET		= (1 << 23),
>>  	COMP_CMDPKT		= (1 << 24),
>>  	COMP_SCAN		= (1 << 25),
>>  	COMP_PS			= (1 << 26),
>>  	COMP_DOWN		= (1 << 27),
>>  	COMP_INTR		= (1 << 28),
>> -	COMP_LED		= (1 << 29),
>> -	COMP_MLME		= (1 << 30),
>>  	COMP_ERR		= (1 << 31)
>>  };
>
>Is it possible that this change will make future readers wonder why
>there are holes in the enum values, and hence hurts readability?

It should not. This enum is used as log categories for various parts of the driver.
Some of them were just never used.

IMO once driver is ready for unstagimg this enum should be removed and replaced wih dyn debug where it makes sense.

Regards,
Mateusz

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web