Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1180664 > unrolled thread
| Started by | Michal Hocko <mhocko@kernel.org> |
|---|---|
| First post | 2015-07-09 14:10 +0200 |
| Last post | 2015-07-09 14:10 +0200 |
| Articles | 1 — 1 participant |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [PATCH 4/8] memcg, mm: move mem_cgroup_select_victim_node into vmscan Michal Hocko <mhocko@kernel.org> - 2015-07-09 14:10 +0200
| From | Michal Hocko <mhocko@kernel.org> |
|---|---|
| Date | 2015-07-09 14:10 +0200 |
| Subject | Re: [PATCH 4/8] memcg, mm: move mem_cgroup_select_victim_node into vmscan |
| Message-ID | <pKiOn-8rE-29@gated-at.bofh.it> |
On Wed 08-07-15 19:01:59, Vladimir Davydov wrote: > On Wed, Jul 08, 2015 at 02:27:48PM +0200, Michal Hocko wrote: > > From: Michal Hocko <mhocko@suse.cz> > > > > We currently have only one caller of mem_cgroup_select_victim_node which > > is sitting in mm/vmscan.c and which is already wrapped by CONFIG_MEMCG > > ifdef. Now that we have struct mem_cgroup visible outside of > > mm/memcontrol.c we can move the function and its dependencies there. > > This even shrinks the code size by few bytes: > > > > text data bss dec hex filename > > 478509 65806 26384 570699 8b54b mm/built-in.o.before > > 478445 65806 26384 570635 8b50b mm/built-in.o.after > > > > Signed-off-by: Michal Hocko <mhocko@suse.cz> > > I dislike this patch, because I don't see any reason why logic specific > to per memcg reclaim should live in the file representing the global > reclaim path. Well the idea was that mem_cgroup_select_victim_node is specific to try_to_free_mem_cgroup_pages. It is basically a split up of otherwise large function for readability. Same applies to mem_cgroup_may_update_nodemask. Having that code together makes some sense to me. On the other hand I do agree that at least test_mem_cgroup_node_reclaimable is generally reusable and so it shouldn't be in vmscan. I can move it back to memcontrol but that leaves the generated code much worse. Fair enough then, I will drop this patch. -- Michal Hocko SUSE Labs -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to top | Article view | linux.kernel
csiph-web