Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1742873

[PATCH 08/18] ecryptfs: use ARRAY_SIZE

From Jérémy Lefaure <jeremy.lefaure@lse.epita.fr>
Newsgroups linux.kernel
Subject [PATCH 08/18] ecryptfs: use ARRAY_SIZE
Date 2017-10-01 21:40 +0200
Message-ID <uvSfM-67y-31@gated-at.bofh.it> (permalink)
References <uvSfL-67y-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Using the ARRAY_SIZE macro improves the readability of the code.

Found with Coccinelle with the following semantic patch:
@r depends on (org || report)@
type T;
T[] E;
position p;
@@
(
 (sizeof(E)@p /sizeof(*E))
|
 (sizeof(E)@p /sizeof(E[...]))
|
 (sizeof(E)@p /sizeof(T))
)

Signed-off-by: Jérémy Lefaure <jeremy.lefaure@lse.epita.fr>
---
 fs/ecryptfs/crypto.c | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

diff --git a/fs/ecryptfs/crypto.c b/fs/ecryptfs/crypto.c
index 7acd57da4f14..2e78e851788e 100644
--- a/fs/ecryptfs/crypto.c
+++ b/fs/ecryptfs/crypto.c
@@ -36,6 +36,7 @@
 #include <linux/scatterlist.h>
 #include <linux/slab.h>
 #include <asm/unaligned.h>
+#include <linux/kernel.h>
 #include "ecryptfs_kernel.h"
 
 #define DECRYPT		0
@@ -884,8 +885,7 @@ static int ecryptfs_process_flags(struct ecryptfs_crypt_stat *crypt_stat,
 	u32 flags;
 
 	flags = get_unaligned_be32(page_virt);
-	for (i = 0; i < ((sizeof(ecryptfs_flag_map)
-			  / sizeof(struct ecryptfs_flag_map_elem))); i++)
+	for (i = 0; i < ARRAY_SIZE(ecryptfs_flag_map); i++)
 		if (flags & ecryptfs_flag_map[i].file_flag) {
 			crypt_stat->flags |= ecryptfs_flag_map[i].local_flag;
 		} else
@@ -922,8 +922,7 @@ void ecryptfs_write_crypt_stat_flags(char *page_virt,
 	u32 flags = 0;
 	int i;
 
-	for (i = 0; i < ((sizeof(ecryptfs_flag_map)
-			  / sizeof(struct ecryptfs_flag_map_elem))); i++)
+	for (i = 0; i < ARRAY_SIZE(ecryptfs_flag_map); i++)
 		if (crypt_stat->flags & ecryptfs_flag_map[i].local_flag)
 			flags |= ecryptfs_flag_map[i].file_flag;
 	/* Version is in top 8 bits of the 32-bit flag vector */
-- 
2.14.1

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 00/18] use ARRAY_SIZE macro Jérémy Lefaure          <jeremy.lefaure@lse.epita.fr> - 2017-10-01 21:40 +0200
  [PATCH 04/18] IB/mlx5: Use ARRAY_SIZE Jérémy Lefaure          <jeremy.lefaure@lse.epita.fr> - 2017-10-01 21:40 +0200
  [PATCH 12/18] x86: use ARRAY_SIZE Jérémy Lefaure          <jeremy.lefaure@lse.epita.fr> - 2017-10-01 21:40 +0200
  [PATCH 02/18] tracing/filter: use ARRAY_SIZE Jérémy Lefaure          <jeremy.lefaure@lse.epita.fr> - 2017-10-01 21:40 +0200
  [PATCH 16/18] media: staging: atomisp: use ARRAY_SIZE Jérémy Lefaure          <jeremy.lefaure@lse.epita.fr> - 2017-10-01 21:40 +0200
  [PATCH 06/18] drm: use ARRAY_SIZE Jérémy Lefaure          <jeremy.lefaure@lse.epita.fr> - 2017-10-01 21:40 +0200
    Re: [PATCH 06/18] drm: use ARRAY_SIZE Jani Nikula <jani.nikula@linux.intel.com> - 2017-10-02 09:50 +0200
    Re: [PATCH 06/18] drm: use ARRAY_SIZE Thierry Reding <thierry.reding@gmail.com> - 2017-10-02 10:30 +0200
  [PATCH 18/18] staging: rtlwifi: use ARRAY_SIZE Jérémy Lefaure          <jeremy.lefaure@lse.epita.fr> - 2017-10-01 21:40 +0200
  [PATCH 15/18] acpi: use ARRAY_SIZE Jérémy Lefaure          <jeremy.lefaure@lse.epita.fr> - 2017-10-01 21:40 +0200
    Re: [PATCH 15/18] acpi: use ARRAY_SIZE "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-10-02 14:40 +0200
  [PATCH 01/18] sound: use ARRAY_SIZE Jérémy Lefaure          <jeremy.lefaure@lse.epita.fr> - 2017-10-01 21:40 +0200
    Re: [PATCH 01/18] sound: use ARRAY_SIZE Joe Perches <joe@perches.com> - 2017-10-02 06:20 +0200
  [PATCH 09/18] nfsd: use ARRAY_SIZE Jérémy Lefaure          <jeremy.lefaure@lse.epita.fr> - 2017-10-01 21:40 +0200
    Re: [PATCH 09/18] nfsd: use ARRAY_SIZE Jeff Layton <jlayton@redhat.com> - 2017-10-02 13:10 +0200
  [PATCH 08/18] ecryptfs: use ARRAY_SIZE Jérémy Lefaure          <jeremy.lefaure@lse.epita.fr> - 2017-10-01 21:40 +0200
  [PATCH 03/18] media: use ARRAY_SIZE Jérémy Lefaure          <jeremy.lefaure@lse.epita.fr> - 2017-10-01 21:40 +0200
    Re: [PATCH 03/18] media: use ARRAY_SIZE Michael Ira Krufky <mkrufky@linuxtv.org> - 2017-10-02 12:40 +0200
  [PATCH 14/18] ipmi: use ARRAY_SIZE Jérémy Lefaure          <jeremy.lefaure@lse.epita.fr> - 2017-10-01 21:40 +0200
  [PATCH 07/18] scsi: bfa: use ARRAY_SIZE Jérémy Lefaure          <jeremy.lefaure@lse.epita.fr> - 2017-10-01 21:40 +0200
  [PATCH 17/18] staging: rtl8723bs: use ARRAY_SIZE Jérémy Lefaure          <jeremy.lefaure@lse.epita.fr> - 2017-10-01 21:40 +0200
  [PATCH 10/18] orangefs: use ARRAY_SIZE Jérémy Lefaure          <jeremy.lefaure@lse.epita.fr> - 2017-10-01 21:40 +0200
  [PATCH 13/18] tpm: use ARRAY_SIZE Jérémy Lefaure          <jeremy.lefaure@lse.epita.fr> - 2017-10-01 21:40 +0200
  [PATCH 11/18] dm space map metadata: use ARRAY_SIZE Jérémy Lefaure          <jeremy.lefaure@lse.epita.fr> - 2017-10-01 21:40 +0200
  Re: [PATCH 00/18] use ARRAY_SIZE macro "Tobin C. Harding" <me@tobin.cc> - 2017-10-02 00:10 +0200
    Re: [PATCH 00/18] use ARRAY_SIZE macro Jérémy Lefaure <jeremy.lefaure@lse.epita.fr> - 2017-10-02 03:00 +0200
      Re: [PATCH 00/18] use ARRAY_SIZE macro Greg KH <greg@kroah.com> - 2017-10-02 07:40 +0200
      Re: [PATCH 00/18] use ARRAY_SIZE macro Mauro Carvalho Chehab <mchehab@s-opensource.com> - 2017-10-02 22:50 +0200
  Re: [PATCH 05/18] net: use ARRAY_SIZE Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-10-02 15:10 +0200

csiph-web