Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1738721

[PATCH 2/3] iio: accel: mma8452: Rename read/write event value callbacks to generic function name.

From Harinath Nampally <harinath922@gmail.com>
Newsgroups linux.kernel
Subject [PATCH 2/3] iio: accel: mma8452: Rename read/write event value callbacks to generic function name.
Date 2017-09-25 05:20 +0200
Message-ID <uts66-zR-13@gated-at.bofh.it> (permalink)
References <uts65-zR-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


'mma8452_read_thresh' and 'mma8452_write_thresh' functions
does more than just read/write threshold values.
They also handle  IIO_EV_INFO_HIGH_PASS_FILTER_3DB and
IIO_EV_INFO_PERIOD therefore renaming to generic names.

Improves code readability, no impact on functionality.

Signed-off-by: Harinath Nampally <harinath922@gmail.com>
---
 drivers/iio/accel/mma8452.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/iio/accel/mma8452.c b/drivers/iio/accel/mma8452.c
index 74b6221..43c3a6b 100644
--- a/drivers/iio/accel/mma8452.c
+++ b/drivers/iio/accel/mma8452.c
@@ -792,7 +792,7 @@ static int mma8452_get_event_regs(struct mma8452_data *data,
 	}
 }
 
-static int mma8452_read_thresh(struct iio_dev *indio_dev,
+static int mma8452_read_event_value(struct iio_dev *indio_dev,
 			       const struct iio_chan_spec *chan,
 			       enum iio_event_type type,
 			       enum iio_event_direction dir,
@@ -855,7 +855,7 @@ static int mma8452_read_thresh(struct iio_dev *indio_dev,
 	}
 }
 
-static int mma8452_write_thresh(struct iio_dev *indio_dev,
+static int mma8452_write_event_value(struct iio_dev *indio_dev,
 				const struct iio_chan_spec *chan,
 				enum iio_event_type type,
 				enum iio_event_direction dir,
@@ -1391,8 +1391,8 @@ static const struct iio_info mma8452_info = {
 	.read_raw = &mma8452_read_raw,
 	.write_raw = &mma8452_write_raw,
 	.event_attrs = &mma8452_event_attribute_group,
-	.read_event_value = &mma8452_read_thresh,
-	.write_event_value = &mma8452_write_thresh,
+	.read_event_value = &mma8452_read_event_value,
+	.write_event_value = &mma8452_write_event_value,
 	.read_event_config = &mma8452_read_event_config,
 	.write_event_config = &mma8452_write_event_config,
 	.debugfs_reg_access = &mma8452_reg_access_dbg,
-- 
2.7.4

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 0/3] This patchset refactors event related functions  Harinath Nampally <harinath922@gmail.com> - 2017-09-25 05:20 +0200
  [PATCH 2/3] iio: accel: mma8452: Rename read/write event value callbacks to generic function name. Harinath Nampally <harinath922@gmail.com> - 2017-09-25 05:20 +0200
  [PATCH 1/3] iio: accel: mma8452: Rename time step look up struct to generic name as the values are same for all the events. Harinath Nampally <harinath922@gmail.com> - 2017-09-25 05:20 +0200
  [PATCH 3/3] iio: accel: mma8452: Add single pulse/tap event detection feature for fxls8471. Harinath Nampally <harinath922@gmail.com> - 2017-09-25 05:20 +0200
    Re: [PATCH 3/3] iio: accel: mma8452: Add single pulse/tap event  detection feature for fxls8471. Martin Kepplinger <martink@posteo.de> - 2017-09-25 08:40 +0200
  Re: [PATCH 0/3] This patchset refactors event related functions Martin Kepplinger <martink@posteo.de> - 2017-09-25 08:30 +0200

csiph-web