Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1737310

Re: [PATCH net-next RFC 2/5] vhost: introduce helper to prefetch desc index

From Stefan Hajnoczi <stefanha@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH net-next RFC 2/5] vhost: introduce helper to prefetch desc index
Date 2017-09-22 11:10 +0200
Message-ID <uss8b-4hz-47@gated-at.bofh.it> (permalink)
References <usrc5-3JR-5@gated-at.bofh.it> <usrc5-3JR-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Fri, Sep 22, 2017 at 04:02:32PM +0800, Jason Wang wrote:
> diff --git a/drivers/vhost/vhost.c b/drivers/vhost/vhost.c
> index f87ec75..8424166d 100644
> --- a/drivers/vhost/vhost.c
> +++ b/drivers/vhost/vhost.c
> @@ -2437,6 +2437,61 @@ struct vhost_msg_node *vhost_dequeue_msg(struct vhost_dev *dev,
>  }
>  EXPORT_SYMBOL_GPL(vhost_dequeue_msg);
>  
> +int vhost_prefetch_desc_indices(struct vhost_virtqueue *vq,
> +				struct vring_used_elem *heads,
> +				u16 num, bool used_update)

Missing doc comment.

> +{
> +	int ret, ret2;
> +	u16 last_avail_idx, last_used_idx, total, copied;
> +	__virtio16 avail_idx;
> +	struct vring_used_elem __user *used;
> +	int i;

The following variable names are a little confusing:

last_avail_idx vs vq->last_avail_idx.  last_avail_idx is a wrapped
avail->ring[] index, vq->last_avail_idx is a free-running counter.  The
same for last_used_idx vs vq->last_used_idx.

num argument vs vq->num.  The argument could be called nheads instead to
make it clear that this is heads[] and not the virtqueue size.

Not a bug but it took me a while to figure out what was going on.

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH net-next RFC 2/5] vhost: introduce helper to prefetch desc index Jason Wang <jasowang@redhat.com> - 2017-09-22 10:10 +0200
  Re: [PATCH net-next RFC 2/5] vhost: introduce helper to prefetch  desc index Stefan Hajnoczi <stefanha@gmail.com> - 2017-09-22 11:10 +0200
    Re: [PATCH net-next RFC 2/5] vhost: introduce helper to prefetch desc  index Jason Wang <jasowang@redhat.com> - 2017-09-25 04:10 +0200

csiph-web