Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1737168
| From | Masahiro Yamada <yamada.masahiro@socionext.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH v2 02/12] mtd: nand: denali: prefix detect_max_banks() with denali_ |
| Date | 2017-09-22 06:00 +0200 |
| Message-ID | <usni9-1cy-3@gated-at.bofh.it> (permalink) |
| References | <usn8t-19x-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
All functions in this driver are prefixed with denali_
except detect_max_banks(). Rename it for consistency.
Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
---
Changes in v2: None
drivers/mtd/nand/denali.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/mtd/nand/denali.c b/drivers/mtd/nand/denali.c
index d847ae4..48193f9 100644
--- a/drivers/mtd/nand/denali.c
+++ b/drivers/mtd/nand/denali.c
@@ -81,7 +81,7 @@ static void denali_host_write(struct denali_nand_info *denali,
* Use the configuration feature register to determine the maximum number of
* banks that the hardware supports.
*/
-static void detect_max_banks(struct denali_nand_info *denali)
+static void denali_detect_max_banks(struct denali_nand_info *denali)
{
uint32_t features = ioread32(denali->reg + FEATURES);
@@ -1115,7 +1115,7 @@ static void denali_hw_init(struct denali_nand_info *denali)
* if this value is 0, just let it be.
*/
denali->oob_skip_bytes = ioread32(denali->reg + SPARE_AREA_SKIP_BYTES);
- detect_max_banks(denali);
+ denali_detect_max_banks(denali);
iowrite32(0x0F, denali->reg + RB_PIN_ENABLED);
iowrite32(CHIP_EN_DONT_CARE__FLAG, denali->reg + CHIP_ENABLE_DONT_CARE);
--
2.7.4
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v2 00/12] mtd: nand: denali: more clean-ups Masahiro Yamada <yamada.masahiro@socionext.com> - 2017-09-22 05:50 +0200 [PATCH v2 11/12] mtd: nand: denali: support direct addressing mode Masahiro Yamada <yamada.masahiro@socionext.com> - 2017-09-22 05:50 +0200 [PATCH v2 05/12] mtd: nand: denali: slight clean up of denali_wait_for_irq() Masahiro Yamada <yamada.masahiro@socionext.com> - 2017-09-22 05:50 +0200 [PATCH v2 10/12] mtd: nand: denali: remove unneeded init of ECC_ENABLE register Masahiro Yamada <yamada.masahiro@socionext.com> - 2017-09-22 05:50 +0200 [PATCH v2 07/12] mtd: nand: denali: use more FIELD_PREP / FIELD_GET where appropriate Masahiro Yamada <yamada.masahiro@socionext.com> - 2017-09-22 06:00 +0200 [PATCH v2 02/12] mtd: nand: denali: prefix detect_max_banks() with denali_ Masahiro Yamada <yamada.masahiro@socionext.com> - 2017-09-22 06:00 +0200 [PATCH v2 06/12] mtd: nand: denali: clean up macros with <linux/bitfield.h> Masahiro Yamada <yamada.masahiro@socionext.com> - 2017-09-22 06:00 +0200 [PATCH v2 09/12] mtd: nand: denali: use upper/lower_32_bits() macro for clean-up Masahiro Yamada <yamada.masahiro@socionext.com> - 2017-09-22 06:00 +0200 [PATCH v2 08/12] mtd: nand: denali: clean up comments Masahiro Yamada <yamada.masahiro@socionext.com> - 2017-09-22 06:00 +0200 Re: [PATCH v2 00/12] mtd: nand: denali: more clean-ups Boris Brezillon <boris.brezillon@free-electrons.com> - 2017-09-22 12:10 +0200
csiph-web