Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1731344
| From | "jianchao.wang" <jianchao.w.wang@oracle.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] blk-mq: put the driver tag of nxt rq before first one is requeued |
| Date | 2017-09-13 04:50 +0200 |
| Message-ID | <up5Ut-1pM-5@gated-at.bofh.it> (permalink) |
| References | (1 earlier) <uoQC6-8vg-11@gated-at.bofh.it> <up4lI-wf-11@gated-at.bofh.it> <up4F4-El-3@gated-at.bofh.it> <up4Yp-KK-7@gated-at.bofh.it> <up5B8-1jr-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 09/13/2017 10:23 AM, Jens Axboe wrote:
> On 09/12/2017 07:39 PM, jianchao.wang wrote:
>>
>>
>> On 09/13/2017 09:24 AM, Ming Lei wrote:
>>> On Wed, Sep 13, 2017 at 09:01:25AM +0800, jianchao.wang wrote:
>>>> Hi ming
>>>>
>>>> On 09/12/2017 06:23 PM, Ming Lei wrote:
>>>>>> @@ -1029,14 +1029,20 @@ bool blk_mq_dispatch_rq_list(struct request_queue *q, struct list_head *list)
>>>>>> if (list_empty(list))
>>>>>> bd.last = true;
>>>>>> else {
>>>>>> - struct request *nxt;
>>>>>> -
>>>>>> nxt = list_first_entry(list, struct request, queuelist);
>>>>>> bd.last = !blk_mq_get_driver_tag(nxt, NULL, false);
>>>>>> }
>>>>>>
>>>>>> ret = q->mq_ops->queue_rq(hctx, &bd);
>>>>>> if (ret == BLK_STS_RESOURCE) {
>>>>>> + /*
>>>>>> + * If an I/O scheduler has been configured and we got a
>>>>>> + * driver tag for the next request already, free it again.
>>>>>> + */
>>>>>> + if (!list_empty(list)) {
>>>>>> + nxt = list_first_entry(list, struct request, queuelist);
>>>>>> + blk_mq_put_driver_tag(nxt);
>>>>>> + }
>>>>> The following way might be more simple and clean:
>>>>>
>>>>> if (nxt)
>>>>> blk_mq_put_driver_tag(nxt);
>>>>>
>>>>> meantime 'nxt' need to be cleared inside the 'if (list_empty(list))'
>>>>> before .queue_rq().
>>>>
>>>> I had ever thought about that, but to avoid add extra command in the
>>>> fast path, I made the patch above.
>>>
>>> Got it, so how about changing to the following way simply:
>>>
>>> if (nxt && !list_empty(list))
>>> blk_mq_put_driver_tag(nxt);
>>>
>> It seems that we even could change it as following:
>> if (!list_empty(list))
>> blk_mq_put_driver_tag(nxt);
>
> This is starting to get too clever for its own good, I generally don't
> like to sacrifice readability for performance. In reality, the compiler
> probably figures it out anyway...
>
> So either make it explicit, or add a nice comment as to why it is the
> way that it is.
>
yes, it indeed leads to compiler warning of "may be used uninitialized"
maybe the original one could be taken back.
if (!list_empty(list)) {
nxt = list_first_entry(list, struct request, queuelist);
blk_mq_put_driver_tag(nxt);
}
It is more readable and could avoid the warning.
Thanks
jianchao
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] blk-mq: put the driver tag of nxt rq before first one is requeued Jianchao Wang <jianchao.w.wang@oracle.com> - 2017-09-12 11:20 +0200
Re: [PATCH] blk-mq: put the driver tag of nxt rq before first one is requeued Ming Lei <ming.lei@redhat.com> - 2017-09-12 12:30 +0200
Re: [PATCH] blk-mq: put the driver tag of nxt rq before first one is requeued "jianchao.wang" <jianchao.w.wang@oracle.com> - 2017-09-13 03:10 +0200
Re: [PATCH] blk-mq: put the driver tag of nxt rq before first one is requeued Ming Lei <ming.lei@redhat.com> - 2017-09-13 03:30 +0200
Re: [PATCH] blk-mq: put the driver tag of nxt rq before first one is requeued "jianchao.wang" <jianchao.w.wang@oracle.com> - 2017-09-13 03:50 +0200
Re: [PATCH] blk-mq: put the driver tag of nxt rq before first one is requeued Ming Lei <ming.lei@redhat.com> - 2017-09-13 04:00 +0200
Re: [PATCH] blk-mq: put the driver tag of nxt rq before first one is requeued Jens Axboe <axboe@kernel.dk> - 2017-09-13 04:30 +0200
Re: [PATCH] blk-mq: put the driver tag of nxt rq before first one is requeued "jianchao.wang" <jianchao.w.wang@oracle.com> - 2017-09-13 04:50 +0200
Re: [PATCH] blk-mq: put the driver tag of nxt rq before first one is requeued Jens Axboe <axboe@kernel.dk> - 2017-09-13 04:50 +0200
Re: [PATCH] blk-mq: put the driver tag of nxt rq before first one is requeued "jianchao.wang" <jianchao.w.wang@oracle.com> - 2017-09-13 05:40 +0200
Re: [PATCH] blk-mq: put the driver tag of nxt rq before first one is requeued Jens Axboe <axboe@kernel.dk> - 2017-09-13 06:00 +0200
Re: [PATCH] blk-mq: put the driver tag of nxt rq before first one is requeued "jianchao.wang" <jianchao.w.wang@oracle.com> - 2017-09-13 06:00 +0200
Re: [PATCH] blk-mq: put the driver tag of nxt rq before first one is requeued Ming Lei <ming.lei@redhat.com> - 2017-09-13 06:00 +0200
csiph-web